cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5111
Views
0
Helpful
2
Replies

Delete class from existing policy-map ?

wmtski666
Level 1
Level 1

How do you delete a class from an existing policy map?  For, example, if I have:

class-map match-all telnet-class

  match access-group 102

class-map match-all voice-class

  match access-group 103

!

policy-map voip-telnet-outbound

class voice-class

  priority 100

class telnet-class

  bandwidth percent 30

!

access-list 102 permit tcp any any eq telnet

access-list 103 permit ip 192.168.230.0 0.0.0.255 any

... and I want to delete the voice-class from the voip-telnet-outbound policy, what command would do that?

And, once it is deleted, would the changes automagically apply to any interfaces that voip-telnet-outbound is applied to?  Or, would I need to do another "service-policy output voip-telnet-outbound" command on the interfaces?  Or would I need to do something like shut the interface down and then restart it?  Or something else?

I tried "no class voice-class" when configuring the voip-telnet-outbound policy-map, but it didn't do anything.

2 Replies 2

Edison Ortiz
Hall of Fame
Hall of Fame

IOS and platform, please.

I tried here on 7200 with 12.4(15)T17 and it worked as expected

class-map match-all voice-class

match access-group 103

class-map match-all telnet-class

match access-group 102

!

!

policy-map voip-telnet-outbound

class voice-class

  priority 100

class telnet-class

  bandwidth percent 30

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

service-policy output voip-telnet-outbound

!

R1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#policy-map voip-telnet-outbound

R1(config-pmap)#no class voice-class

class-map match-all voice-class

match access-group 103

class-map match-all telnet-class

match access-group 102

!

!

policy-map voip-telnet-outbound

class telnet-class

  bandwidth percent 30

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

service-policy output voip-telnet-outbound

conf t

policy-map voip-telnet-outbound

no class voice-class

Review Cisco Networking for a $25 gift card