cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
824
Views
4
Helpful
4
Replies

Eigrp and variance values

robert
Level 1
Level 1

Hi

I´m just starting to learn eigrp and have a question with the variance values when load balancing.

I have 2 routers, R1 and R2, and they have communication to each other via 2 vlans.

R1:

interface Loopback1

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet0/0

description WAN

ip address 33.33.33.1 255.255.255.0

ip ospf authentication message-digest

ip ospf authentication-key password

duplex auto

speed auto

no cdp enable

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 1 native

ip address 10.1.1.101 255.255.255.0

!

interface FastEthernet0/1.2

encapsulation dot1Q 2

ip address 10.2.1.101 255.255.255.0

router eigrp 5050

network 33.33.33.0 0.0.0.255

network 10.1.1.0 0.0.0.255

network 10.2.1.0 0.0.0.255

no auto-summary

R2:

interface Loopback1

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip address 17.17.17.1 255.255.255.0

ip ospf authentication message-digest

ip ospf authentication-key password

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 1 native

ip address 10.1.1.100 255.255.255.0

!

interface FastEthernet0/1.2

encapsulation dot1Q 2

ip address 10.2.1.100 255.255.255.0

router eigrp 5050

variance 2

network 17.17.17.0

network 10.1.1.0 0.0.0.255

network 10.2.1.0 0.0.0.255

no auto-summary

If I set variance to 2 on R1 it will update it´s routing table to 17.17.17.0 with 2 entries (routing through 10.1.1.0 and 10.2.1.0) so I´ll load balance traffic going to this destination. But will it work it variance is set to default=1 on R2 ?

Then only one end is load balancing. Is this valid?

Regards

Robert

2 Accepted Solutions

Accepted Solutions

cadet alain
VIP Alumni
VIP Alumni

Hi,

R1 should have 2 routes to 17.17.17.0 without the variance command as these 2 paths should have same FD so they should be considered as 2 successors.What variance does is install unequal cost routes in the RIB provided

1st the feasibility condition must be met that is the second route must be considered as feasible successor( RD < FD of successor)

2nd the FD of FS * Variance <= FD of successor

Then the switching process will take care of the load sharing but it is only one way of course.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

Cadet Alain is correct- even without the variance command you should have two paths back to 17.17.17.0/24 in your route table.

But let say you have unequal costs - then you will have only one path back to 17.17.17.0/24 as the composite metric in eigrp will be different and eigrp it will take the lowest value.

You can view this metric ( lets say from R1(  by “ sh ip eigrp topology 17.17.17.0/24” – this will show you all the metrics for all links to this network

EG (143360/128256) – these metrics are linked to the feasible successor Cadat Alain has mentioned.

The 1st  metric calculated from R1 to destination

The 2nd metric is advertised by the neighbour.(R2)

For unequal cost load balancing - you can use the variance command -
Divide the highest and lowest composite metric for your network (in this case 17.17.17.0/24) - lets say 156160/143360 =1.089
round this up to the nearest whole value = 2

Both RTR
router eigrp 5050
variance 2

You should then see both paths populated in the route table with the two different composite metrics.

Res

Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

4 Replies 4

Abzal
Level 7
Level 7

Hi,

What is connected on R2 on 10.1.1.100? Post here your network diagram. It's still not clear .

Best regards,

Abzal

Best regards,
Abzal

cadet alain
VIP Alumni
VIP Alumni

Hi,

R1 should have 2 routes to 17.17.17.0 without the variance command as these 2 paths should have same FD so they should be considered as 2 successors.What variance does is install unequal cost routes in the RIB provided

1st the feasibility condition must be met that is the second route must be considered as feasible successor( RD < FD of successor)

2nd the FD of FS * Variance <= FD of successor

Then the switching process will take care of the load sharing but it is only one way of course.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Cadet Alain is correct- even without the variance command you should have two paths back to 17.17.17.0/24 in your route table.

But let say you have unequal costs - then you will have only one path back to 17.17.17.0/24 as the composite metric in eigrp will be different and eigrp it will take the lowest value.

You can view this metric ( lets say from R1(  by “ sh ip eigrp topology 17.17.17.0/24” – this will show you all the metrics for all links to this network

EG (143360/128256) – these metrics are linked to the feasible successor Cadat Alain has mentioned.

The 1st  metric calculated from R1 to destination

The 2nd metric is advertised by the neighbour.(R2)

For unequal cost load balancing - you can use the variance command -
Divide the highest and lowest composite metric for your network (in this case 17.17.17.0/24) - lets say 156160/143360 =1.089
round this up to the nearest whole value = 2

Both RTR
router eigrp 5050
variance 2

You should then see both paths populated in the route table with the two different composite metrics.

Res

Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Super, thanks to all.

Your are correct, both routes exist in the routing table as they have equel cost. So what I learned:

a. equal cost routes is automatic added to routing table

b. variance is only nessesary when I have unequal cost for my routes

robert

Review Cisco Networking products for a $25 gift card