02-16-2024 09:44 AM - last edited on 02-18-2024 10:04 PM by Translator
Hello guys,
I have 2 routers that are connected to each other through interface G0/0. Before EIGRP authentication was configured, they could see each other as EIGRP neighbors. The moment I put in authentication on both routers' interfaces G0/0, the EIGRP neighbor ship drops. Do you see any issue with the routers' authentication?
Router 1:
key chain My_KEY_CHAIN
key 1
key-string MY_KEY_STRING
!
interface GigabitEthernet0/0
ip address 10.1.12.1 255.255.255.252
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 MY_KEY_CHAIN
duplex auto
speed auto
media-type rj45
end
router eigrp 1
network 10.1.12.0 0.0.0.3
network 10.1.13.0 0.0.0.3
R1#
============
Router 2:
key chain My_KEY_CHAIN
key 1
key-string MY_KEY_STRING
!
interface GigabitEthernet0/0
ip address 10.1.12.2 255.255.255.252
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 MY_KEY_CHAIN
duplex auto
speed auto
media-type rj45
end
!
router eigrp 1
network 10.1.12.0 0.0.0.3
network 10.1.23.0 0.0.0.3
R2#
Thanks
Solved! Go to Solution.
02-16-2024 09:49 AM
only add lifetime into both router,
and if you can match time learn via NTP, this key is sensitive to time
MHM
02-16-2024 09:53 AM - last edited on 02-18-2024 10:07 PM by Translator
not that i remember this is case senstive - check and replace with right case senstive :
My_KEY_CHAIN
also enable debug :
debug eigrp packets
02-16-2024 09:49 AM
only add lifetime into both router,
and if you can match time learn via NTP, this key is sensitive to time
MHM
02-16-2024 09:53 AM - last edited on 02-18-2024 10:07 PM by Translator
not that i remember this is case senstive - check and replace with right case senstive :
My_KEY_CHAIN
also enable debug :
debug eigrp packets
02-16-2024 10:08 AM - last edited on 02-18-2024 10:07 PM by Translator
Yes, it was case sensitive. I'm able to bring back neighbor ship between 2 routers after corrected
MY_KEY_CHAIN
. Thanks.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide