08-28-2005 07:24 AM - edited 03-03-2019 10:22 AM
Hi all
Let's say I enable EIGRP on my router with
router eigrp 900
network 10.0.0.0
no auto summary
the router has 5 WAN interfaces with IP addresses coresponding to subnets of 172.26.1.0/24 using 30 bits for masking.
The two ethernet interfaces have IP addresses coresponding to subnets of 10.0.255.0/24 using 30 bits for masking.
At this moment my understanding is that the EIGRP is enabled on all interfaces and 10.0.0.0 will be anounced on all of them. Is this correct ?
One of my coleagues is saying that in order to activate EIGRP on one interface you have to declare the network that the interface belongs to in EIGRP or to declare larger one.
I also think that the 10.0.0.0 route is propageted on interfaces which belong to 172.26.1.0 without any aditional statements. Is this corect ?
*************************
Now let's say I have a few D subnets in 10.0.255.0/24 and a few C subnets for 10.100.0.0/16
The D subnets are used for WAN interfaces the C subnets are user for LANs
No auto-summary and manual aggregation (using network statements)
The WAN router is configured like this:
router EIGRP 700
network 10.0.0.0
no auto summary
The Ethernet router facing the WAN router is configured like this:
router EIGRP 700
network 10.0.0.0
no auto summary
I know that it works and the subnets are corectly propagated. What I want to understand is what will be the advantage or disadvantage of declaring all the subnets on each router (using the wildcard mask)
Ex for the Ethernet router:
router EIGRP 700
network 10.100.1.0 0.0.0.255
network 10.100.2.0 0.0.0.255
network 10.100.3.0 0.0.0.255
....
no auto summary
I know that the first situation (10.0.0.0) will save a lot of work but not sure if the EIGPR performance is not impacted.
Thank you
Cristian
08-28-2005 08:21 AM
To answer your first question, no!
the "network 10.0.0.0" will enable EIGRP on those interfaces that uses 10.x.x.x only, but will also start advertising those networks to its neighbors.
In case you don't want EIGRP running on an interface, but still ned to advertise the subnet, use the passive-interface command. Like this:
router eigrp 700
passive-interface Ethernet0
network 172.26.1.0 0.0.0.255
Try issuing the "sh ip eigrp interface" and you'll see which interfaces are running EIGRP.
08-28-2005 05:54 PM
Cristian
I believe that Teddy is quite right in his answer. If you enter the network statement network 10.0.0.0 and do not have a network statement 172.16.0.0 then the interfaces in 172.16.0.0 will not participate in that EIGRP. And he is correct that the show ip eigrp interface is a very helpful command to verify and understand this function.
He did not address the other part of your question and I will do that here. Your question had two parts 1) what are advantages and disadvantages of specifying network statement with netmask, and 2) is EIGRP performance affected. You are correct that using just network 10.0.0.0 is easier and saves configuration work instead of specifying multiple network statements with netmask. Using network statements with netmask gives you the capability of including some interfaces into EIGRP and not including other interfaces. There might be some security issue or some policy reason that you want most interfaces in 10.0.0.0 to be included in EIGRP but have one (or more) interfaces which you do not want to include in EIGRP. Using the netmask option will allow you to do this. So the advantage of no netmask is easier configuration. And the advantage of using netmask is greater control and more granularity in controlling your configuration.
EIGRP performance is not affected by which way you configure the network statements. The network statement is used to specify which interfaces EIGRP will include in the protocol. After it resolves which interfaces to include the performance is exactly the same.
HTH
Rick
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide