cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
179
Views
0
Helpful
2
Replies
carl_townshend
Frequent Contributor

Enabling bfd for ospf on vlans

Hi all

we have ospf setup between our sites and I am looking to enable bfd to help speed up ospf convergence.

at present we use layer 3 svi’s for the routing and not l3 physical interfaces.

Where do we put the bfd interval and timers etc? Do we enable these on the layer 3 svi I.e the vlan interface?

what are the recommended timers?

cheers

1 ACCEPTED SOLUTION

Accepted Solutions
balaji.bandi
VIP Master

High level You can enable in SVI Interface BFD and also in OSPF config BFD interface all

 

Since we do not know the device model and IOS here, make sure you read the release notes for supported IOs and devices.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post

2 REPLIES 2
balaji.bandi
VIP Master

High level You can enable in SVI Interface BFD and also in OSPF config BFD interface all

 

Since we do not know the device model and IOS here, make sure you read the release notes for supported IOs and devices.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post

Georg Pauwen
VIP Expert

Hello,

 

basically, you have two options: option 1 is to enable BFD under the routing process. Option 2 is to enable BFD on individual interfaces. The typical timer values are included in the examples below:

 

Option 1

 

interface Vlan 10
ip address 192.168.10.1 255.255.255.0
--> bfd interval 50 min_rx 50 multiplier 3
!
router ospf 1
log-adjacency-changes detail
network 192.168.10.0 0.0.0.255 area 0
--> bfd all-interfaces

 

Option 2

 

interface Vlan 10
ip address 192.168.10.1 255.255.255.0
--> ip ospf bfd
--> bfd interval 50 min_rx 50 multiplier 3
!
router ospf 1
log-adjacency-changes detail
network 192.168.10.0 0.0.0.255 area 0