cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
64
Views
0
Helpful
3
Replies
Beginner

fail over probe? 1921 router only fails over if primary link goes down

I followed the cisco router dual WAN failover guide at http://docwiki.cisco.com/wiki/NAT_failover_with_DUAL_ISP_on_a_router_Configuration_Example

If I remove the ethernet cable or shutdown interface Gi0/1 or the modem that is its gateway reboots or powers down, the router fails over to Gi0/0/0

However, if the link stays up but the modem's access to the internet goes down, failover does not occur and 

I've seen this problem with failover on Sonicwall firewalls if there is not probe to test the actual internet connection itself. Is there anything like this that that I can setup on the 1921 router?

Here's my configurations for WAN and NAT overload

interface GigabitEthernet0/1
description Comcast WAN link
bandwidth 100000
ip address 96.x.x.xx0 255.255.255.240
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/0/0
description Integra WAN link
bandwidth 100000
ip address 68.x.x.x8 255.255.255.252
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto

!

ip nat inside source route-map isp1 interface GigabitEthernet0/1 overload
ip nat inside source route-map isp2 interface GigabitEthernet0/0/0 overload

ip route 0.0.0.0 0.0.0.0 96.x.x.xx4
ip route 0.0.0.0 0.0.0.0 68.x.x.x7 10

access-list 100 remark == [Control NAT Service]==
access-list 100 permit ip 10.1.10.0 0.0.0.255 any
access-list 100 permit ip 10.1.20.0 0.0.0.255 any
access-list 100 permit ip 192.168.30.0 0.0.0.255 any

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Enthusiast

Hi,

Hi,

You need to configure "Enhanced Object Tracking" (this link refers to 3750 switches but gives a good overview: 
http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750x_3560x/software/release/12-2_55_se/configuration/guide/3750xscg/sweot.html#pgfId-1082302 

See the section on "Configuring Static Routing Support"

Beginner

you have to configure the

you have to configure the IPSLA to proper fail over operation & What types of License do you have installed in 1921router

3 REPLIES 3
Highlighted
Enthusiast

Hi,

Hi,

You need to configure "Enhanced Object Tracking" (this link refers to 3750 switches but gives a good overview: 
http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750x_3560x/software/release/12-2_55_se/configuration/guide/3750xscg/sweot.html#pgfId-1082302 

See the section on "Configuring Static Routing Support"

Beginner

Thanks guys,

Thanks guys,

Sorry that I never updated this. For the 1921 I needed the datak9 license. As the first answer points out, I needed IP SLA. This allowed me to setup tracks for the main route (as second answer points out); the first track I setup pings out to 8.8.8.8. If that fails (if google dns fails), I ping the ISP dns server on the track 2. If that fails, it goes to my failover route that I already setup. 

EDIT: I used this external guide to help me with the first track. Then the second track was simple enough: http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/813-cisco-router-ipsla-basic.html

Beginner

you have to configure the

you have to configure the IPSLA to proper fail over operation & What types of License do you have installed in 1921router

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards