cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
817
Views
15
Helpful
6
Replies

forward external dynamic ip:port to internal ip:port on isr series 1100

ino
Beginner
Beginner

how do i forward a port from an external dynamic ip

if some one could give me an example? 

 

ip nat inside source static tcp 10.10.10.10 123 1.2.3.4 321

this if i am not wrong would forward calls to my external ip 1.2.3.4:321 to an internal 10.10.10.10:123 ip

how can i

dynamic_ip:321 --> 10.10.10.10:123

and for completeness

10.10.10.10:123 --> dynamic_ip:654 --> internet

10.10.10.10:123 --> dynamic_ip:what ever is free --> internet

 

this is my current config which works so fare

 

Router(config)#interface cellular 0/2/0
Router(config-if)#ip address negotiated
Router(config-if)#dialer in-band
Router(config-if)#dialer-group 1
Router(config-if)#ip nat outside
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#dialer-list 1 protocol ip permit
Router(config)#ip route 0.0.0.0 0.0.0.0 cellular 0/2/0
Router(config)#interface vlan1
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#exit

Router(config)#ip access-list extended NAT
Router(config-ext-nacl)#permit ip 10.10.10.0 0.0.0.255 any
Router(config-ext-nacl)#exit

Router(config)#$ip nat inside source list NAT interface cellular 0/2/0 overload

 

device c1111-p4lteea

 

i am totally new to ios and the above config took me 2 days

so if some one could lent me a hand

 

cheers rick

 

1 Accepted Solution

Accepted Solutions

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

static NAT with dynamic IP addresses (such as in your case Cellular 0/2/0 with ip address negotiated) would look like this:

 

ip nat inside source static tcp 10.10.10.10 123 interface Cellular 0/2/0 321

View solution in original post

6 Replies 6

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

static NAT with dynamic IP addresses (such as in your case Cellular 0/2/0 with ip address negotiated) would look like this:

 

ip nat inside source static tcp 10.10.10.10 123 interface Cellular 0/2/0 321

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

 

below example works for you ?

 

ip nat inside source static tcp 10.10.10.10 123 interface cellular 0/2/0  321

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

ino
Beginner
Beginner

hmmm till now i tried with cisco packet tracer 

now i took the time and tried it on an actual c1111 on the real device it accepts the command

i cant test if it works or not as there is no sim installed in the moment and i wont get to the device location till tomorrow 

but it looks promising 

 

my confusion and inability to figure it out came from the packet tracer not accepting such commands 

question why cant i enter this in packet tracer (using a gi0/0/0 instead of cell) 

packet tracer in general dont seems to accept an interface in this place

 

Router(config)#ip nat inside source static tcp 10.10.10.10 123 interfac?

% Unrecognized command

 

cheers rick

 

 

Hello,

 

Packet Tracer does not feature full IOS versions, but only a subset of commands required to accomplish predetermined tasks.

 

The command works on every 'real' router.

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

i am not an expert on that tool - in the real-world it should work as expected.

 

or look below video may help :

 

https://www.youtube.com/watch?v=hGyNiveOlUs

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

ino
Beginner
Beginner

have tested it

ip nat inside source static tcp 10.10.10.10 123 interface Cellular 0/2/0 321

working fine

what isnt clear why 

inside source --> Cellular 

from a general logic this should mean if the device whit the ip 10.10.10.10 from port 123 sends something route it trough cellular 123

and not if you receive something on cell port 123 route it to 10.10.10.10

 

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers