cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1341
Views
0
Helpful
9
Replies

Having issues with a troubleshooting lab

jackcage72
Level 1
Level 1

My team and I are having issues getting this configuration to work.  Can anyone help me find where we went wrong?  We are using a 2811 Cisco router in class and the DHCP is not working.  All other configurations for the other 2 routers are working but those were the easy ones.

Here is the command structure:

Frame relay

DHCP

HDLC

NAT

Sub interfaces

no VLAN on this router or Loopbacks

The LA and SEA routers configs work just fine.

ABQ Router::

en

config t

enable secret cisco

line con 0

password bob

login

line vty 0 4

password BOB

login

int s0/0/0

encapsulation frame-relay

ip summary-address eigrp 50 192.168.1.0 255.255.255.192

clock rate 64000

frame-relay intf-type dce

int s0/0/1

encapsulation frame-relay

ip summary-address eigrp 50 192.168.2.0 255.255.255.252

no keepalive

interface Serial0/0/1.102 point-to-point

description WAN CONNECTION TO LA 102

ip address 192.168.3.1 255.255.255.0

no keepalive

frame-relay interface-dlci 102

no shut

int s0/0/1.103 point-to-point

frame-relay interface-dlci 103 point-to-point

description WAN CONNECTION TO SEA DLCI 103

ip address 192.168.2.1 255.255.255.0

frame-relay interface-dlci 103

no keepalive

int f0/0.64

encapsulation dot1q 64

ip nat inside

ip address 192.168.1.65 255.255.255.192

int f0/0.128

encapsulation dot1q 128

ip nat inside

ip address 192.168.1.129 255.255.255.192

int f0/0.192

encapsulation dot1q 192

ip nat inside

ip address 192.168.1.193 255.255.255.192

exit

ip dhcp excluded-address 192.168.1.64 192.168.1.65

ip dhcp excluded-address 192.168.1.128 192.168.1.129

ip dhcp excluded-address 192.168.1.192 192.168.1.193

ip dhcp excluded-address 192.168.1.10

ip dhcp pool ABQ

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 8.8.8.8

ip dhcp pool LA

network 192.168.8.0 255.255.255.0

default-router 192.168.5.1

dns-server 8.8.8.8

ip dhcp pool SEA

network 192.168.16.0 255.255.255.0

default-router 192.168.6.1

dns-server 8.8.8.8

int f0/1

ip address 10.10.50.1 255.255.255.252

ip nat outside

router eigrp 50

network 192.168.1.0 0.0.0.63

network 192.168.2.0

network 192.168.3.0

no auto-summary

ip nat inside source list 1 interface FastEthernet0/1 overload

access-list 1 permit 192.168.0.0 0.0.31.255

exit

5 Accepted Solutions

Accepted Solutions

turnera
Level 1
Level 1

Look over your DHCP pool configuration again. You have things misconfigured here.

ip dhcp pool ABQ

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 8.8.8.8

ip dhcp pool LA

network 192.168.8.0 255.255.255.0

default-router 192.168.5.1

dns-server 8.8.8.8

ip dhcp pool SEA

network 192.168.16.0 255.255.255.0

default-router 192.168.6.1

dns-server 8.8.8.8

View solution in original post

Please note the subnet for your 3 vlans namely 64,128,192 and check how the pools are configured they are in all different Network and doesnt match the same network of the VLANs.

hence the requests coming from the clients in these vlans will not reach the pool(DHCP server) for it to assign the ip addresss

Hence please rework the network under DHCP pool with proper Subnet mask matching same as those of vlans configured

Reply if it helps

View solution in original post

hello Joseph
where are the recipients for the dhcp - if over the F/R you may need a dhcp relay ( ip helper- address)

Res
paul

Sent from Cisco Technical Support iPad App


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

Joseph,

Here are a couple of examples. Maybe you can see where your problem lies in comparing these with yours.

ip dhcp pool dev-pool

import all

network 172.27.54.0 255.255.255.128

default-router 172.27.54.1

dns server x.x.x.x y.y.y.y

ip dhcp pool prod-pool

import all

network 172.27.54.128 255.255.255.128

default-router 172.27.54.129

dns server x.x.x.x y.y.y.y

In my scenario, I have a couple of vlans configured as well:

vlan 54

ip address 172.27.54.1 255.255.255.128

vlan 128

ip address 172.27.54.129 255.255.255.128

Hope these examples guide you to your answer.

View solution in original post

Hello

Are your clients on these vlans ?

Res
Pauli

Sent from Cisco Technical Support iPad App


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

9 Replies 9

turnera
Level 1
Level 1

Look over your DHCP pool configuration again. You have things misconfigured here.

ip dhcp pool ABQ

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 8.8.8.8

ip dhcp pool LA

network 192.168.8.0 255.255.255.0

default-router 192.168.5.1

dns-server 8.8.8.8

ip dhcp pool SEA

network 192.168.16.0 255.255.255.0

default-router 192.168.6.1

dns-server 8.8.8.8

jackcage72
Level 1
Level 1

Can you point me in the right direction? What ip is wrong?

Please note the subnet for your 3 vlans namely 64,128,192 and check how the pools are configured they are in all different Network and doesnt match the same network of the VLANs.

hence the requests coming from the clients in these vlans will not reach the pool(DHCP server) for it to assign the ip addresss

Hence please rework the network under DHCP pool with proper Subnet mask matching same as those of vlans configured

Reply if it helps

Joseph,

Here are a couple of examples. Maybe you can see where your problem lies in comparing these with yours.

ip dhcp pool dev-pool

import all

network 172.27.54.0 255.255.255.128

default-router 172.27.54.1

dns server x.x.x.x y.y.y.y

ip dhcp pool prod-pool

import all

network 172.27.54.128 255.255.255.128

default-router 172.27.54.129

dns server x.x.x.x y.y.y.y

In my scenario, I have a couple of vlans configured as well:

vlan 54

ip address 172.27.54.1 255.255.255.128

vlan 128

ip address 172.27.54.129 255.255.255.128

Hope these examples guide you to your answer.

Hello

Are your clients on these vlans ?

Res
Pauli

Sent from Cisco Technical Support iPad App


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

hello Joseph
where are the recipients for the dhcp - if over the F/R you may need a dhcp relay ( ip helper- address)

Res
paul

Sent from Cisco Technical Support iPad App


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

The recipients are 2 other 2811 Cisco routers and 2 other end users.  The basic set up it 3 cities and only ABQ has DHCP.  LA and SEA have Loopbacks and access through F/R to ABQ.  ABQ is the main for internet access.  You guys are all pro's so you know more than I do on this so I don't have to over explain it as I tend to do.  Working on the ip helper-address now.  Going to run it through packet tracer to see if any errors show up but don't have access to the physical equiptment until Wed at 9 am.

jackcage72
Level 1
Level 1

Ok here is the new running config for the router.....again this is for a troubleshooting lab and we changed the DHCP pools and a few frame-relay commands.  Other than issuing the NAT statement how does it look?

hostname ABQ

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

memory-size iomem 10

!

dot11 syslog

ip source-route

!

!

ip cef

ip dhcp excluded-address 192.168.0.1 192.168.0.10

ip dhcp excluded-address 192.168.1.1 192.168.1.10

ip dhcp excluded-address 192.168.2.1 192.168.1.10

ip dhcp excluded-address 192.168.3.1 192.168.1.10

!

ip dhcp pool VLAN64

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 8.8.8.8

!

ip dhcp pool VLAN128

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 8.8.8.8

!

ip dhcp pool VLAN192

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   dns-server 8.8.8.8

!

!

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

description management vlan 1

encapsulation dot1Q 1 native

ip address 192.168.0.1 255.255.255.0

!

interface FastEthernet0/0.64

description vlan 64

encapsulation dot1Q 64

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet0/0.128

description vlan 128

encapsulation dot1Q 128

ip address 192.168.2.1 255.255.255.0

!

interface FastEthernet0/0.192

description vlan 192

encapsulation dot1Q 192

ip address 192.168.3.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

encapsulation frame-relay

ip summary-address eigrp 50 192.168.0.0 255.255.255.224 5

clock rate 64000

frame-relay intf-type dce

!

interface Serial0/0/0.103 point-to-point

description WAN CONNECTION TO SEA DLCI 103

ip address 192.168.4.1 255.255.255.0

no keepalive

frame-relay interface-dlci 103

!

interface Serial0/0/1

no ip address

encapsulation frame-relay

ip summary-address eigrp 50 192.168.0.0 255.255.255.224 5

clock rate 64000

frame-relay intf-type dce

!

interface Serial0/0/1.102 point-to-point

description WAN CONNECTION TO LA 102

ip address 192.168.5.1 255.255.255.0

no keepalive

frame-relay interface-dlci 102

!

router eigrp 50

network 192.168.0.0

network 192.168.4.0

network 192.168.5.0

no auto-summary

!

ip forward-protocol nd

no ip http server

no ip http secure-server

jackcage72
Level 1
Level 1

Got it working, thanks for all the help and direction.

Here is the new config with the corrections

hostname ABQ

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

memory-size iomem 10

!

dot11 syslog

ip source-route

ip route 0.0.0.0 0.0.0.0 int f0/1

!

ip cef

ip dhcp excluded-address 192.168.0.1 192.168.0.10

ip dhcp excluded-address 192.168.1.1 192.168.1.10

ip dhcp excluded-address 192.168.2.1 192.168.2.10

ip dhcp excluded-address 192.168.3.1 192.168.3.10

!

ip dhcp pool VLAN64

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 8.8.8.8

!

ip dhcp pool VLAN128

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 8.8.8.8

!

ip dhcp pool VLAN192

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   dns-server 8.8.8.8

!

!

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

description management vlan 1

encapsulation dot1Q 1 native

ip address 192.168.0.1 255.255.255.0

!

interface FastEthernet0/0.64

description vlan 64

encapsulation dot1Q 64

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet0/0.128

description vlan 128

encapsulation dot1Q 128

ip address 192.168.2.1 255.255.255.0

!

interface FastEthernet0/0.192

description vlan 192

encapsulation dot1Q 192

ip address 192.168.3.1 255.255.255.0

!

interface FastEthernet0/1

ip address 10.10.50.1 255.255.255.252

no shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

encapsulation frame-relay

ip summary-address eigrp 50 192.168.0.0 255.255.255.224 5

clock rate 64000

frame-relay intf-type dce

!

interface Serial0/0/0.103 point-to-point

description WAN CONNECTION TO SEA DLCI 103

ip address 192.168.4.1 255.255.255.0

no keepalive

frame-relay interface-dlci 103

!

interface Serial0/0/1

no ip address

encapsulation frame-relay

ip summary-address eigrp 50 192.168.0.0 255.255.255.224 5

clock rate 64000

frame-relay intf-type dce

!

interface Serial0/0/1.102 point-to-point

description WAN CONNECTION TO LA 102

ip address 192.168.5.1 255.255.255.0

no keepalive

frame-relay interface-dlci 102

!

router eigrp 50

network 192.168.0.0

network 192.168.4.0

network 192.168.5.0

no auto-summary

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

!

!

control-plane

!

!

!

!

mgcp fax t38 ecm

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card