cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
648
Views
0
Helpful
2
Replies

How to accomplish dual WAN failover...

johnny.schultz
Level 1
Level 1

I currently have 2 WAN connections and we are sending voice traffic to ISP-A and data traffic to ISP-B with the use of an ACL to specify source IP subnet then a route map to specify a next-hop address.  What I need to accomplish now is dual failover for both voice and data in the event that either ISP-A or ISP-B goes down.  I have reviewed some configurations with the tracking command and IP SLA however they are all one-way failover with a primary/secondary setup.  I need failover to happen both ways if either ISP goes down since they will both be sending and receiving data.

access-list 100 remark Specify voice traffic by source IP
access-list 100 permit ip 10.10.31.0 0.0.0.255 any

access-list 110 remark Specify data traffic by source IP
access-list 110 permit ip 172.16.10.0 0.0.0.255 any

route-map FORWARD permit 10
description Source based routing with route map
match ip address 100
set ip next-hop 1.1.1.2

route-map FORWARD permit 20
description Source based routing with route map
match ip address 110
set ip next-hop 2.2.2.1


interface fa0/0
description LAN interface
ip policy route-map FORWARD


interface Serial1/0
description ISP-A
ip address 1.1.1.1 255.255.255.252

interface Serial1/1
description ISP-B
ip address 2.2.2.2 255.255.255.252

If someone can let me know if this is possible, I would appreciate it.  Platform for this scenario would be 7206 router, full BGP tables from both ISPs.  Any more information needed, let me know.  Thank you.

-Johnny Schultz

2 Replies 2

Edison Ortiz
Hall of Fame
Hall of Fame

If one if the circuits goes down, the PBR would become invalid and the routing table will be used.

At that point, the routing table will point to the usable circuit and you shouldn't experience any outage as long as one circuit is up.

Isn't that the case?

bava_ccna
Level 1
Level 1

Hi Johnny,

Try the below config, I would suggest to refer the attached document

ip sla 1
  icmp-echo 1.1.1.2
  frequency 3
ip sla schedule 1 life forever start-time now
!
ip sla 2
  icmp-echo 2.2.2.1
  frequency 3
ip sla schedule 2 life forever start-time now
!
track 11 ip sla 1 reachability
track 22 ip sla 2 reachability

!

route-map FORWARD permit 10
description Source based routing with route map
match ip address 100
set ip next-hop verify-availability 1.1.1.2 10 track 11
set ip next-hop verify-availability 2.2.2.1 20 track 22


route-map FORWARD permit 20
description Source based routing with route map
match ip address 110
set ip next-hop verify-availability 2.2.2.1 20 track 22

set ip next-hop verify-availability 1.1.1.2 10 track 11
!
interface fa0/0
description LAN interface
ip policy route-map FORWARD


HTH

bava

Review Cisco Networking for a $25 gift card