cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
286
Views
10
Helpful
5
Replies

how to trunk thought static route ?

Anaphat
Beginner
Beginner

what the quest..PNG

 

 

VLAN gateway on different switch with access port how to trunk thought static route if it not possible is there a way around it ?

i just get in to  learning networking for two week 

stuck on this question for 4 day now  any subject i should look in to? 

to be able to answer this question 

here the config on the switch

  core switch 1 : 

                          

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/3

no switchport

ip address 172.16.0.1 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/4

switchport access vlan 60

switchport mode access

switchport nonegotiate

!

interface Vlan10

mac-address 000a.413d.8101

ip address 192.168.10.1 255.255.255.0

ip helper-address 192.168.40.2

ip access-group Vlan-ACLs in

!

interface Vlan20

mac-address 000a.413d.8102

ip address 192.168.20.1 255.255.255.0

ip helper-address 192.168.40.2

!

interface Vlan30

mac-address 000a.413d.8103

ip address 192.168.30.1 255.255.255.0

ip helper-address 192.168.40.2

!

ip classless

ip route 192.168.40.0 255.255.255.0 172.16.0.2

ip route 192.168.50.0 255.255.255.0 172.16.0.2

ip route 192.168.60.0 255.255.255.0 172.16.0.2

!

ip flow-export version 9

!

!

ip access-list extended Vlan-ACLs

permit tcp any eq www any

deny icmp 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255 echo

permit ip any any

permit icmp any any

!


core switch 2 : 

!

interface FastEthernet0/1

no switchport

ip address 172.16.0.2 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/2

switchport access vlan 50

switchport mode access

switchport nonegotiate

!

interface FastEthernet0/3

switchport access vlan 40

switchport mode access

switchport nonegotiate

!

interface FastEthernet0/4

switchport access vlan 40

switchport mode access

switchport nonegotiate

!

!

interface Vlan1

no ip address

shutdown

!

interface Vlan40

mac-address 00d0.5882.e301

ip address 192.168.40.1 255.255.255.0

ip helper-address 192.168.40.2

!

interface Vlan50

mac-address 00d0.5882.e302

ip address 192.168.50.1 255.255.255.0

ip helper-address 192.168.40.2

!

interface Vlan60

mac-address 00d0.5882.e303

ip address 192.168.60.1 255.255.255.0

ip helper-address 192.168.40.2

!

ip classless

ip route 192.168.10.0 255.255.255.0 172.16.0.1

ip route 192.168.20.0 255.255.255.0 172.16.0.1

ip route 192.168.30.0 255.255.255.0 172.16.0.1

!


 

 

ps. thank you in advance for the answer and apology on my broken english

here the file : https://drive.google.com/file/d/1pr5DI7H7qcbIlY7KVO9prL6YzpEbpSkQ/view?usp=sharing

 

1 Accepted Solution

Accepted Solutions

Jon Marshall
VIP Community Legend VIP Community Legend
VIP Community Legend

 

Your setup won't work.

 

Either create the L3 interface (SVI) for vlan 60 on core switch 1 or use a trunk link between core switch 1 and core switch 2 and allow vlan 60.

 

Jon

 

View solution in original post

5 Replies 5

Kasun Bandara
VIP Advocate VIP Advocate
VIP Advocate

better share your pkt file as in zip  format

Please rate this and mark as solution/answer, if this resolved your issue
Good luck
KB