- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-19-2017 01:05 PM - edited 03-05-2019 09:20 AM
Can someone help me to figure out this ICMP issue
See attached diagram for more info and the config can be found below:
When I ping from R3 to R1 loopback, I get the following error message:
Error on R1:
*Mar 1 06:38:29.862: ICMP: dst (8.8.8.8) host unreachable rcv from 90.0.0.9
*Mar 1 06:38:32.094: ICMP: echo reply sent, src 8.8.8.8, dst 100.0.0.25
*Mar 1 06:38:32.178: ICMP: dst (8.8.8.8) host unreachable rcv from 90.0.0.9
*Mar 1 06:38:34.498: ICMP: echo reply sent, src 8.8.8.8, dst 100.0.0.25
*Mar 1 06:38:34.546: ICMP: dst (8.8.8.8) host unreachable rcv from 90.0.0.9
*Mar 1 06:38:36.858: ICMP: echo reply sent, src 8.8.8.8, dst 100.0.0.25
*Mar 1 06:38:36.926: ICMP: dst (8.8.8.8) host unreachable rcv from 90.0.0.9
*Mar 1 06:39:12.674: ICMP: echo reply sent, src 8.8.8.8, dst 100.0.0.20
Error on R9:
*Mar 1 09:23:38.697: ICMP: dst (10.0.2.3) host unreachable sent to 8.8.8.8
*Mar 1 09:23:41.025: ICMP: dst (10.0.2.3) host unreachable sent to 8.8.8.8
*Mar 1 09:23:43.301: ICMP: dst (10.0.2.3) host unreachable sent to 8.8.8.8
*Mar 1 09:23:45.749: ICMP: dst (10.0.2.3) host unreachable sent to 8.8.8.8
*Mar 1 09:23:48.029: ICMP: dst (10.0.2.3) host unreachable sent to 8.8.8.8
R3
—-
hostname R3
!
interface FastEthernet0/1
ip address 10.0.2.3 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
network 10.0.0.0
no auto-summary
R4
—
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip vrf INTERNAL
rd 200:200
!
ip vrf INTERNET
rd 100:100
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip vrf forwarding INTERNET
ip address 40.0.0.10 255.255.255.252
!
interface FastEthernet0/0.200
encapsulation dot1Q 200
ip vrf forwarding INTERNAL
ip address 10.0.4.10 255.255.255.252
!
interface FastEthernet0/1.100
encapsulation dot1Q 100
ip vrf forwarding INTERNET
ip address 40.0.0.2 255.255.255.252
!
interface FastEthernet0/1.200
encapsulation dot1Q 200
ip vrf forwarding INTERNAL
ip address 10.0.4.2 255.255.255.252
!
interface FastEthernet1/0
no switchport
ip vrf forwarding INTERNAL
ip address 10.0.2.4 255.255.255.0
!
router eigrp 999
auto-summary
!
address-family ipv4 vrf INTERNAL
network 10.0.0.0
no auto-summary
autonomous-system 100
exit-address-family
R5
—-
ip vrf INTERNAL
rd 200:200
!
ip vrf INTERNET
rd 100:100
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip vrf forwarding INTERNET
ip address 40.0.0.6 255.255.255.252
!
interface FastEthernet0/0.200
encapsulation dot1Q 200
ip vrf forwarding INTERNAL
ip address 10.0.4.6 255.255.255.252
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.100
encapsulation dot1Q 100
ip vrf forwarding INTERNET
ip address 40.0.0.1 255.255.255.252
!
interface FastEthernet0/1.200
encapsulation dot1Q 200
ip vrf forwarding INTERNAL
ip address 10.0.4.1 255.255.255.252
!
interface FastEthernet1/0
no switchport
ip vrf forwarding INTERNET
ip address 90.0.0.5 255.255.255.0
!
interface Vlan1
no ip address
!
router eigrp 999
auto-summary
!
address-family ipv4 vrf INTERNAL
network 10.0.0.0
no auto-summary
autonomous-system 100
exit-address-family
!
ip forward-protocol nd
ip route vrf INTERNET 0.0.0.0 0.0.0.0 90.0.0.9
ip route vrf INTERNET 100.0.0.0 255.255.255.0 40.0.0.5
ip route vrf INTERNET 100.0.0.0 255.255.255.0 40.0.0.2 250
R6
—-
!
ip vrf INTERNAL
rd 200:200
!
ip vrf INTERNET
rd 100:100
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip vrf forwarding INTERNET
ip address 40.0.0.5 255.255.255.252
!
interface FastEthernet0/0.200
encapsulation dot1Q 200
ip vrf forwarding INTERNAL
ip address 10.0.4.5 255.255.255.252
!
interface FastEthernet0/1.100
encapsulation dot1Q 100
ip vrf forwarding INTERNET
ip address 40.0.0.9 255.255.255.252
!
interface FastEthernet0/1.200
encapsulation dot1Q 200
ip vrf forwarding INTERNAL
ip address 10.0.4.9 255.255.255.252
!
interface FastEthernet1/0
no switchport
ip vrf forwarding INTERNAL
ip address 10.0.0.6 255.255.255.0
!
interface FastEthernet1/2
no switchport
ip vrf forwarding INTERNET
ip address 100.0.0.6 255.255.255.0
!
router eigrp 999
auto-summary
!
address-family ipv4 vrf INTERNAL
network 10.0.0.0
no auto-summary
autonomous-system 100
exit-address-family
!
ip forward-protocol nd
ip route vrf INTERNET 0.0.0.0 0.0.0.0 40.0.0.6
ip route vrf INTERNET 0.0.0.0 0.0.0.0 40.0.0.10 250
R7
—-
!
interface Loopback0
ip address 10.0.100.100 255.255.255.255
!
interface FastEthernet1/0
no switchport
ip address 10.0.0.7 255.255.255.0
!
interface FastEthernet1/1
no switchport
ip address 10.0.1.7 255.255.255.0
!
router eigrp 100
redistribute static metric 1 1 0 1 1500
passive-interface FastEthernet1/1
network 10.0.0.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.1.8
R8
—-
interface FastEthernet1/1
no switchport
ip address 10.0.1.8 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet1/2
no switchport
ip address 100.0.0.8 255.255.255.0
ip nat outside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.0.0.6
!
!
no ip http server
no ip http secure-server
ip nat pool MY_NAT 100.0.0.20 100.0.0.254 netmask 255.255.255.0
ip nat inside source list TEST pool MY_NAT
!
ip access-list extended TEST
permit icmp any any
permit ip any any log
permit ip 10.0.0.0 0.0.255.255 any log
R9
—-
!
interface FastEthernet0/1
ip address 70.0.0.9 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no switchport
ip address 90.0.0.9 255.255.255.0
!
interface FastEthernet1/4
no switchport
ip address 80.0.0.9 255.255.255.0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 70.0.0.0 mask 255.255.255.0
network 80.0.0.0 mask 255.255.255.0
network 90.0.0.0 mask 255.255.255.0
redistribute static
neighbor 80.0.0.1 remote-as 200
no auto-summary
!
ip forward-protocol nd
ip route 100.0.0.0 255.255.255.0 90.0.0.5
!
R1
——-
!
interface Loopback0
ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet1/4
no switchport
ip address 80.0.0.1 255.255.255.0
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 8.8.8.8 mask 255.255.255.255
network 80.0.0.0 mask 255.255.255.0
neighbor 80.0.0.9 remote-as 100
no auto-summary
!
Solved! Go to Solution.
- Labels:
-
Other Routing
Accepted Solutions
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-19-2017 04:16 PM - edited 10-19-2017 04:22 PM
Hi
Have you verified if the R1's loopback has an entry into the R3's routing table? and if the R1's routing table has entries related to R3's networks?
>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-19-2017 04:16 PM - edited 10-19-2017 04:22 PM
Hi
Have you verified if the R1's loopback has an entry into the R3's routing table? and if the R1's routing table has entries related to R3's networks?
>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
