09-08-2023 10:56 AM
I am using a Cisco C1111 ISR w/ 2 L3 interfaces, 8 L2 interfaces.
Interface Vlan601 currently has an IP address assigned to it. I would like to use DHCP to assign the IP address to this interface. However, when I change it to DHCP, the MAC address in the DHCP request is 0000.0000.0000 which is causing the DHCP request to fail.
Starting Point:
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/1/0 unassigned YES unset up up
Vlan601 192.168.1.50 YES NVRAM up up
interface GigabitEthernet0/1/0
switchport access vlan 601
switchport mode access
interface Vlan601
description PartnerNet1
ip vrf forwarding PARTNER-NET-1
ip address 192.168.1.50 255.255.255.0
ip nat outside
router#ping vrf PARTNER-NET-1 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms
router#show int Gi0/1/0
GigabitEthernet0/1/0 is up, line protocol is up (connected)
Hardware is C1111-ES-8, address is 5c64.f184.b088 (bia 5c64.f184.b088)
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:36, output 00:00:13, output hang never
Last clearing of "show interface" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1000 bits/sec, 2 packets/sec
5 minute output rate 1000 bits/sec, 2 packets/sec
950 packets input, 76619 bytes, 0 no buffer
Received 24 broadcasts (11 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 11 multicast, 0 pause input
0 input packets with dribble condition detected
933 packets output, 79668 bytes, 0 underruns
Output 2 broadcasts (18 multicasts)
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
router#show ip int Vlan601
Vlan601 is up, line protocol is up
Internet address is 192.168.1.50/24
Broadcast address is 255.255.255.255
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing Common access list is not set
Outgoing access list is not set
Inbound Common access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF switching turbo vector
IP Null turbo vector
VPN Routing/Forwarding "PARTNER-NET-1"
Associated unicast routing topologies:
Topology "base", operation state is UP
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is enabled, interface in domain outside
BGP Policy Mapping is disabled
Input features: Virtual Fragment Reassembly, NAT Outside, MCI Check
Output features: Post-routing NAT Outside
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled
IP Clear Dont Fragment is disabled
I remove the IP address from the Vlan601 interface.
router(config)#int Vlan601
router(config-if)#no ip address
router#show ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/1/0 unassigned YES unset up up
Vlan601 unassigned YES manual up up
I then set the IP address to DHCP. I have tried this as just "ip address dhcp" and with the client-id set to the physical interface, and with a hostname set. Showing the last iteration. There are not many options available here.
interface Vlan601
description PartnerNet1
ip vrf forwarding PARTNER-NET-1
ip address dhcp client-id GigabitEthernet0/1/0 hostname Cisco
ip nat outside
end
router#show ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/1/0 unassigned YES unset up up
Vlan601 unassigned YES DHCP up up
router(config-if)#ip address dhcp ?
client-id Specify client-id to use
hostname Specify value for hostname option
<cr> <cr>
router(config-if)#ip address dhcp client-id ?
BD-VIF Bridge-Domain Virtual IP interface
BDI Bridge-Domain interface
GigabitEthernet GigabitEthernet IEEE 802.3z
Port-channel Ethernet Channel of interfaces
Vlan Catalyst Vlans
router(config-if)#ip address dhcp client-id GigabitEthernet 0/1/0 ?
hostname Specify value for hostname option
<cr> <cr>
But the ip dhcp debug shows the MAC address being set as all zeros.
Sep 8 17:15:15.174: DHCP: Try 3 to acquire address for Vlan601
Sep 8 17:15:15.177: DHCP: allocate request
Sep 8 17:15:15.177: DHCP: zapping entry in DHC_PURGING state for Vl601
Sep 8 17:15:15.177: DHCP: deleting entry FFFF56A0D0F8 0.0.0.0 from list
Sep 8 17:15:15.177: DHCP: new entry. add to queue, interface Vlan601
Sep 8 17:15:15.177: DHCP: MAC address specified as 0000.0000.0000 (0 0). Xid is 10A945FE
Sep 8 17:15:15.177: DHCP: SDiscover attempt # 1 for entry:
Sep 8 17:15:15.178: DHCP: Scan: Option vendor class Identifier 124
Sep 8 17:15:15.178: Enterprise ID 9
Sep 8 17:15:15.178: vendor-class-data-len 13
Sep 8 17:15:15.178: data: C1111-8PLTEEA
Sep 8 17:15:15.178: DHCP: SDiscover: sending 305 byte length DHCP packet
Sep 8 17:15:15.178: DHCP: SDiscover 305 bytes
Sep 8 17:15:15.178: B'cast on Vlan601 interface from 0.0.0.0
Sep 8 17:15:18.200: DHCP: SDiscover attempt # 2 for entry:
Sep 8 17:15:18.200: DHCP: Scan: Option vendor class Identifier 124
Sep 8 17:15:18.200: Enterprise ID 9
Sep 8 17:15:18.200: vendor-class-data-len 13
Sep 8 17:15:18.201: data: C1111-8PLTEEA
Sep 8 17:15:18.201: DHCP: SDiscover: sending 305 byte length DHCP packet
Sep 8 17:15:18.201: DHCP: SDiscover 305 bytes
Sep 8 17:15:18.201: B'cast on Vlan601 interface from 0.0.0.0
Sep 8 17:15:22.202: DHCP: SDiscover attempt # 3 for entry:
Sep 8 17:15:22.202: DHCP: Scan: Option vendor class Identifier 124
Sep 8 17:15:22.202: Enterprise ID 9
Sep 8 17:15:22.202: vendor-class-data-len 13
Sep 8 17:15:22.202: data: C1111-8PLTEEA
Sep 8 17:15:22.202: DHCP: SDiscover: sending 305 byte length DHCP packet
Sep 8 17:15:22.202: DHCP: SDiscover 305 bytes
Sep 8 17:15:22.202: B'cast on Vlan601 interface from 0.0.0.0
%Unknown DHCP problem.. No allocation possible
Sep 8 17:15:35.657: DHCP: Waiting for 15 seconds on interface Vlan601
How can I set the MAC address to use the MAC address of the Gi0/1/0 or some other viable solution?
10-02-2024 10:00 AM
Thank you for the run config.
If you can not have 2 overlap IP address, why do you need VLAN 1 here ?
interface GigabitEthernet0/0/1
description gig 0/0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
negotiation auto
ip virtual-reassembly
interface Vlan1
ip helper-address 192.168.1.1
ip nat inside
vlan-autoconfig
You can have any one them need for that to work, or if you have need different VLAN, then use different RFC 1918 addres with out overlap.
10-02-2024 10:17 AM
I was under the impression that all of the 8 ports on the router are mapped to vlan1 by default. Are you saying I should eliminate VLAN1?
Do you have a config that you know would work?
10-05-2024 12:38 AM
Hello
Can you confirm as this iis an svi then assumption is the dhcp server reachable from that vrf and its connected physical interface?
Meaning it’s not reachable via the global route table (GRT)
10-05-2024 09:24 AM
In the early stages of this discussion the config showed a DHCP pool configured on the new Cisco router. So it was local and reachability was certainly not an issue. At that point the issue was that the subnet of the DHCP pool was assigned to physical interface G0/0/1 and therefore was not available to devices connected to vlan 1 who needed to use addresses in that subnet.
Some changes were made but the DHCP still did not work. And then the router was reset. So we are effectively starting from the beginning. When the router is recovered and is functional we can address issues about DHCP.
10-14-2024 08:52 AM
Well, I was able to get the file and re-load the OS. The router is now assigning IP addresses but when I plug my MacBook in to the lan port (#5) I get connection errors trying to access the GUI https://www.cisco.com/c/en/us/td/docs/routers/access/isr1100/software/configuration/xe-17/isr1100-sw-config-xe-17/mgmt_interfaces.html
Safari and Chrome give different responses but it seems the router is not allowing the MacBook to access 192.168.1.1. I've checked all the settings on the browser and tried turning off the firewall (Edge with my Surface).
Not sure what the issue is
10-15-2024 01:08 PM
Can you verify what IP address, mask, and default gateway are assigned to your MacBook? and can you post the configuration of the port to which it connects and of the vlan interface for that port?
10-15-2024 01:59 PM
I won't have access to the machine until Friday and will send the running config. First time I plugged it in it received 192.168.1.6 . I think 255.255.255.0 but would have to check again. When I plugged in the Surface it received 192.168.1.7. I also plugged in my switch and the light on the front went to steady which means it was assigned an IP address.
The vlan1 interface is configured as instructed in the document mentioned above
interface Vlan1 ip address 192.168.1.1 255.255.255.0
ip nat inside
no shutdown
I've been reading about the management interface gigabitethernet0 . Might that have something to do with this issue?
10-15-2024 02:26 PM
Thanks for the additional information. It may be helpful to see the running config. In the meantime I have a couple things:
- when you connected the Surface it worked ok? Was able to access resources in the local subnet? Was able to access resources in remote subnets?
- when you were connecting the various devices it was always to the same port?
- without knowing more it is difficult to be sure but I find it hard to understand how management interface gig0 would be part of this issue.
10-17-2024 01:44 PM
What is the best way for me to share the configuration with you?
I use PuTTY on a Microsoft Surface to access the CLI through the control port
10-18-2024 01:57 PM
I am not familiar with the capabilities of Surface, but if you are using PuTTY can you do a show run, highlight and copy the output, and then paste it in a response in the community?
10-18-2024 02:45 PM
I turned the machine off for the week and when I turned it on it came up in rommon.
I just spent 2 hours with the tech from Cisco. It turns out that IOS-XE 17.12 (which is what they gave me) needs an updated rommon. The tech loaded 17.6 which automatically upgrades the rommon and then went to 17.12
The machine boots in 17.12 now and I executed the configuration commands to access the GUI. I can now access the GUI login page and enter my credentials. I get the spinning balls and then the screen goes whitte and stays there.
Any idea what might be causing it?
10-19-2024 11:31 AM
Thanks for the update. Glad that Cisco was able to help upgrade the version of code, and that the upgrade got you to where you could enter your credentials. Not sure why your attempt to access the GUI hangs up. Is it possible that there is some mismatch between what the Cisco is expecting address wise and what your Surface is using?
10-19-2024 11:58 AM
Thanks Richard. I tried 2 different versions of Safari and neither worked. But Chrome did and I got in. I was also able to access the wireless controller. All good. I am on my way.
Thanks again to all. You are all incredible!
10-19-2024 12:57 PM
You are quite welcome.
Thanks for the update. Interesting that your recent issue was browser related.
Glad that you are on your way. This community is an excellent resource. I hope you continue to be active in it.
10-19-2024 01:06 PM
I agree. This Community is very helpful.
I hope no one has to go through what I did but if they experience the same issues I’ve learned a lot and will look to help if I can.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide