cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
570
Views
0
Helpful
2
Replies

Issue with PIM-SSM Multicast Configuration ISR4431s

I have an issue with my PIM-SSM multicast configuration using ISR4431s. 

 

I am wanting to forward broadcast data from an application from one VLAN in on the multicast source to another VLAN on a multicast router on a small network.  The method I am using is PIM-SSM.  I have a multicast source R1, a multicast transition router R2, and a multicast receiver, the R3 device.

 

Any insight into why the broadcast data is not forwarding is welcome.

 

Here is the topology:

              R1---R2---R3

                R1                                                     R2                                              R3

vlan 100 (IP: 10.1.1.1)--10.194.234.226-|--G0/0/0 (IP: 10.194.234.225)---G0/0/0 (IP: 10.156.51.225)-|-G0/0/0 IP: (10.156.51.226)--vlan 600 (IP: 192.142.1.1)

R1 Config (Multicast Source):

!
hostname R1
!
ip multicast-routing distributed
!
ip pim spt-threshold infinity
!
ip pim ssm default
!
no ip igmp snooping
!
vtp mode transparent
!
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 100
!
interface GigabitEthernet0/0/0
ip address 10.194.234.226 255.255.255.252
ip nat outside
ip pim sparse-dense-mode
!
interface GigabitEthernet0/1/0
switchport access vlan 100
switchport mode access
!
interface GigabitEthernet0/1/1
switchport access vlan 100
switchport mode access
!
interface GigabitEthernet0/1/2
switchport access vlan 100
switchport mode access
!
interface GigabitEthernet0/1/3
switchport access vlan 100
switchport mode access
!
interface GigabitEthernet0/1/4
switchport access vlan 100
switchport mode access
!
interface GigabitEthernet0/1/5
switchport access vlan 100
switchport mode access
!
interface GigabitEthernet0/1/6
switchport access vlan 100
switchport mode access
!
interface GigabitEthernet0/1/7
switchport access vlan 100
switchport mode access
!
interface Vlan100
description /// 10.1.1.1 is the VLAN 100 IP address ///
ip address 10.1.1.1 255.255.255.0
ip nat inside
ip pim sparse-dense-mode
ip multicast helper-map broadcast 232.1.1.1 bcast-to-mcast ttl 50
!
ip forward-protocol udp 3205
!
ip nat inside source static udp 10.1.1.71 3205 10.194.234.226 3205 extendable
!
ip route 0.0.0.0 0.0.0.0 G0/0/0
!
ip access-list extended bcast-to-mcast
permit udp any any eq 3205
!
end

 

R2 Config (Multicast Transition Router):

!
hostname R2
!
ip multicast-routing distributed
!
ip pim spt-threshold infinity
!
vtp mode transparent
!
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 100
!
interface GigabitEthernet0/0/0
ip address 10.194.234.225 255.255.255.252
ip pim sparse-dense-mode
no shutdown
negotiation auto
!
interface GigabitEthernet0/0/1
ip address 10.156.51.225 255.255.255.252
ip pim sparse-dense-mode
no shutdown
negotiation auto
!
interface GigabitEthernet0/1/0
!
interface GigabitEthernet0/1/1
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
!
interface GigabitEthernet0/1/4
!
interface GigabitEthernet0/1/5
!
interface GigabitEthernet0/1/6
!
interface GigabitEthernet0/1/7
!
interface Vlan100
description /// 10.10.1.1 is the VLAN 100 IP address ///
ip address 10.10.1.1 255.255.255.0
ip nat inside
ip pim sparse-dense-mode
ip multicast helper-map broadcast 232.1.1.1 bcast-to-mcast ttl 50
!
ip forward-protocol udp 3205
!
ip nat inside source static udp 10.1.1.71 3205 10.194.234.226 3205 extendable
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/1
!
!
end

 

R3 Config (Multicast Receiver, NOTE:  192.142.1.99 is not the device that is receiving the data.  Other devices on vlan 600 need the data):

 

!
hostname R3
!
ip multicast-routing distributed
!
ip pim spt-threshold infinity
!
ip pim ssm default
!
no ip igmp snooping
!
vtp mode transparent
!
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 600
!
interface GigabitEthernet0/0/0
ip address 10.156.51.226 255.255.255.252
ip pim sparse-dense-mode
ip multicast helper-map 232.1.1.1 192.142.1.255 bcast-to-mcast
ip igmp version 3
negotiation auto
!
interface GigabitEthernet0/1/0
switchport access vlan 600
switchport mode access
!
interface GigabitEthernet0/1/1
switchport access vlan 600
switchport mode access
!
interface GigabitEthernet0/1/2
switchport access vlan 600
switchport mode access
!
interface GigabitEthernet0/1/3
switchport access vlan 600
switchport mode access
!
interface GigabitEthernet0/1/4
switchport access vlan 600
switchport mode access
!
interface GigabitEthernet0/1/5
switchport access vlan 600
switchport mode access
!
interface GigabitEthernet0/1/6
switchport access vlan 600
switchport mode access
!
interface GigabitEthernet0/1/7
switchport access vlan 600
switchport mode access
!
interface Vlan600
ip address 192.142.1.1 255.255.255.0
ip broadcast-address 192.142.1.255
ip directed-broadcast
ip pim sparse-dense-mode
ip igmp join-group 232.1.1.1 source 10.194.234.226
ip igmp version 3
!
ip forward-protocol udp 3205
!
ip nat inside source static tcp 192.142.1.99 61000 10.156.51.226 61000 extendable
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0
!
ip access-list extended bcast-to-mcast
permit udp any any eq 3205
!
end

 

 

2 Replies 2

I checked my post and I uploaded the R2 config incorrectly...  here is the correct one...

 

R2 Config (Multicast Transition Router):

!

hostname R2

!

ip multicast-routing distributed

!

ip pim spt-threshold infinity

!

vtp mode transparent

!

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet0/0/0

ip address 10.194.234.225 255.255.255.252

ip pim sparse-dense-mode

no shutdown

negotiation auto

!

interface GigabitEthernet0/0/1

ip address 10.156.51.225 255.255.255.252

ip pim sparse-dense-mode

no shutdown

negotiation auto

!

interface GigabitEthernet0/1/0

!

interface GigabitEthernet0/1/1

!

interface GigabitEthernet0/1/2

!

interface GigabitEthernet0/1/3

!

interface GigabitEthernet0/1/4

!

interface GigabitEthernet0/1/5

!

interface GigabitEthernet0/1/6

!

interface GigabitEthernet0/1/7

!

!

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/1

!

!

end

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello @donaldhughes743301172 ,

contrary to what sometimes is written in configuration guide to build a working PIM SSM internetwork you need to configure Ip pim SSm in ALL routers in the path and not only on the edge routers.

I would suggest you to add on R2:

ip pim ssm default

 

remove also all the commands related to transition to source based tree as there is no RP in PIM SSM the source needs to be known in advance as an IGMPv3 join describes both the group address G and the source address.

 

Hope to help

Giuseppe

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco