cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1261
Views
0
Helpful
8
Replies

linking atm0 to ethernet0

zombiecrab
Level 1
Level 1

Hi I have been trying to configure a 837 for a while now and I'm finally nearly there. So far the tests run(SDM interface test) and pass on atm0(WAN connection to the internet) but not on ethernet0. I am guessing i need to link them somehow but since I don't know the terminology searching for how to do it is turning out to be difficult.

Here is my config:

!This is the running config of the router: 192.168.0.1

!----------------------------------------------------------------------------

!version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$j4/M$/YkFiP.GPRtivQdLd.2wE1

!

username alex privilege 15 password 0 password1

no aaa new-model

ip subnet-zero

!

!

!

!

ip name-server 8.8.8.8

ip name-server 8.8.4.4

ip ips po max-events 100

no ftp-server write-enable

!

!

!

!

!

!

!

interface Ethernet0

description ethernet

ip address 192.168.0.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

hold-queue 100 out

!

interface Ethernet2

no ip address

shutdown

hold-queue 100 out

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname #########3@adsl.virgin.net

ppp chap password 0 samsung905

ppp pap sent-username ########@adsl.virgin.net password 0 ##########

ppp ipcp mask request

ppp ipcp route default

ppp ipcp address accept

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 ATM0

!

ip http server

ip http authentication local

ip http secure-server

!

ip nat inside source list 1 interface Dialer0 overload

!

!

!

control-plane

!

!

line con 0

no modem enable

transport preferred all

transport output all

line aux 0

transport preferred all

transport output all

line vty 0 4

privilege level 15

login local

transport preferred all

transport input telnet ssh

transport output all

!

scheduler max-task-time 5000

end

I tried ip route 0.0.0.0 0.0.0.0 Dialer0 first with no luck to i added the ip route 0.0.0.0 0.0.0.0 ATM0 still nothing

Any suggestions are appreciated.

Thanks

8 Replies 8

manish arora
Level 6
Level 6

Hey Alex,

Few changes :-

1> router(config)# access-list 1 permit 192.168.0.0 0.0.0.255

2> router(config)#int atm 0

                        #no ip nat outside

                        #exit

3> router(config)#int dialer 0

                       #ip nat outside

                       #ip mtu 1492

                       #exit

4> you need just one default route out of dialer 0 so ,

router(config)# no ip route 0.0.0.0 0.0.0.0 ATM0

5> router# wr

Manish

No luck sorry

here is what SDM is outputting:

ethernet0:

checking exit interface...               Failed

     exit interfae found: Dialer0

     exit interfae found: Dialer0

Failure Reasons

To test connectivity, SDM tries to ping the configured DNS servers. Howesver, there is no configured route to any of the DNS servers through the selected interface.

Recommended Actions

Select 'User-specified' option or add a 'host specific/network specific/default' route through this interface and retest connection.

My bad dude ,

The ip nat outside stays under atm 0 , so please change it back :-

router(config)#int dialer 0

                   # no ip nat outside

                   #exit

                   #int atm 0

                  # ip nat outside

                 # exit

Nope sorry same result. ATM0 passes and ethernet0 faills in the same place.

I wouldn't worry about what SDM says , Just connect a laptop/pc with eth0 and give an ip

address 192.168.0.10 , 255.255.255.0 gateway 192.168.0.1 , test connectivity.

or try extended ping from the router.

Manish

Sorry about the wait, it's been hectic at work.

I hooked up the lan cable and was able to communicate with the router but not able to connect to the internet.

I have fiddled with the config a bit so I'll post the changes(differences are in bold):

!This is the running config of the router: 192.168.0.1

!----------------------------------------------------------------------------

!version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$j4/M$/YkFiP.GPRtivQdLd.2wE1

!

username alex privilege 15 password 0 ########

no aaa new-model

ip subnet-zero

!

!

!

!

ip name-server 8.8.8.8

ip name-server 8.8.4.4

ip ips po max-events 100

no ftp-server write-enable

!

!

!

!

!

!

!

interface Ethernet0

description ethernet

ip address 192.168.0.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

hold-queue 100 out

!

interface Ethernet2

no ip address

shutdown

hold-queue 100 out

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname ####################

ppp chap password 0 ###################

ppp pap sent-username alex.wood3@adsl.virgin.net password 0 ################

ppp ipcp mask request

ppp ipcp route default

ppp ipcp address accept

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0 permanent

!

ip http server

ip http authentication local

ip http secure-server

!

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 192.168.0.0 0.0.0.255

!

!

control-plane

!

!

line con 0

no modem enable

transport preferred all

transport output all

line aux 0

transport preferred all

transport output all

line vty 0 4

privilege level 15

login local

transport preferred all

transport input telnet ssh

transport output all

!

scheduler max-task-time 5000

end

Humm I though I changed more then that but notepad++ disagrees.

Anyway. Can you see anything that would be preventing it from connecting the two interfaces?

I really apriciate the help you have given me.

Hi Alex,

Can you please do the following :-

interface Ethernet0
ip tcp adjust-mss 1452
!
interface Dialer0
ip mtu 1492
ip tcp adjust-mss 1452

Rest of the configuration looks good to me. Please post output of "sh version" if you still have issues.

Manish

Sorry no luck. Ping from computer connected to router didn't work neither did the SDM connection test from ethernet0 but the connection test from ATM0 did work as usaual.

Here is the output you asked for:

Router#sh version

Cisco IOS Software, C837 Software (C837-K9O3SY6-M), Version 12.3(8)YG, RELEASE S                                             OFTWARE (fc1)

Synched to technology version 12.3(10.3)T2

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2004 by Cisco Systems, Inc.

Compiled Fri 17-Dec-04 17:01 by ealyon

ROM: System Bootstrap, Version 12.2(11r)YV1, RELEASE SOFTWARE (fc1)

ROM: Cisco IOS Software, C837 Software (C837-K9O3SY6-M), Version 12.3(8)YG, RELE                                             ASE SOFTWARE (fc1)

Router uptime is 5 minutes

System returned to ROM by power-on

System image file is "flash:c837-k9o3sy6-mz.123-8.YG.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco C837 (MPC857DSL) processor (revision 0x501) with 44237K/4915K bytes of memory.

Processor board ID FCZ091043L1 (3846568980), with hardware revision 0000

CPU rev number 7

2 Ethernet interfaces

4 FastEthernet interfaces

1 ATM interface

128K bytes of NVRAM.

12288K bytes of processor board System flash (Read/Write)

2048K bytes of processor board Web flash (Read/Write)

Configuration register is 0x2102

Router#

Sorry for the late responce I was stuck in Wales due to a train strike.

Review Cisco Networking products for a $25 gift card