cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1090
Views
0
Helpful
8
Replies

Load Balancing across multiple ADSL Link

jain.nitin
Level 3
Level 3

Hi Techies,

Please help to configure load balancing between four adsl links connected to a router.

How can I achieve load balancing between these link. getting dynamic IPs on each link.

8 Replies 8

devang_etcom
Level 7
Level 7

hi nitin...

will you give me the connectivity diagram... where all the four ADSL line connection end... its on different router or on the same router...

so as per your connectivity you can use various tools like MLPPP, HSRP or static routes...

rate this post if it helps

regards

Devang

Hi Devang,

Thanks for reply. It is connected on a single router.

i think here you can do it by configuring 4 default route with the same AD... so you can have loadbalancing among all the link...

other thing you can have MLPPP but this configuration need point to point connection so you have to go for PPPoE or PPPoA...then you can create virtual templet or you can use the MLPPP... i m not sure about it but check it out... otherwies you can do it using the four default route with the same AD...

hope this helps you

rate this post if it helps

regards

Devang

rajinikanth
Level 3
Level 3

Do you have 4 adsl modems connected to 4 interfaces on router same router

yeah...

Hi ,

About getting dynamic Ips on ur router is possible by setting your adsl modems to bridge mode.

Try using this config to create dialer interface on ur router:

interface FastEthernet0/1 (depending on the inteface ur modem connected)

description ADSL Internet connection

no ip address

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

and

!

interface Dialer1

ip address dhcp

no ip unreachables

no ip proxy-arp

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname

ppp chap password 7

!

Try configuring a single dialer interface for each connection .

Tell me if this helps

Thanks

Raj

Hello,

in addition to the other posts, here is a sample configuration for 4 links on the same router configured for load balancing. At the bottom of this post, you can find a couple remarks regarding this configuration:

R1 Configuration

ip cef

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

interface ATM0.2 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 2

!

interface ATM0.3 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 3

!

interface ATM0.4 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 4

!

interface Dialer1

description ISP1_Connection_1

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

interface Dialer2

description ISP1_Connection_2

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 2

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

interface Dialer3

description ISP1_Connection_3

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 3

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

interface Dialer4

description ISP1_Connection_4

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 4

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

ip nat inside source route-map ISP1_Connection_1 interface Dialer1 overload

ip nat inside source route-map ISP1_Connection_2 interface Dialer2 overload

ip nat inside source route-map ISP1_Connection_3 interface Dialer3 overload

ip nat inside source route-map ISP1_Connection_4 interface Dialer4 overload

!

access-list 1 permit 192.168.1.0

!

route-map ISP1_Connection_1 permit 10

match ip address 1

match interface Dialer1

!

route-map ISP1_Connection_2 permit 10

match ip address 1

match interface Dialer2

!

route-map ISP1_Connection_3 permit 10

match ip address 1

match interface Dialer3

!

route-map ISP1_Connection_4 permit 10

match ip address 1

match interface Dialer4

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

ip route 0.0.0.0 0.0.0.0 Dialer3

ip route 0.0.0.0 0.0.0.0 Dialer4

!

dialer-list 1 protocol ip permit

The following applies:

- the use of four static routes will allow load-balancing over the four links and provide redundancy at the same time

- the NAT configuration will dynamically choose the NAT'ed address depending on which interface CEF has been chosen to send the packet out of

- enabling CEF with four default routes will by default load balance per-destination, which means for every source and destination address pair, CEF creates a hash and chooses one of the routes in the routing table.

- enabling CEF on a router will load balance outgoing traffic only, not incoming traffic. If your ISP uses Cisco, you could ask for the ISP to enable CEF on their end as well, which would result in inbound load balancing.

To verify load balancing, use the EXEC command:

sh ip cef 0.0.0.0

Hope this makes sense...

Regards,

GNT

@GNT: you have 4 lines over 1 ATM IF? i'm not a technician .. but how is that possible?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: