cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3369
Views
16
Helpful
30
Replies

Load Sharing with the Loopback Address as a BGP Neighbor - BGP session down

Hello,

I have one scenario. One end is using Cisco router and the other end using Juniper router have been configured eBGP Multihoming using loopback IP. At each router, two interface have been configured and both static route has been pointing to the eBGP loopback IP. The problem is, for example if the

1st interface/link down, the BGP also will down eventhough the 2nd interface/link up. By right for Multihoming BGP at least one physical link should be up to keep to BGP up. Any one have experienced this sort of problem before? Need some help. Thanks in advance!

Regards,

arel

30 Replies 30

lgijssel
Engager
Engager

Having a look at some configuration would be helpful.

Cisco side should contain this:

neighbor 2.2.2.2 remote-as xxxx

neighbor 2.2.2.2 update-source loopback 0

neighbor 2.2.2.2 ebgp-multihop [ttl]

Are you sure both paths are working?

Verify both paths carefully, using static routes may not be the best way to create failover redundancy.

regards,

Leo

Hi Leo,

Thanks a lot for your feedback. Both path are working and all configuration you mention above already included. Please look example config below. If one link down the BGP will drop. Any idea what cause this problem? Thank you

----------------------------

CISCO BGP config

----------------------------

neighbor 2.2.2.2 remote-as xx

neighbor 2.2.2.2 description "SINGA-STM4x2"

neighbor 2.2.2.2 ebgp-multihop 2

neighbor 2.2.2.2 password 7 xxxxxx

neighbor 2.2.2.2update-source Loopback0

neighbor 2.2.2.2 activate

neighbor 2.2.2.2 remove-private-as

neighbor 2.2.2.2 soft-reconfiguration inbound

neighbor 2.2.2.2 prefix-list in-filter in

neighbor 2.2.2.2 prefix-list xxxxxx out

neighbor 2.2.2.2 route-map xxxxx in

neighbor 2.2.2.2 filter-list 1 out

ip route 2.2.2.2 255.255.255.255 x.x.x.33

ip route 2.2.2.2 255.255.255.255 x.x.x.21

Loopback0            1.1.1.1

Juniper BGP config

==============

set routing-options static route 1.1.1.1/32 next-hop x.x.x.22

set routing-options static route 1.1.1.1/32 next-hop x.x.x.34

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 descriptionn "XXXX with Multihop-EBGP"

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 multihop ttl 2

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 local-address 2.2.2.2

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 import no-default

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 import no-smallprefixes

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 import rfc1918-dsua

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 import XXXXIN

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 import XXX-IN

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 family inet any prefix-limit maximum 1000

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 family inet any prefix-limit teardown 90

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 family inet any prefix-limit teardown idle-timeout forever

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 authentication-key "xxxxxx"

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 export no-default

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 export no-smallprefixes

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 export rfc1918-dsua

set protocols bgp group CUSTOMERS neighbor 1.1.1.1 peer-as XXXX

Regards,

arel

Hi,

What type of WAN link are you using?

Regards.

Alain.

Don't forget to rate helpful posts.

Hi Alain,

Do you mean interface? POS interface. Thanks

Regards,

arel

Yes and what encapsulation are you using?

Regards.

Alain.

Don't forget to rate helpful posts.

encapsulation PPP

Regards,

arel

Hi,

Can you post output of sh ip route static and sh ip int br | exc una  when both links are up then when one is down

as well as sh run interface.

Regards.

Alain.

Don't forget to rate helpful posts.

Peter Paluch
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

Gentlemen,

In addition to other requested information, would it be possible to post the (complete) output of the show ip bgp neighbor 2.2.2.2 command on the Cisco side?

Best regards,

Peter

Hi Guys,

Maybe later will do some failover test and capture debugging for both router to check BGP and TCP transaction. I think there is no wrong with the configuration right or am I missing any configuration? because when both links is up no issue arise...

==================

Cisco interface config

==================

interface POS7/1

description XXXXX

ip address X.X.X.22 255.255.255.252

no ip directed-broadcast

encapsulation ppp

ip route-cache flow sampled input

crc 32

pos framing sdh

pos flag s1s0 2

!

interface POS7/2

description XXXX

ip address X.X.X.34 255.255.255.252

no ip directed-broadcast

encapsulation ppp

ip route-cache flow sampled input

crc 32

pos framing sdh

pos flag s1s0 2

!

=====

Juniper

======

- configuration is the same for other interface

> show configuration interfaces so-6/1/1

clocking external;

encapsulation ppp;

sonet-options {

    fcs 32;

    no-payload-scrambler;

}

unit 0 {

    description "XXXXX"

    family inet {

        rpf-check {

            fail-filter URPF-FILTER;

            mode loose;

        }

        filter {

            input CFLOW;

        }

        address x.x.x.21/30;

    }

}

Regards,

Arel

i'm just curious..erm could be this related to problem at lower layer? example on transmission issue?

Regards,

arel