cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
305
Views
0
Helpful
5
Replies
Beginner

Missing a route somewhere

I'm not new to Cisco routing and switching by any means, but I seem to be missing a basic routing issue somewhere.  It looks like a rookie mistake, probably.  I could use a second set of eyes on it.  Basically, I have a remote switch that I cannot ping or telnet/ssh into directly.  I have to get into the router in that remote office, then telnet into the switch from the router.  That switch also cannot ping back to the gateway in my office.  Here is a diagram of the situation:

Basically, I have a 3750X layer 3 switch acting as my core network router.  It is the gateway for many of my subnets that traverse my network, such as 10.1.250.0 and 10.1.252.0.  That switch is directly connected to a 2811 router that terminates a few Point to Point T1's.  One of those T1's in question goes to a remote office and terminates on a 2820XM router.  That router is then connected to a 3524PWR switch.  It is the 3524 that I cannot ping or manage from my corporate office.

Connectivity:

  • The remote 2620 can ping and telnet into the 3524 (10.1.250.50)
  • Neither the local 2811 nor the local 3570x can ping the remote 3524
  • The remote 3524 cannot ping either of the local devices
  • I am using eigrp as my standard dynamic routing protocol

Configs

Below are the main portions of my configs, including interfaces and route entries.  I have also listed pertinent portions of my route tables.

Local 3750x:

interface FastEthernet0
 no ip address
 no ip route-cache cef
 no ip route-cache
!
interface GigabitEthernet1/0/8
 switchport access vlan 252
 speed 100
 duplex full
!
interface Vlan30
 description Management VLAN 30
 ip address 10.1.250.1 255.255.255.0
!
interface Vlan252
 ip address 10.1.252.101 255.255.255.252
!
router eigrp 7
 network 10.0.0.0
 redistribute static

Gateway of last resort is 10.1.252.250 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 10.1.252.250
      10.0.0.0/8 is variably subnetted, 42 subnets, 5 masks

D        10.1.24.0/22 [90/2181376] via 10.1.252.102, 4w6d, Vlan252
C        10.1.250.0/24 is directly connected, Vlan30
L        10.1.250.1/32 is directly connected, Vlan30
C        10.1.252.100/30 is directly connected, Vlan252
L        10.1.252.101/32 is directly connected, Vlan252
D        10.1.252.112/30 [90/2178816] via 10.1.252.102, 4w6d, Vlan252

Local 2811:

interface FastEthernet0/0
 ip address 10.1.252.102 255.255.255.252
 duplex full
 speed 100

interface Serial0/1/0:0
 ip address 10.1.252.113 255.255.255.252

router eigrp 7
 network 10.0.0.0
 redistribute static

Gateway of last resort is 10.1.252.101 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/28416] via 10.1.252.101, 3d15h, FastEthernet0/0
      10.0.0.0/8 is variably subnetted, 37 subnets, 5 masks
D        10.1.24.0/22 [90/2181120] via 10.1.252.114, 3d15h, Serial0/1/0:0
D        10.1.250.0/24 [90/28416] via 10.1.252.101, 3d15h, FastEthernet0/0
D        10.1.250.16/29 [90/31232] via 10.1.252.101, 3d15h, FastEthernet0/0
D        10.1.250.24/29 [90/28928] via 10.1.252.101, 3d15h, FastEthernet0/0
C        10.1.252.112/30 is directly connected, Serial0/1/0:0
L        10.1.252.113/32 is directly connected, Serial0/1/0:0
D        10.1.252.248/29 [90/28416] via 10.1.252.101, 3d15h, FastEthernet0/0

Remote 262XM:

interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 10.1.24.1 255.255.255.0
 ip helper-address 10.1.2.10
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 10.1.25.1 255.255.255.0
 ip helper-address 10.1.2.10
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 10.1.250.49 255.255.255.0
!
interface Serial0/0
 ip address 10.1.252.114 255.255.255.252
 ip summary-address eigrp 7 10.1.24.0 255.255.252.0 5
!
router eigrp 7
 passive-interface FastEthernet0/0.10
 passive-interface FastEthernet0/0.20
 passive-interface FastEthernet0/0.30
 network 10.0.0.0
 no auto-summary

Gateway of last resort is 10.1.252.113 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 35 subnets, 4 masks
D       10.1.252.248/29 [90/2181376] via 10.1.252.113, 6d21h, Serial0/0
C       10.1.25.0/24 is directly connected, FastEthernet0/0.20
C       10.1.24.0/24 is directly connected, FastEthernet0/0.10
D       10.1.24.0/22 is a summary, 4w6d, Null0
C       10.1.252.112/30 is directly connected, Serial0/0
D       10.1.252.100/30 [90/2181120] via 10.1.252.113, 6d21h, Serial0/0
D       10.1.252.108/30 [90/2690560] via 10.1.252.113, 3d15h, Serial0/0
D       10.1.252.104/30 [90/2690560] via 10.1.252.113, 6d21h, Serial0/0
D       10.1.250.56/29 [90/2181888] via 10.1.252.113, 6d21h, Serial0/0
D       10.1.250.32/29 [90/2184192] via 10.1.252.113, 6d21h, Serial0/0
D       10.1.250.16/29 [90/2184192] via 10.1.252.113, 6d21h, Serial0/0
D       10.1.250.24/29 [90/2181888] via 10.1.252.113, 6d21h, Serial0/0
C       10.1.250.0/24 is directly connected, FastEthernet0/0.30
D       10.1.248.0/24 [90/2181632] via 10.1.252.113, 6d21h, Serial0/0
D*EX 0.0.0.0/0 [170/2181376] via 10.1.252.113, 6d21h, Serial0/0

Remote 3524PWR

interface VLAN30
 description Management Interface
 ip address 10.1.250.50 255.255.255.252
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 10.1.250.1

 

Can anyone see what I'm missing?  I'm thinking the problem is probably with my 2620XM.

 

Thanks

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Master

In addition to the issues

In addition to the issues that Reza identifies I see this issue. You have configured this on the 3750

interface Vlan30
 description Management VLAN 30
 ip address 10.1.250.1 255.255.255.0

and then on the 3524 you have configured vlan 30 and subnet 10.1.250.0. The use of vlan 30 in two different parts of the network may be a bit confusing but it is not necessarily a problem. But the fact that you have the same subnet in two different parts of the network is a big problem. The 3750 believes that 10.1.250.0 is locally connected and will never go to the 2811 or over the T1 to try to get to that subnet somewhere else.

 

HTH

 

Rick

HTH

Rick

View solution in original post

5 REPLIES 5
Highlighted
VIP Expert

On the 3524 your default

On the 3524 your default-gateway is 10.1.250.1.  It should be the interface on the 2620xm, which is 10.1.250.49

also, the mask for subnet 10.1.250.0 on the 2620xm is 255.255.255.0 but on the 3524 the mask is 255.255.255.252

Can you fix that and test again?

HTH

 

Highlighted
Beginner

Thanks for pointing out those

Thanks for pointing out those two obvious mistakes.  I changed the subnet on my 3524 to:

ip address 10.1.250.50 255.255.255.0

And I set the default gateway to 10.1.250.49

But for some reason, I still can't seem to bridge the gap.  I still can't ping past the 2620XM to or from the 3524.  Any other ideas?

Thanks again for taking the time!

Highlighted
Hall of Fame Master

In addition to the issues

In addition to the issues that Reza identifies I see this issue. You have configured this on the 3750

interface Vlan30
 description Management VLAN 30
 ip address 10.1.250.1 255.255.255.0

and then on the 3524 you have configured vlan 30 and subnet 10.1.250.0. The use of vlan 30 in two different parts of the network may be a bit confusing but it is not necessarily a problem. But the fact that you have the same subnet in two different parts of the network is a big problem. The 3750 believes that 10.1.250.0 is locally connected and will never go to the 2811 or over the T1 to try to get to that subnet somewhere else.

 

HTH

 

Rick

HTH

Rick

View solution in original post

Highlighted
Beginner

Richard, you are correct.  I

Richard, you are correct.  I had some overlapping subnets that caused the problem.  I changed the subnet on the 3750x to 255.255.255.240 to encompass the locally managed devices, and I can get to my other switch now.  Thanks so much for taking a look at what I rightly guessed was a rookie mistake. :)

Thanks

Highlighted
Hall of Fame Master

I am glad that my response

I am glad that my response did help you to understand and correct the mistake. It is an easy mistake to make and sometimes not so easy to recognize. Thank you for using the rating system to mark this question as answered. This will help to signal to other readers that there is helpful information in this discussion.

 

HTH

 

Rick

HTH

Rick
CreatePlease to create content