cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1450
Views
30
Helpful
36
Replies

MultiLink for point to point connection

ajurado25
Level 1
Level 1

Hi,

We currently have two t1 lines from the corporate office to our warehouse. The t1's on both sides are connected to two wics on 1721 routers. We are attempting to combine the two t1s to get the full 3mbps bandwidth. I tried using the ip cef command but it is not available (even though I'm running IOS 12.1). I am now trying to setup multilink but it just doesn't work. I'm using the same IP scheme on both sides (the current setup has the t1s within the same bridge-group). I've provided my running config.

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Corporate_PTP_Router

!

enable password xxxxxx

!

!

!

!

!

memory-size iomem 25

ip subnet-zero

no ip routing

!

!

!

!

interface Serial0

ip address 192.168.1.20 255.255.255.0

no ip route-cache

service-module t1 clock source internal

bridge-group 1

!

interface Serial1

ip address 192.168.1.24 255.255.255.0

no ip route-cache

service-module t1 clock source internal

bridge-group 1

!

interface FastEthernet0

ip address 192.168.1.20 255.255.255.0

no ip route-cache

speed auto

bridge-group 1

!

ip classless

no ip http server

!

bridge 1 protocol ieee

!

line con 0

transport input none

line aux 0

line vty 0 4

password xxxxx

login

!

end

I setup the multilink interface on the corporate side first but I cannot ping the multilink IP. I then proceed to setup the multilink IP on the warehouse side and i can ping that IP address but only from the corporate router.

Any ideas?????

36 Replies 36

I'm glad we could help. Be sure to rate any posts you found helpful so other folks will know it was useful information. Helps them navigate the noise, so to speak.

DNS may also need to be updated with your hosts' new IP addresses.

I'm not so familiar with Dameware. I was looking at their website, and they seem to rely on NetBIOS over TCP/IP for some communications, especially name resolution. But I'm not certain.

Do you have any issue connecting to shares across the WAN?

If this is the case, (are some of these boxes Win9x or WinNT?) then you will want to enable WINS on a domain controller, and add the WINS entries to either DHCP or host configuration. I seem to remember you will want to change the netbios node type to hybrid (0x8) if I recall correctly.

Another test, is to verify that you can open port 6129 accross the WAN. You can do this by typing:

"telnet x.x.x.x 6129" where x.x.x.x is the client IP address or devicename as known to dameware. Telnet should tell you if it either can't find the host, or can't open the port.

DNS was updated when i made a change I tested this by having someone connect to a warehouse workstations using RDP from the corporate office.

There doesn't seem to be any issues with the workstations communicating across the WAN to the corporate side. They are able to browse any network shares. All workstations are XP and the domain is a Windows 2000/2003 enviroment only using TCP/IP and DNS. I then tried to connect via dameware to one machine using the IP address but it wouldn't let me connect.

I had also checked to see if port 6129 was open across the WAN to one of the warehouse workstations (using telnet) but it shows as being closed.

I then checked to see if there were any access lists on the routers but there weren't any.

It seems to me that the port is closed or the routers are not forwarding anything using port 6129. This feature was working fine before the change so I know that there isn't any client side firewalls on the warehouse workstations preventing me from connecting, which leads me to think that its something with the router config. I will post the running configs for both routers.

Corporate config:

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Corporate_PTP_Router

!

enable password xxxxx

!

!

!

!

!

memory-size iomem 25

ip subnet-zero

!

!

!

!

interface Multilink1

ip address 192.168.254.1 255.255.255.0

no cdp enable

ppp multilink

no ppp multilink fragmentation

multilink-group 1

!

interface Serial0

no ip address

encapsulation ppp

no fair-queue

service-module t1 clock source internal

ppp multilink

multilink-group 1

!

interface Serial1

no ip address

encapsulation ppp

no fair-queue

service-module t1 clock source internal

ppp multilink

multilink-group 1

!

interface FastEthernet0

ip address 192.168.1.20 255.255.255.0

speed auto

bridge-group 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.18

ip route 192.168.2.0 255.255.255.0 192.168.254.2

no ip http server

!

bridge 1 protocol ieee

!

line con 0

transport input none

line aux 0

line vty 0 4

password xxxxx

login

!

end

Warehouse config:

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Warehouse_PTP_Router

!

enable password xxxxx

!

!

!

!

!

memory-size iomem 25

ip subnet-zero

!

!

!

!

interface Multilink1

ip address 192.168.254.2 255.255.255.0

no cdp enable

ppp multilink

no ppp multilink fragmentation

multilink-group 1

!

interface Serial0

no ip address

encapsulation ppp

no fair-queue

ppp multilink

multilink-group 1

!

interface Serial1

no ip address

encapsulation ppp

no fair-queue

ppp multilink

multilink-group 1

!

interface FastEthernet0

ip address 192.168.2.1 255.255.255.0

speed auto

bridge-group 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.254.1

no ip http server

!

bridge 1 protocol ieee

!

line con 0

transport input none

line aux 0

line vty 0 4

password xxxxx

login

!

end

Another question.

Do I need to add a static route to the warehouse router identifying the corporte network?

192.168.1.0 255.255.255.0 192.168.254.1

I ask because I tried to ping from the warehouse router the email server and I did not get any replies.

Thanks.

No, you shouldn't need to. Your default route, 0.0.0.0 0.0.0.0 via 192.168.254.1 should take care of that.

You might try a trace route from the email server to the warehouse computer, and visa versa, to see where this traffic is going.

What is the ip, mask, and default gateway of the email server?

Also, wrt to another post, I don't see anything in these configs that would block dameware nor ICMP. Does ping fail from HQ dameware host to warehouse dameware client as well?

If so, these problems are probably related.

the multilink config should be:

Corporate_PTP_Router

int s0

enc ppp

ppp multi

multilink-group 1

int s1

enc ppp

ppp multi

multilink-group 1

interface Multilink1

ip address 192.168.1.24 255.255.255.0

Warehouse_Router

ip routing

int s0

enc ppp

ppp multi

multilink-group 1

int s1

enc ppp

ppp multi

multilink-group 1

interface Multilink1

ip address 192.168.1.26 255.255.255.0

Actually, the multilink IP needs to be on a different subnet from the Fastethernet interface (currently 192.168.1.0/24) when ip routing is enabled.

Review Cisco Networking for a $25 gift card