cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
375
Views
0
Helpful
3
Replies

OSPF non backbone area

yang yang
Beginner
Beginner

HI ALL

    It is about following topology, the backbone area cut the area 1 in to two parts. now the plan is not to use virtual links to connect area 1. will it has any route problem?  or any kind of unknow problem? the following are some captures. from what i test. if the area 1 cut by backbone the backbone, ospf database can see all the  non backbone route  from area 1 other then that.( if change R1 to area 2 will see different network from different area) . i do not see any problem the ping area working as well.

    Is that means to cut the non backbone are to two using backbone area is ok ?

             R1--ospf 200 area 1-- R2--ospf 200 area 0--R3--ospf 200 area 1--R4

          the following area the connection

        R1 Fe0 10.10.10.1 OSPF 200 area 1 ----- Fe0 10.10.10.2 OSFP 200 area 1  R2  

        R2 Fe1 10.10.20.2 OSPF 200 area 0----- F0 10.10.20.1 OSPF 200 area 0 R3 

       R3 F2 10.10.30.2 ospf 200 area 1-----  F0 10.10.30.1 OSPF 200 area 1 R4


yangyang_21-1669611780099.png

 

R1

interface FastEthernet0
ip address 10.10.10.1 255.255.255.0
ip ospf 200 area 1
duplex auto
speed auto
end

Router#show run | sec ospf
ip ospf 200 area 1
router ospf 200
router-id 10.10.10.1

yangyang_0-1669609753570.png

yangyang_15-1669610418807.pngyangyang_16-1669610437179.png

 

R2

router ospf 200
router-id 10.10.10.2

interface GigabitEthernet0/1/7
ip address 10.10.10.2 255.255.255.0
ip ospf 200 area 1
negotiation auto
end

interface TenGigabitEthernet0/0/2
ip address 10.10.20.2 255.255.255.0
ip ospf 200 area 0
cdp enable
arp timeout 295
end

yangyang_1-1669609893641.png

yangyang_2-1669609915491.png

yangyang_3-1669609993579.png

yangyang_8-1669610207942.png

yangyang_9-1669610222929.png

 

     R3     

router ospf 200
router-id 10.10.20.2

interface TenGigabitEthernet0/1/3
ip address 10.10.20.1 255.255.255.0
ip ospf 200 area 0
end

cl2# show run interface te 0/1/5
Building configuration...

Current configuration : 98 bytes
!
interface TenGigabitEthernet0/1/5
ip address 10.10.30.1 255.255.255.0
ip ospf 200 area 1
end

yangyang_4-1669610038860.png

yangyang_5-1669610055389.png

yangyang_6-1669610143773.png

yangyang_7-1669610167932.png

 

       R4


router ospf 200
router-id 10.10.30.2

interface Ethernet1/30/3
ip router ospf 200 area 0.0.0.1

 

yangyang_11-1669610309972.pngyangyang_12-1669610330040.pngyangyang_13-1669610348422.pngyangyang_14-1669610369721.png

 

 

if i change  R1-R2 to area 2

R2 result

yangyang_17-1669611059060.png

 

yangyang_18-1669611076017.png

R3 result

yangyang_19-1669611321755.png

 

 

 

 

1 Accepted Solution

Accepted Solutions

yang yang
Beginner
Beginner

here i fund the result.

 the RFC

RFC 2328                     OSPF Version 2                   April 1998


        of the graph connects to a network, or is itself a point-to-
        point network.  In either case, the edge is colored with the
        network's Area ID.

        A group of edges, all having the same color, and interconnected
        by vertices, represents an area.  If the topology of the
        Autonomous System is intact, the graph will have several regions
        of color, each color being a distinct Area ID.

        When the AS topology changes, one of the areas may become
        partitioned.  The graph of the AS will then have multiple
        regions of the same color (Area ID).  The routing in the
        Autonomous System will continue to function as long as these
        regions of same color are connected by the single backbone
        region.

 show same area present at different physical location  is work . but if have  network summary configure could have connectivity problem following are the links form CISCO community

 

Same OSPF area different physical locations

https://community.cisco.com/t5/routing/same-ospf-area-different-physical-locations/td-p/4167200

View solution in original post

3 Replies 3

yang yang
Beginner
Beginner

does this mean if both end do not announce same subnet this top will be ok?

yang yang
Beginner
Beginner

here i fund the result.

 the RFC

RFC 2328                     OSPF Version 2                   April 1998


        of the graph connects to a network, or is itself a point-to-
        point network.  In either case, the edge is colored with the
        network's Area ID.

        A group of edges, all having the same color, and interconnected
        by vertices, represents an area.  If the topology of the
        Autonomous System is intact, the graph will have several regions
        of color, each color being a distinct Area ID.

        When the AS topology changes, one of the areas may become
        partitioned.  The graph of the AS will then have multiple
        regions of the same color (Area ID).  The routing in the
        Autonomous System will continue to function as long as these
        regions of same color are connected by the single backbone
        region.

 show same area present at different physical location  is work . but if have  network summary configure could have connectivity problem following are the links form CISCO community

 

Same OSPF area different physical locations

https://community.cisco.com/t5/routing/same-ospf-area-different-physical-locations/td-p/4167200

I will run lab and see exact the effect of partition the non backbone area.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers