cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
225
Views
0
Helpful
3
Replies

OSPF Routes is showing wrong information

karamalomari
Beginner
Beginner

I have a network where I have one central site and multiple remote sites.

I have configured OSPF on all the routers and neighbor ship is acheived.

I have checked the ospf routes on site C and found that site C is seeing the routes to site B directly as if there are direct connection between them but there is NO direct link.

If i configure ip ospf point-to-point on the main Router (Site A), will this eliminate this behavior and routes in Site C for reaching Site B will be shown through Site A?

 

Site A Router Config:

router ospf 50

network 1.1.1.0 0.0.0.255 area 0

int T0/1/0

ip add 1.1.1.1 255.255.255.0

ip ospf priority 150

no negotiation auto

!

 

Site B Router Config:

router ospf 1

redistribute connected subnets

redistribute static subnets

network 1.1.1.0 0.0.0.255 area 0

!

int G1/1/1

no switchport

ip add 1.1.1.2 255.255.255.0

!

 

Site c Router Config:

router ospf 1

redistribute connected subnets

redistribute static subnets

network 1.1.1.0 0.0.0.255 area 0

!

int G1/1/1

no switchport

ip add 1.1.1.3 255.255.255.0

!

3 Replies 3

David Ruess
VIP Rising star VIP Rising star
VIP Rising star

Hello,

 

Can you provide a diagram. It looks like you have a mesh topology (all Interfaces on same subnet). Can you also provide a show up route to show specifically what networks Router C is learning.

 

Additionally it looks like you have router A configured as wanting to be the DR. Router B could be sending networks to the DR and sending them to Router C. This is normal behavior. Also keep in mind that all OSPF Routers in the area will have full visibility of all routes. That is the nature of link state protocols.  

 

Do all routers have neighborship with each other?

 

If you do P2P I believe it will allow only one connection and kill the other neighbor depending on your setup.

 

-David

paul driver
VIP Expert VIP Expert
VIP Expert

Hello

It most probably be the ospf network type.

The next hop address of a a route from a ospf broadcast network be of the interface from the originating router, from a P2P network type this is based on the router that is advertising the route ( its direct neighbor) 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

MHM Cisco World
VIP Mentor VIP Mentor
VIP Mentor

The HQ and site how it connect via tunnel ?

from ccie doc. This designs need to config 

1-network broadcast 

2- config ospf priority to sure that the DR is HQ

 

and if you can share topology.

p2p will make ospf flapping if I am right.

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers