03-18-2023 05:24 PM
Hi,
Here DMVPN is working fine i can ping from hub to spoke
But from Hub to Vios I am running ospf 1
this is the config
Vios
int gig 0/0
ip add 10.11.3.1
no sh
ip ospf 1 area 0
On hub router
int gig 0/1
ip add 10.11.3.1
no sh
ip ospf 1 area 0
So i can't ping 10.11.3.1 and lo0 1.1.1.1 from spoke
but i can ping 10.11.3.2 which is on Hub router
so whats the problem
Solved! Go to Solution.
03-18-2023 05:41 PM
Why you use ibgp between two sites?
This second post And I dont get why?
03-18-2023 05:56 PM
First start with IP address: (both the interface configured same IP address, so correct that one and test it)
ip add 10.11.3.1
post-show run from all device and show IP ospf neigh and show IP route information
03-18-2023 05:41 PM
Why you use ibgp between two sites?
This second post And I dont get why?
03-18-2023 05:55 PM
I am using ibgp because i want to demonstrate that R2 and R4 two router are my ISP and the route between hub and R2, R4 and spoke are static
03-18-2023 05:56 PM
First start with IP address: (both the interface configured same IP address, so correct that one and test it)
ip add 10.11.3.1
post-show run from all device and show IP ospf neigh and show IP route information
03-18-2023 06:11 PM
Router#sh run
Router#sh running-config
Building configuration...
Current configuration : 3069 bytes
!
! Last configuration change at 00:14:17 UTC Sun Mar 19 2023
!
version 15.9
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet0/0
ip address 10.11.3.1 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
router ospf 1
router-id 1.1.1.1
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 ioam timestamp
!
!
!
control-plane
!
banner exec ^C
--------------------------------------------------------------------
Hub#sh run
Building configuration...
Current configuration : 3504 bytes
!
! Last configuration change at 01:01:36 UTC Sun Mar 19 2023
!
version 15.9
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Hub
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
ip ospf 1 area 0
!
interface Tunnel0
ip address 172.16.10.1 255.255.255.0
no ip redirects
ip mtu 1400
no ip next-hop-self eigrp 100
no ip split-horizon eigrp 100
ip nhrp authentication cisco
ip nhrp network-id 1
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 123
!
interface GigabitEthernet0/0
ip address 100.1.2.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 10.11.3.2 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
!
router eigrp 100
network 10.0.0.0
network 172.16.0.0
redistribute ospf 1
!
router ospf 1
router-id 10.10.10.10
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 100.1.2.2
!
ipv6 ioam timestamp
!
!
!
control-plane
!
banner exec ^C
----------------------------------------------------------------------------------
r2#sh run
Building configuration...
Current configuration : 3414 bytes
!
! Last configuration change at 01:01:55 UTC Sun Mar 19 2023
!
version 15.9
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 100.0.0.3 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet0/0
ip address 100.1.2.2 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 100.0.3.1 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
router ospf 1
router-id 100.0.0.3
!
router bgp 1
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 100.0.0.4 remote-as 1
neighbor 100.0.0.4 update-source Loopback0
!
address-family ipv4
network 100.0.3.0 mask 255.255.255.0
network 100.1.2.0 mask 255.255.255.0
neighbor 100.0.0.4 activate
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 100.1.2.1
!
ipv6 ioam timestamp
!
!
!
control-plane
!
banner exec ^C
--------------------------------------------------------------------------------------------
R4#sh run
*Mar 19 01:03:31.793: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
Current configuration : 3515 bytes
!
! Last configuration change at 01:03:31 UTC Sun Mar 19 2023
!
version 15.9
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 100.0.0.4 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet0/0
ip address 100.0.3.2 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 101.0.0.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
ip address 105.0.0.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
router ospf 1
router-id 100.0.0.4
!
router bgp 1
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 100.0.0.3 remote-as 1
neighbor 100.0.0.3 update-source Loopback0
!
address-family ipv4
network 100.0.3.0 mask 255.255.255.0
network 101.0.0.0 mask 255.255.255.0
network 105.0.0.0 mask 255.255.255.0
neighbor 100.0.0.3 activate
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 101.0.0.0 255.255.255.0 101.0.0.2
ip route 105.0.0.0 255.255.255.0 105.0.0.2
!
ipv6 ioam timestamp
!
!
!
control-plane
!
banner exec ^C
-------------------------------------------------------------------------------------------------
vios9#sh
*Mar 19 01:03:37.242: %SYS-5-CONFIG_I: Configured from console by consolerun
vios9#sh running-config
Building configuration...
Current configuration : 3470 bytes
!
! Last configuration change at 01:03:37 UTC Sun Mar 19 2023
!
version 15.9
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname vios9
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 30.30.30.30 255.255.255.255
!
interface Tunnel0
ip address 172.16.10.3 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication cisco
ip nhrp map multicast 100.1.2.1
ip nhrp map 172.16.10.1 100.1.2.1
ip nhrp network-id 1
ip nhrp nhs 172.16.10.1
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 123
!
interface GigabitEthernet0/0
ip address 105.0.0.2 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
!
router eigrp 100
network 30.0.0.0
network 172.16.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 105.0.0.1
ip route 10.0.0.0 255.255.255.0 Tunnel0
!
ipv6 ioam timestamp
!
!
!
control-plane
!
banner exec ^C
---------------------------------------------------------------------------------------------------
vios8#sh run
Building configuration...
Current configuration : 3430 bytes
!
! Last configuration change at 01:03:12 UTC Sun Mar 19 2023
!
version 15.9
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname vios8
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 25.25.25.25 255.255.255.255
!
interface Tunnel0
ip address 172.16.10.2 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication cisco
ip nhrp map multicast 100.1.2.1
ip nhrp map 172.16.10.1 100.1.2.1
ip nhrp network-id 1
ip nhrp nhs 172.16.10.1
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 123
!
interface GigabitEthernet0/0
ip address 101.0.0.2 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
!
router eigrp 100
network 25.0.0.0
network 172.16.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 101.0.0.1
!
ipv6 ioam timestamp
!
!
!
control-plane
!
banner exec ^C
i make changes 10.11.3.1 to 10.11.3.2 now i can ing 10.11.3.2 from spoke but not 10.11.3.1
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide