03-13-2017 12:04 PM - edited 03-05-2019 08:11 AM
I have a internet connection through cox communications, for the past year or more I've had issues with packet loss sometimes it's around 10% and higher but for the most part it's about 1%. I've complained to them over and over and they tell me the issue is not with them. I've ran some trace routes using a linux box and mtr and uploaded the photo to the post. The first host is my router (cisco 2821) the second host is some cox device even though it has a private IP, it is nothing inside my network.
I was hoping someone could take a quick peak at my config and see if there is anything they see that could possibly cause this issue. I don't think Cox is going to be able to help me much as the last tech (a senior tech) told me the issue was my cable modem was plugged into a power strip and the power strip splits the voltage 6 ways causing the cable modem to fail....so given that comment I don't think I will be getting much help on their end.
Building configuration...
Current configuration : 6207 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router2821
!
boot-start-marker
boot system flash c2800nm-adventerprisek9-mz.151-4.M12a.bin
boot-end-marker
!
!
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
ip domain name Home
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ipv6 unicast-routing
ipv6 cef
ipv6 cef accounting per-prefix
ipv6 dhcp pool Cox
prefix-delegation pool Cox-ipv6
dns-server 2001:4860:4860::8888
dns-server 2001:4860:4860::8844
!
ipv6 inspect name traffic ftp
ipv6 inspect name traffic udp
ipv6 inspect name traffic icmp
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-
revocation-check none
rsakeypair TP-self-signed-
!
!
crypto pki certificate chain TP-self-signed-
certificate self-signed 01
quit
!
!
license udi pid CISCO2821 sn
username admin privilege 15 password 7
!
redundancy
!
!
ip ssh time-out 70
ip ssh authentication-retries 2
ip ssh version 2
!
class-map type inspect match-any All_Protocols
match protocol tcp
match protocol udp
match protocol icmp
!
!
policy-map type inspect Trusted_to_Internet
class type inspect All_Protocols
inspect
class class-default
drop
!
zone security Trusted
zone security Internet
zone-pair security Trusted->Internet source Trusted destination Internet
service-policy type inspect Trusted_to_Internet
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
description WAN
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
ipv6 address dhcp
ipv6 address autoconfig default
ipv6 enable
ipv6 nd autoconfig default-route
ipv6 verify unicast reverse-path
ipv6 dhcp client pd hint ::/60
ipv6 dhcp client pd Cox-ipv6
ipv6 inspect traffic out
ipv6 traffic-filter wan-in in
ipv6 traffic-filter wan-out out
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.1
description LAN
encapsulation dot1Q 1 native
ip address 10.10.1.253 255.255.255.0
ip nat inside
ip virtual-reassembly in
ipv6 address Cox-ipv6 ::/64 eui-64
ipv6 address autoconfig
ipv6 enable
ipv6 nd other-config-flag
ipv6 dhcp server Cox
!
interface GigabitEthernet0/1.2
description Wireless
encapsulation dot1Q 2
ip address 192.168.2.254 255.255.255.0
ip access-group wifi_block in
ip access-group wifi_block out
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
ip dns server
ip nat inside source list NAT interface GigabitEthernet0/0 overload
ip route 10.28.0.0 255.255.255.0 10.10.1.249
ip route 10.29.0.0 255.255.255.0 10.10.1.249
ip route 10.30.0.0 255.255.255.0 10.10.1.249
!
ip access-list extended NAT
deny ip 10.10.1.0 0.0.0.255 192.168.2.0 0.0.0.255
deny ip 192.168.2.0 0.0.0.255 10.10.1.0 0.0.0.255
permit ip any any
ip access-list extended wifi_block
deny ip 192.168.2.0 0.0.0.255 10.10.1.0 0.0.0.255
deny ip 10.10.1.0 0.0.0.255 192.168.2.0 0.0.0.255
permit ip any any
!
ip sla 1
http get http://freedns.afraid.org/dynamic/update.php
frequency 120
ip sla schedule 1 life forever start-time now
access-list 122 deny tcp any eq 22 any
access-list 122 permit tcp 10.0.0.0 0.255.255.255 any
!
!
!
!
snmp-server community fast_stats RO
snmp-server host 10.10.1.249 version 2c
!
!
!
!
ipv6 access-list wan-in
permit icmp any any
permit udp any any eq 546
permit tcp any any established
sequence 100 deny ipv6 any any
!
ipv6 access-list wan-out
permit icmp any any
permit tcp any any
permit udp any any
sequence 100 deny ipv6 any any
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
access-class 122 in
privilege level 15
password 7
transport input ssh
!
scheduler allocate 20000 1000
end
I just want to make sure I don't have something goofed up on my end before I point the finger anymore at Cox.
Thank you for the help and input.
03-13-2017 12:51 PM
Hello,
the only thing I could think of are MTU and MSS settings for the PPPoE connection on the outside interface. Try to add the below (in bold) to your interface configuration:
interface GigabitEthernet0/0
description WAN
ip address dhcp
ip mtu 1492
ip tcp adjust-mss 1452
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
ipv6 address dhcp
ipv6 address autoconfig default
ipv6 enable
ipv6 nd autoconfig default-route
ipv6 verify unicast reverse-path
ipv6 dhcp client pd hint ::/60
ipv6 dhcp client pd Cox-ipv6
ipv6 inspect traffic out
ipv6 traffic-filter wan-in in
ipv6 traffic-filter wan-out out
03-13-2017 12:58 PM
just added those settings to the WAN interface and still having packet loss. Do you think it's possible the piece of equipment at host 2 10.33.192.1 is either overloaded or has a port that is dropping packets?
03-13-2017 01:35 PM
Hello,
I don't see how a power problem could cause packet loss. Either way, can you post the output of:
show interfaces GigabitEthernet0/0
?
03-13-2017 01:47 PM
I don't think it's a power problem either. When he told me that the voltage is split 6 ways when using a power strip I knew he was just trying to play dumb
Router2821#show interfaces gigabitEthernet 0/0
GigabitEthernet0/0 is up, line protocol is up
Hardware is MV96340 Ethernet, address is 001b.d4ee.a600 (bia 001b.d4ee.a600)
Description: WAN
Internet address is 68.102.**.**/20
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1Gbps, media type is T
output flow-control is XON, input flow-control is XON
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/54/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 30000 bits/sec, 60 packets/sec
5 minute output rate 13000 bits/sec, 17 packets/sec
12546318 packets input, 211451445 bytes, 0 no buffer
Received 8973340 broadcasts (0 IP multicasts)
0 runts, 0 giants, 2 throttles
740 input errors, 2 CRC, 0 frame, 0 overrun, 738 ignored
0 watchdog, 0 multicast, 0 pause input
2475415 packets output, 370562418 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 1 pause output
0 output buffer failures, 0 output buffers swapped out
03-13-2017 02:09 PM
Hello,
the 'ignored' errors are usually due to a lack of packet memory buffers. We can try and finetune the buffers. Can you post the output of:
show buffers
03-13-2017 02:14 PM
Router2821#show buffers
Buffer elements:
675 in free list (500 max allowed)
749543 hits, 0 misses, 617 created
Public buffer pools:
Small buffers, 104 bytes (total 50, permanent 50, peak 103 @ 1d20h):
48 in free list (20 min, 150 max allowed)
9398275 hits, 147 misses, 71 trims, 71 created
88 failures (0 no memory)
Middle buffers, 600 bytes (total 49, permanent 25, peak 56 @ 1d20h):
47 in free list (10 min, 150 max allowed)
191871 hits, 102 misses, 59 trims, 83 created
53 failures (0 no memory)
Big buffers, 1536 bytes (total 50, permanent 50, peak 51 @ 1d21h):
48 in free list (5 min, 150 max allowed)
73819 hits, 0 misses, 1 trims, 1 created
0 failures (0 no memory)
VeryBig buffers, 4520 bytes (total 16, permanent 10, peak 16 @ 01:33:27):
16 in free list (0 min, 100 max allowed)
664 hits, 23 misses, 1 trims, 7 created
23 failures (0 no memory)
Large buffers, 5024 bytes (total 4, permanent 0, peak 4 @ 01:37:02):
4 in free list (0 min, 10 max allowed)
13 hits, 10 misses, 15 trims, 19 created
10 failures (0 no memory)
Huge buffers, 18024 bytes (total 2, permanent 0, peak 2 @ 01:37:02):
2 in free list (0 min, 4 max allowed)
3 hits, 7 misses, 15 trims, 17 created
7 failures (0 no memory)
Interface buffer pools:
Syslog ED Pool buffers, 600 bytes (total 133, permanent 132, peak 133 @ 1d20h):
101 in free list (132 min, 132 max allowed)
17427 hits, 0 misses
CD2430 I/O buffers, 1536 bytes (total 1, permanent 0, peak 1 @ 1d20h):
1 in free list (0 min, 0 max allowed)
0 hits, 0 fallbacks
IPC buffers, 4096 bytes (total 2, permanent 2):
1 in free list (1 min, 8 max allowed)
1 hits, 0 fallbacks, 0 trims, 0 created
0 failures (0 no memory)
IPC Medium buffers, 16384 bytes (total 2, permanent 2):
2 in free list (1 min, 8 max allowed)
0 hits, 0 fallbacks, 0 trims, 0 created
0 failures (0 no memory)
IPC Large buffers, 65535 bytes (total 17, permanent 16, peak 17 @ 1d21h):
17 in free list (16 min, 16 max allowed)
0 hits, 0 misses, 2700 trims, 2701 created
0 failures (0 no memory)
Header pools:
Header buffers, 0 bytes (total 768, permanent 768):
256 in free list (128 min, 1024 max allowed)
512 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
512 max cache size, 512 in cache
451 hits in cache, 0 misses in cache
Particle Clones:
1024 clones, 0 hits, 0 misses
Public particle pools:
F/S buffers, 256 bytes (total 768, permanent 768):
256 in free list (128 min, 1024 max allowed)
512 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
512 max cache size, 512 in cache
0 hits in cache, 0 misses in cache
Normal buffers, 1548 bytes (total 768, permanent 768):
768 in free list (128 min, 1024 max allowed)
0 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Private particle pools:
HQF buffers, 0 bytes (total 2000, permanent 2000):
2000 in free list (500 min, 2000 max allowed)
0 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
IDS SM buffers, 240 bytes (total 128, permanent 128):
0 in free list (0 min, 128 max allowed)
128 hits, 0 fallbacks
128 max cache size, 128 in cache
0 hits in cache, 0 misses in cache
GigabitEthernet0/0 buffers, 1536 bytes (total 384, permanent 384):
0 in free list (0 min, 384 max allowed)
384 hits, 0 fallbacks
384 max cache size, 256 in cache
12654132 hits in cache, 0 misses in cache
GigabitEthernet0/1 buffers, 1536 bytes (total 384, permanent 384):
0 in free list (0 min, 384 max allowed)
384 hits, 0 fallbacks
384 max cache size, 256 in cache
2554130 hits in cache, 0 misses in cache
NETGX_CACHE_BUFFERS buffers, 1700 bytes (total 256, permanent 256):
0 in free list (0 min, 256 max allowed)
256 hits, 0 fallbacks
256 max cache size, 256 in cache
0 hits in cache, 0 misses in cache
03-13-2017 02:37 PM
Hello,
here is what I have come up with, based on the output of 'show buffers'. Give those a try and check if the ignored counter is reduced:
buffers small permanent 60
buffers small min-free 30
buffers small max-free 100
buffers middle permanent 35
buffers middle min-free 15
buffers middle max-free 60
buffers verybig permanent 20
buffers verybig min-free 10
buffers verybig max-free 40
buffers large permanent 10
buffers large min-free 5
buffers large max-free 10
buffers huge permanent 4
buffers huge min-free 2
buffers huge max-free 8
Also, check if your IOS supports the global command 'buffers tune automatic'.
03-13-2017 02:44 PM
Thank you for the help. I just changed all the buffers to what you suggest...yes this IOS has buffers tune automatic, should I do that?
03-13-2017 03:09 PM
Hello,
yes, use that command as well. It will auto-adjust the system buffers.
03-13-2017 04:12 PM
I added that command and ran 1000 pings to www.google.com. It shows 987 out of 1000 made it. So is it safe to assume the issue is not on my end? I had someone at work run some pings who live in the same city as I and they are also on Cox and they didn't lose any pings to google but when they would run MTR on their router it would show packet loss on the hops right before they got to me.
03-14-2017 12:21 AM
Hello,
what is your full IP address 68.102.x.x/20 ? I want to send some pings with different packet sizes to see if fragmentation might be the problem. That said, ping losses usually don't mean that much, since most providers mark ICMP traffic with the lowest priority...
Try and ping with a packet size of 1400, and check how that affects packet loss:
Router#ping
Protocol [ip]:
Target IP address: 8.8.8.4
Repeat count [5]: 1000
Datagram size [100]: 1400
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1000, 1400-byte ICMP Echos to 8.8.8.4, timeout is 2 seconds:
Or from a PC command line:
ping -n 1000 -l 1400 8.8.4.4
03-14-2017 06:44 AM
I ran 1000 pings from my router at 1400 byte and lost 10 packets. I also ran 1000 pings from a computer at a different location and ran 1000 1400byte packets and I lost 119 packets.
03-14-2017 08:06 AM
Hello,
what is your public IP address ? I want to run some PING tests from here...
03-14-2017 03:51 PM
68.102.72.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide