cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
301
Views
0
Helpful
4
Replies
joshhaleaos
Beginner

Policy Route Question

I am trying to setup a policy route at a remote site that routes to a different router over BGP/MPLS.  We need to move this network traffic for testing reasons.  Instead of the 10.1.1.0 network going to 1.1.1.10 to get to 10.5.5.0 (another remote site), I need it to go to 2.2.2.1.   Currently, the remote has a subinterface and a policy route that I have already created along with the HQ router..see below.  (Ive changed IPs for security purposes)

REMOTE SITE

interface FastEthernet0/1.10

encapsulation dot1q 10

ip address 10.1.1.1 255.255.255.0

ip flow ingress

ip flow egress

ip policy route-map TEMP-ROUTE

interface Serial0/0/1:1

description OUTSIDE

ip address 1.1.1.1 255.255.255.252

route-map TEMP permit 10

set ip next-hop recursive 10.2.2.1

router bgp 65001

no synchronization

bgp log-neighbor-changes

network 10.1.1.0 mask 255.255.255.0

neighbor 1.1.1.2 remote-as 1  (Provider)

neighbor 1.1.1.2 allowas-in

no auto-summary

B    10.2.2.0 255.255.255.0 [20/0] via 1.1.1.2, 00:00:01

B    10.5.5.0 255.255.255.0 [20/0] via 1.1.1.10, 00:00:01

HQ

interface FastEthernet0/1

description OUTSIDE

ip address 2.2.2.1 255.255.255.252

int fa0/0

description INSIDE

ip address 10.2.2.1

I know 10.2.2.1 is not a next hop so I used the recursive option but it still uses the 1.1.1.10 BGP route to get to 10.5.5.0.  We are tracing from vlan 10 inside a switch with the IP of 10.1.1.254.  Is there a different way to do this?  If not...what am I missing?  Thanks.

Switch#traceroute

Protocol [ip]:

Target IP address: 10.5.5.1

Source address: 10.1.1.254

Numeric display [n]:

Timeout in seconds [3]:

Probe count [3]:

Minimum Time to Live [1]:

Maximum Time to Live [30]:

Port Number [33434]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Type escape sequence to abort.

Tracing the route to 10.5.5.1

  1 10.5.5.1 0 msec 1 msec 2 msec

  2 1.1.1.10 7 msec 4 msec 10 msec

4 REPLIES 4
John Blakley
Advisor

The policy map that's applied is a different name than the route-map that you have created. Is that a typo?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***

It was a good catch by John about the mismatching names. But I believe that there is a more fundamental problem. The route map is setting the next hop to 2.2.2.1. But when you look for 2.2.2 in the routing table it turns out that it results in the next hop really being 1.1.1.2, which is not any different from the normal route.

B    10.2.2.0 255.255.255.0 [20/0] via 1.1.1.2,

HTH

Rick

HTH

Rick

Hey John and Richard,

Thanks for comments and yes...I have two typos in my config. 

1.  The name is wrong on my route-map

2.  My route should be  -->  B    10.2.2.0 255.255.255.0 [20/0] via 2.2.2.1, 00:00:01

Should'nt the config work like shown above or is there another way to do this?  I feel like I am overthinking this at this point.

So how does the remote site get to 2.2.2.1? From what you give us in the original post the remote router has one inside interface and one outside interface. How will it get to 2.2.2.1 that is different from its normal route?

HTH

Rick

HTH

Rick