09-18-2006 03:26 PM - edited 03-03-2019 02:02 PM
i installed a new t1 to the Internet at a remote location. now email traffic to the Internet (yahoo, google) from the remote site is using the new interface. i need to redirect port 25 traffic up to my office then out to the Internet from here.
any ideas?
thanks in advance.
09-18-2006 03:44 PM
Hi Jerry,
How about using route maps? Match port 25 and change the next hop to your location. let me know if this helps.
Thanks,
Karthik Mani.
09-18-2006 07:23 PM
Check below for policy-base routing info. & sample. However, you also need to have proper routing config. at your office for the return traffic.
Hope this helps.
09-19-2006 11:48 AM
jack - i already have this policy map and i think i read you can only have one policy map per interface. is that true?
policy-map ABC_SP
class voice-traffic
priority 800
class voice-signaling
bandwidth 8
class class-default
fair-queue
this is what i plan on using;
access-list 104 permit tcp 172.19.0.0 0.0.255.255 eq 25
access-list 104 permit tcp 10.10.160.0 0.0.0.255 eq 25
access-list 104 permit tcp 10.10.161.0 0.0.0.255 eq 25
route-map smtp1 permit 10
match ip address 104
set ip next hop 172.17.1.5
this is the current interface config;
interface Serial0/2/0
description
bandwidth 1544
ip unnumbered GigabitEthernet0/0.10
no cdp enable
service-policy output ABC_SP
09-19-2006 11:53 AM
yes you do have only single policy map per interface...
regards
Devang
09-19-2006 12:20 PM
ok thanks for the info. whats the difference b/t route map and policy map?
i am going to apply this route map to the interface connected to the ISP so the one policy per interface shouldnt aplly to me - correct? do i even need to apply the map below to an interface?
access-list 104 permit tcp 172.19.0.0 0.0.255.255 eq 25
access-list 104 permit tcp 10.10.160.0 0.0.0.255 eq 25
access-list 104 permit tcp 10.10.161.0 0.0.0.255 eq 25
route-map smtp1 permit 10
match ip address 104
set ip next hop 172.17.1.5
09-19-2006 05:09 PM
Yes, only one policy map per interface. The route-map is used to identify the matching list of the address and set the next step for the matched traffic.
We use route-map to define the policy and apply it to the interface w/ "policy-map" command. So you can set different condidtion in route-map but apply it at a time to the interface.
According to your config., it is correct, you only need to add the "policy-map" command at the interface. Check the link that I provided for the format.
If you have multiple conditions, you can use below syntex :
route-map smtp1 permit 10
match xxx
set ....
route-map smtp1 permit 20
match yyy
set ...
The line no. 10 & 20 is used to set the sequence of each condition. If line 10 map not matched, it will continute to scan the route-map w/ 20.
Hope this helps.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide