09-15-2015 03:18 AM - edited 03-05-2019 02:18 AM
I have set port channel in my switch Cisco 2960, and i receiving the following error since then,
Error: 40371: 5w2d: %SW_MATM-4-MACFLAP_NOTIF: Host e41f.13fc.7781 in vlan 1 is flapping between port Gi0/17 and port Gi0/15
Please guide me how to fix it, config of my switch is pasted below
Config:
version 12.2
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname xxxxx
!
logging count
logging buffered informational
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
username nog1 secret 5 xxxxxxxxxxxxxxxxxxxxxxx
aaa new-model
aaa authentication login console-login local
aaa authentication login vty-login group tacacs+ local
aaa authentication enable default group tacacs+ enable
aaa accounting commands 15 default start-stop group tacacs+
!
aaa session-id common
clock timezone pst 5
system mtu routing 1500
ip subnet-zero
no ip source-route
no ip gratuitous-arps
!
no ip domain-lookup
ip domain-name cdcpak.com
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport trunk allowed vlan 1
switchport mode trunk
speed 1000
!
interface Port-channel2
switchport trunk allowed vlan 1
switchport mode trunk
speed 1000
!
interface GigabitEthernet0/1
description BA_DMZ (Assigned to Po1 for SMG purpose)
switchport trunk allowed vlan 1
switchport mode trunk
speed 1000
channel-group 1 mode active
!
interface GigabitEthernet0/2
description BA_DMZ (Assigned to Po1 for SMG purpose)
switchport trunk allowed vlan 1
switchport mode trunk
speed 1000
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode access
speed 100
duplex full
!
interface GigabitEthernet0/4
description BA_DMZ (Assigned to Po1 for SMG purpose)
switchport trunk allowed vlan 1
switchport mode trunk
speed 1000
channel-group 1 mode active
!
interface GigabitEthernet0/5
switchport mode access
speed 100
duplex full
!
interface GigabitEthernet0/6
switchport mode access
!
interface GigabitEthernet0/7
switchport mode access
!
interface GigabitEthernet0/8
description BA_DMZ (Assigned to Po1 for SMG purpose)
switchport trunk allowed vlan 1
switchport mode trunk
speed 1000
channel-group 1 mode active
!
interface GigabitEthernet0/9
switchport mode access
speed 100
duplex full
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
switchport mode access
speed 100
duplex full
!
interface GigabitEthernet0/12
switchport mode access
speed 100
duplex full
!
interface GigabitEthernet0/13
switchport mode access
speed 100
duplex full
!
interface GigabitEthernet0/14
description BA_DMZ (Assigned to Po2 for SMG purpose)
switchport trunk allowed vlan 1
switchport mode trunk
speed 1000
channel-group 2 mode active
!
interface GigabitEthernet0/15
description BA_DMZ (Assigned to Po2 for SMG purpose)
switchport trunk allowed vlan 1
switchport mode trunk
speed 1000
duplex full
channel-group 2 mode active
!
interface GigabitEthernet0/16
description BA_DMZ (Assigned to Po2 for SMG purpose)
switchport trunk allowed vlan 1
switchport mode trunk
speed 1000
channel-group 2 mode active
!
interface GigabitEthernet0/17
description BA_DMZ (Assigned to Po2 for SMG purpose)
switchport trunk allowed vlan 1
switchport mode trunk
speed 1000
channel-group 2 mode active
!
interface GigabitEthernet0/18
switchport mode access
duplex full
!
interface GigabitEthernet0/19
switchport mode access
duplex full
!
interface GigabitEthernet0/20
switchport mode access
shutdown
speed 100
duplex full
!
interface GigabitEthernet0/21
switchport mode access
media-type rj45
speed 100
duplex full
!
interface GigabitEthernet0/22
switchport access vlan 105
switchport mode access
shutdown
media-type rj45
speed 100
duplex full
!
interface GigabitEthernet0/23
switchport access vlan 105
switchport mode access
shutdown
media-type rj45
speed 100
duplex full
!
interface GigabitEthernet0/24
switchport trunk allowed vlan 99
switchport mode trunk
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan99
ip address 10.x.x.x 255.255.255.0
no ip route-cache
!
no ip http server
ip tacacs source-interface Vlan99
logging 10.2.41.11
logging 10.1.24.81
logging 10.1.222.35
logging 10.2.8.144
access-list 10 permit 10.1.24.21
access-list 10 permit 10.1.26.27
access-list 10 permit 10.1.26.26
access-list 10 permit 10.25.2.26
access-list 10 permit 10.1.26.31
access-list 10 permit 10.2.41.11
access-list 10 permit 10.1.26.33
access-list 10 permit 10.1.26.32
access-list 10 permit 10.2.41.23
access-list 10 permit 10.2.40.24
access-list 10 permit 10.1.24.81
access-list 10 permit 10.1.222.35
access-list 10 deny any log
access-list 11 permit 10.2.41.11
access-list 11 permit 10.1.24.81
access-list 11 permit 10.2.8.144
access-list 11 permit 10.1.222.21
access-list 11 permit 10.1.222.20
access-list 11 permit 10.1.222.10
access-list 11 permit 10.1.222.35
access-list 11 deny any log
no cdp run
snmp-server community t3hz33b RO 11
snmp-server host 10.1.222.35 version 2c t3hz33b
snmp-server host 10.1.24.50 version 2c t3hz33b
snmp-server host 10.1.24.81 version 2c t3hz33b
snmp-server host 10.2.41.11 version 2c t3hz33b
snmp-server host 10.2.8.144 version 2c t3hz33b
tacacs-server host 10.2.8.133 key 7 08154D4205003142425D5C
tacacs-server host 10.1.160.15 key 7 08154D4205003142425D5C
tacacs-server directed-request
radius-server source-ports 1645-1646
!
control-plane
!
banner login ^C This network devi^C
!
line con 0
exec-timeout 15 0
logging synchronous
login authentication console-login
line vty 0 4
access-class 10 in
exec-timeout 15 0
logging synchronous
login authentication vty-login
line vty 5 15
access-class 10 in
exec-timeout 15 0
logging synchronous
login authentication vty-login
!
ntp authentication-key 1 md5 0034120D550E1F0721 7
ntp authenticate
ntp trusted-key 1
ntp clock-period 36029386
ntp server 10.1.222.100 key 1 source Vlan99 prefer
end
09-15-2015 10:00 PM
IBM servers are connected to port gig 0/15 and gig 0/17.
Ok i will configure duplex on g 0/17 as well and update if problem still persists
09-15-2015 10:12 PM
port-channel load-balance src-dst-ip
what to me mention in src-dst-ip ?
09-15-2015 10:49 PM
please read the link in my previous post.
09-22-2015 08:35 AM
Did you ever resolve this flapping issue? I have the same issue on a 2960 and wanted to see what IOS you are using and what the fix was. Can you pls elaborate on this?
Thanks,
Scott
09-22-2015 06:08 PM
Based on his replies, it was not an issue on the switch but on the server that is connected to it. Based on his replies, they did not configure NIC teaming on the server that's why flapping occured
Also, that is also most likely your issue, check the ports that flap on your side, verify the configuration on those ports and if those ports are in etherchannel, make sure the other end is configured for etherchannel as well
09-23-2015 06:26 AM
LJ, thanks for writing. My system is not using Port-channel or Ether-channel config's. It's a Netlab system powered by NDG for educational lab environments.
Thanks,
Scott
09-23-2015 06:59 AM
Check the ports that are flapping then, verify their configuration
Better yet why not create another post for this so we can better assist you xD
09-23-2015 07:22 AM
Thanks LJ,
Visit the link to see my post:
https://supportforums.cisco.com/discussion/12614066/mac-flapping-2960-24tc-l-netlab-pod
09-29-2015 03:44 AM
Nopes, issue didnt resolve yet
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide