09-29-2011 07:43 AM - edited 03-04-2019 01:46 PM
I have a customer that wants to prioritize printing on tcp port 9100 and handheld scanners on tcp port 11590 in addition to the current prioritization of Avaya IP Office VoIP. Web browsing would be the lowest priority out of the three . I'm not quite sure how to do this as I believe this will require an ACL as the packets are not tagged by the respective devices. Here's what I have now on the remote router:
class-map match-any VOIP
match dscp ef
class-map match-any IPSI
match dscp af41
!
!
policy-map AVAYA-QOS
class VOIP
priority percent 40
class IPSI
bandwidth percent 5
class class-default
fair-queue
random-detect
!
!
!
interface Multilink1
ip address 172.16.1.1 255.255.255.0
max-reserved-bandwidth 100
service-policy output AVAYA-QOS
no ip route-cache cef
no ip route-cache
no ip mroute-cache
no cdp enable
ppp multilink
ppp multilink group 1
09-29-2011 07:59 AM
Hi,
The policy you posted is applied on a PPP multilink but are the printers and scanners communicating over this leased line to other offices?
Or is it inside the LAN between VLANs?
If traffic is not QoS marked then yes to match it you'll need an ACL.
Regards.
Alain.
09-29-2011 08:20 AM
Cadet,
Everything goes across the multilink, no VLAN's on either side. What I need direction on are the commands for the ACL and then the corresponding class-map and policy map commands re. the ACL.
Thanks
09-29-2011 10:15 AM
Hi,
then you could do something like that:
ip access-list extended PRINT
permit tcp any any eq 9100
permit tcp any eq 9100 any
ip access-list extended SCAN
permit tcp any any eq 11590
permit tcp any eq 11590 any
class-map match-any PRINT_SCAN
match access-group name PRINT
match access-group name SCAN
policy-map AVAYA-QOS
class VOIP
priority percent 40
class IPSI
bandwidth percent 5
class PRINT_SCAN
bandwidth percent xx
class class-default
fair-queue
random-detect
This would guarantee a minimum bandwidth for this traffic in case of congestion.I would also not put printing and scanning in a LLQ with a priority command like Joseph remrked.
I don't know how much bandwidth you want to set so I left it as xx and what is IPSI so I put the class command just before the class-default but don't forget that the position of the class command is important.
Regards.
Alain.
09-29-2011 10:41 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
This would guarantee a minimum bandwidth for this traffic in case of congestion.I would also not put printing and scanning in a LLQ with a priority command like Joseph remrked.
Sorry, guess I wasn't clear (although I agree you probably wouldn't want either of these traffic types in LLQ).
What I meant for printing traffic, I generally wouldn't recommend it be prioritized over any other traffic, reference the original post's "I have a customer that wants to prioritize printing . . . " In fact, printing is the type of traffic I often like to deprioritize it. In this instance, I would suggest leaving it in the default-class as long as that class is configured with FQ. (With the current policy, assuming this is pre-HQF IOS, and when using class-default FQ, recommend other non-LLQ classes only be used to deprioritize.)
09-29-2011 08:22 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
You're correct, you need an ACL. The ACL would be used by a class-map's match statement (match access-group ?), which in turn would be used by a policy-map statement.
PS:
Generally, would recommend against prioritizing printer traffic.
09-29-2011 11:53 AM
Thanks to you both! We will implement tomorrow.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide