cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
279
Views
0
Helpful
4
Replies

Question about multiple ISP with ASA

sam2000
Level 1
Level 1

Hello everybody,

I have a Cisco ASA 5508, connected to a subnetted private network and two ISPs.

The interfaces connected to both ISPs are DHCP, I can't know in advance what IP I will get when the lease get renewed.

One such interface is configured as follow:

interface GigabitEthernet1/8
description access to ISP1
nameif isp1-cable
security-level 0
ip address dhcp setroute

while the other is configured without the setroute option, because it is not possible to have two default gateway:

interface GigabitEthernet1/7
description access to ISP2
nameif isp2-cable
security-level 0
ip address dhcp

so far so good, but with this configuration I can't have traffic routed via ISP2.

Now, I can't obtain OSPF or BGP access from my ISPs, but still I wish to spread evenly my traffic among the two ISPs. My idea would be to let one ISP be the default route and add some static routes of networks convenientely accessed with the other provider, for example 200.0.0.0/8 on the other ISP.

In theory this should work, but I am at loss in the configuration, because in order to enter static route I need to know the gateway address, and that is provided dynamically to the interface when it gets configured by DHCP; in my example, the command should be:

route isp2-cable 200.0.0.0 255.0.0.0 <gateway> <metric>

but how can I obtain the gateway address before the interface gets configured? Or is there another configuration option that I am overlooking?

thanks in advance to whoever could help me.

best regards

Paolo

 

 

1 Accepted Solution

Accepted Solutions

Sorry  I dont think it possible without PBR which need to know next-hop

So we stuck in redundacy not load balance design 

MHM

View solution in original post

4 Replies 4

change the distance of route of one link 
the command you need is 
dhcp client route distance <>

NOTE:- this command must add before command of 
ip add dhcp setroute

MHM

Screenshot (558).pngScreenshot (559).pngScreenshot (561).png

Thanks MHM, if I understood well with dhcp client route distance I can modify the metric of the DHCP leased gateway I will learn afterwards, so I can have two default routes with different metric. That is nice but it will only serve as a backup, one link fails and the other takes over.

What I am trying to do instead is to have two ISP working at the same time, let's say half Internet on one ISP and the other half on the other ISP (I will cook up a better routing than just 1.0.0.0/1 and 128.0.0.0/1 but this is just to explain my idea), and in order to do that I need to set up some static routes via the gateway I learnt from DHCP... just that I don't know which IP is it until I get it.

Ideally speaking, a routing table specifying the interface itself as a gateway instead of the gateway (having the interface its own default gateway already) would be the ideal solution, but I can't find a way to do that.

thanks

Paolo

 

 

Sorry  I dont think it possible without PBR which need to know next-hop

So we stuck in redundacy not load balance design 

MHM

I see, thanks, I think I may force the cable modem to do also PAT so I'll know the IP for next hop.

Best regards

Paolo

Review Cisco Networking for a $25 gift card