cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7075
Views
5
Helpful
1
Replies

Redistribute EIGRP into another EIGRP with different AS

blue phoenix
Level 1
Level 1

Hi all,

I need some inputs regarding summarization of subnets in eigrp whether named or classic mode.

I have configured 2 EIGRP AS's. 1 and 2, by behavior they won't see each other unless redistribution is applied. Now if the routes from AS 2 is redistributed to AS 1, the routing table of AS 1 will have D EX tagging on the subnets advertised by AS 2. Pretty straight-forward.

 

My issue is when I use the summarization command in order to only see 1 line of route instead of 3 lines, it works if it's on the same AS but it doesn't work if it's on different AS's.  The 192.168.x.x is in the same AS1.  172.234.x.x is on AS2.

Can anybody fill in the gaps?

*OSPF is not configured yet here... so don't worry about it.

 

 

R1#sh ip route eigrp

Gateway of last resort is not set

      172.234.0.0/24 is subnetted, 3 subnets
D EX     172.234.1.0 [170/1024640] via 10.14.0.4, 01:17:59, Ethernet0/0
                     [170/13556702] via 10.12.0.3, 01:17:59, Serial1/0
                     [170/13556702] via 10.12.0.2, 01:17:59, Serial1/0
D EX     172.234.2.0 [170/1024640] via 10.14.0.4, 01:17:48, Ethernet0/0
                     [170/13556702] via 10.12.0.3, 01:17:48, Serial1/0
                     [170/13556702] via 10.12.0.2, 01:17:48, Serial1/0
D EX     172.234.3.0 [170/1024640] via 10.14.0.4, 01:17:37, Ethernet0/0
                     [170/13556702] via 10.12.0.3, 01:17:37, Serial1/0
                     [170/13556702] via 10.12.0.2, 01:17:37, Serial1/0
D     192.168.0.0/22 [90/1024640] via 10.14.0.4, 00:00:08, Ethernet0/0
                     [90/13556702] via 10.12.0.3, 00:00:08, Serial1/0
                     [90/13556702] via 10.12.0.2, 00:00:08, Serial1/0

R2#sh run | s eigrp
router eigrp INE
 !
 address-family ipv4 unicast autonomous-system 1
  !
  af-interface default
   passive-interface
  exit-af-interface
  !
  af-interface Serial1/0
   summary-address 192.168.0.0 255.255.252.0
   no passive-interface
  exit-af-interface
  !
  af-interface Loopback9
   no passive-interface
  exit-af-interface
  !
  af-interface Loopback99
   no passive-interface
  exit-af-interface
  !
  af-interface Loopback999
   no passive-interface
  exit-af-interface
  !
  topology base
   redistribute eigrp 2
  exit-af-topology
  network 10.12.0.0 0.0.0.255
  network 192.168.0.0 0.0.3.255
 exit-address-family
router eigrp CISCO
 !
 address-family ipv4 unicast autonomous-system 2
  !
  af-interface Serial1/0
   summary-address 172.234.0.0 255.255.0.0
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 172.234.1.0 0.0.0.255
  network 172.234.2.0 0.0.0.255
  network 172.234.3.0 0.0.0.255
 exit-address-family

R3#sh run | s eigrp
router eigrp INE
 !
 address-family ipv4 unicast autonomous-system 1
  !
  af-interface default
   passive-interface
  exit-af-interface
  !
  af-interface Serial1/0
   summary-address 192.168.0.0 255.255.252.0
   no passive-interface
  exit-af-interface
  !
  af-interface Loopback9
   no passive-interface
  exit-af-interface
  !
  af-interface Loopback99
   no passive-interface
  exit-af-interface
  !
  af-interface Loopback999
   no passive-interface
  exit-af-interface
  !
  topology base
   redistribute eigrp 2
  exit-af-topology
  network 10.12.0.0 0.0.0.255
  network 10.14.0.0 0.0.0.255
  network 192.168.0.0 0.0.3.255
 exit-address-family
router eigrp CISCO
 !
 address-family ipv4 unicast autonomous-system 2
  !
  af-interface Serial1/0
   summary-address 172.234.0.0 255.255.0.0
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 172.234.1.0 0.0.0.255
  network 172.234.2.0 0.0.0.255
  network 172.234.3.0 0.0.0.255
 exit-address-family

R4#sh run | s eigrp
router eigrp INE
 !
 address-family ipv4 unicast autonomous-system 1
  !
  af-interface default
   passive-interface
  exit-af-interface
  !
  af-interface Serial1/0
   no passive-interface
  exit-af-interface
  !
  af-interface Ethernet0/0
   summary-address 192.168.0.0 255.255.252.0
   no passive-interface
  exit-af-interface
  !
  af-interface Loopback9
   no passive-interface
  exit-af-interface
  !
  af-interface Loopback99
   no passive-interface
  exit-af-interface
  !
  af-interface Loopback999
   no passive-interface
  exit-af-interface
  !
  topology base
   redistribute eigrp 2
  exit-af-topology
  network 10.12.0.0 0.0.0.255
  network 10.14.0.0 0.0.0.255
  network 192.168.0.0 0.0.3.255
 exit-address-family
router eigrp CISCO
 !
 address-family ipv4 unicast autonomous-system 2
  !
  af-interface Serial1/0
   summary-address 172.234.0.0 255.255.0.0
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 172.234.1.0 0.0.0.255
  network 172.234.2.0 0.0.0.255
  network 172.234.3.0 0.0.0.255
 exit-address-family

eigrp redistribution.JPG

1 Accepted Solution

Accepted Solutions

GRANT3779
Spotlight
Spotlight

Just had a brief look over and I believe your summary address should be under AS1 process on your routers - Not under AS 2.

 

af-interface Serial1/0
summary-address 192.168.0.0 255.255.252.0
summary-address 172.234.0.0 255.255.0.0
no passive-interface
exit-af-interface 

View solution in original post

1 Reply 1

GRANT3779
Spotlight
Spotlight

Just had a brief look over and I believe your summary address should be under AS1 process on your routers - Not under AS 2.

 

af-interface Serial1/0
summary-address 192.168.0.0 255.255.252.0
summary-address 172.234.0.0 255.255.0.0
no passive-interface
exit-af-interface 

Review Cisco Networking products for a $25 gift card