cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
561
Views
15
Helpful
5
Replies

RIP - Configuration Doubt

Hi all,

 

hope to find you all well

I'm currently programming a simple network with some vlans and using RIPv2, but I'm having some doubts.

I configured RIP like this:

 

interface Vlan2
ip address 10.0.2.1 255.255.255.0
ip summary-address rip 10.0.2.0 255.255.255.0
!
interface Vlan3
ip address 192.168.101.11 255.255.255.0
ip summary-address rip 192.168.101.0 255.255.255.0
!
interface Vlan5
ip address 10.0.5.1 255.255.255.0
ip summary-address rip 10.0.5.0 255.255.255.0
!
interface Vlan6
ip address 10.0.6.1 255.255.255.0
ip summary-address rip 10.0.6.0 255.255.255.0
!
interface Vlan7
ip address 10.0.7.1 255.255.255.0
ip summary-address rip 10.0.7.0 255.255.255.0
!
interface Vlan8
ip address 10.0.8.1 255.255.255.0
ip summary-address rip 10.0.8.0 255.255.255.0
!
interface Vlan10
ip address 10.0.10.1 255.255.255.0
ip summary-address rip 10.0.10.0 255.255.255.0
!
interface Vlan15
ip address 10.0.15.1 255.255.255.0
ip summary-address rip 10.0.15.0 255.255.255.0
!
interface Vlan25
ip address 10.0.25.1 255.255.255.0
ip summary-address rip 10.0.25.0 255.255.255.0
!
router rip
version 2
passive-interface GigabitEthernet1/0/20
neighbor 10.0.2.2
no auto-summary

 

Is this configuration correct? Or is there something that I will need to change?

 

Thank you for the help

2 Accepted Solutions

Accepted Solutions

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello @simoesmarco8626982 ,

you need this:

 

router rip

version 2

passive-interface GigabitEthernet1/0/20
neighbor 10.0.2.2
no auto-summary

network 10.0.0.0

 

All your summary address statements are conceptually wrong for two reasons:

the summary command in RIPv2 can be used to aggregate some component routes but it is not a substitute of the network command.

 

interface Vlan2
ip address 10.0.2.1 255.255.255.0
ip summary-address rip 10.0.2.0 255.255.255.0
!

 

you need to enable RIP on all interfaces and this can be done with the network 10.0.0.0 statement under router rip.

The summary-address at interface level has a different goal: out of the interface it can advertise a summary route but that route cannot be the local subnet !!! it needs to be a route aggregating other subnets

RIPv2 should be able tu support a single summary address per major network per interface but you cannot go beyond the classful boundary for example the following is not supported

ip summary-address rip 10.0.0.0. 254.0.0.0  as it attempts to advertise 10.0.0.0/7 that is a supernet.

 

Hope to help

Giuseppe

 

 

View solution in original post

You already have config : ( add network should work for you)

 

router rip
version 2
passive-interface GigabitEthernet1/0/20
neighbor 10.0.2.2
no auto-summary

network  10.0.0.0

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

5 Replies 5

balaji.bandi
Hall of Fame
Hall of Fame

Not sure about your network topology ? you have so many RIP peers ? in each interface connected to different Routers?

 

another thing in related to RIP   "RIPv2 can only summarize Classful "

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thank you for the reply balaji

Basically the network is comprised of two Layer 3 switch's connected to each other via the interface gi1/0/20 and several other access switches that connect to the other ports. This interface 20 is in trunk mode and tagging some vlans but other VLANs only exist in one or another switch. For example switch 1 has Vlan 15 and switch 2 has Vlan 11 and I wanted for all this VLANs to be advertised to each core switch.

If I introduce all those network in router rip, rip automatically summarize everything to the network 10.0.0.0, I wanted to avoid unnecessary multicast traffic trough the network and just wanted to advertise those specific ones in order for the traffic to be routed around correctly and only to those networks being advertised.

Don't know tough if what I did it's correct

You already have config : ( add network should work for you)

 

router rip
version 2
passive-interface GigabitEthernet1/0/20
neighbor 10.0.2.2
no auto-summary

network  10.0.0.0

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello @simoesmarco8626982 ,

you need this:

 

router rip

version 2

passive-interface GigabitEthernet1/0/20
neighbor 10.0.2.2
no auto-summary

network 10.0.0.0

 

All your summary address statements are conceptually wrong for two reasons:

the summary command in RIPv2 can be used to aggregate some component routes but it is not a substitute of the network command.

 

interface Vlan2
ip address 10.0.2.1 255.255.255.0
ip summary-address rip 10.0.2.0 255.255.255.0
!

 

you need to enable RIP on all interfaces and this can be done with the network 10.0.0.0 statement under router rip.

The summary-address at interface level has a different goal: out of the interface it can advertise a summary route but that route cannot be the local subnet !!! it needs to be a route aggregating other subnets

RIPv2 should be able tu support a single summary address per major network per interface but you cannot go beyond the classful boundary for example the following is not supported

ip summary-address rip 10.0.0.0. 254.0.0.0  as it attempts to advertise 10.0.0.0/7 that is a supernet.

 

Hope to help

Giuseppe

 

 

Thank you all

So in essence I was overcomplicating things...

Thank you Giuseppe and balaji for the explanation and solution

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: