cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1896
Views
4
Helpful
25
Replies

Rip v1 routing

maksunity
Level 1
Level 1

Hello, I have a network topology which will be shown below. Two routers R1 and R4 are connected via Serial ports. The routers will be configured below. My question is why when I build the routing table for R1 (show ip route), in the last two lines I have explicitly the subnet between the routers (10.70.0.2/16) and the port of router R4 (10.70.0.2/32). In all similar cases of connecting two routers via serial ports, this is not the case.

Example show ip route:
r1.lab#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C 10.10.0.0/16 is directly connected, FastEthernet0/0
R 10.30.0.0/16 [120/1] via 10.20.0.2, 00:00:19,FastEthernet0/1

C 10.20.0.0/16 is directly connected, FastEthernet0/1
R 10.40.0.0/16 [120/1] via 10.70.0.2, 00:00:14, Serial0/1/0
R 10.60.0.0/16 [120/2] via 10.70.0.2, 00:00:14,
Serial0/1/0
R 10.50.0.0/16 [120/1] via 10.70.0.2, 00:00:14, Serial0/1/0
C 10.70.0.0/16 is directly connected, Serial0/1/0
C 10.70.0.2/32 is directly connected, Serial0/1/0

maksunity_1-1703533737939.png

 

Network topology

maksunity_0-1703533535177.png

 

Router settings static routing:
R1:
r1.lab#conf t
r1.lab(config)#username r4 privilege 0 password 0 pass
r1.lab(config)#interface FastEthernet0/0
r1.lab(config-if)# ip address 10.10.0.1 255.255.0.0
r1.lab(config-if)# duplex auto
r1.lab(config-if)# speed auto
r1.lab(config-if)#!
r1.lab(config-if)#interface FastEthernet0/1
r1.lab(config-if)# ip address 10.20.0.1 255.255.0.0
r1.lab(config-if)# duplex auto
r1.lab(config-if)# speed auto
r1.lab(config-if)#!
r1.lab(config-if)#interface Serial0/1/0
r1.lab(config-if)# ip address 10.70.0.1 255.255.0.0
r1.lab(config-if)# encapsulation ppp
r1.lab(config-if)# ppp authentication chap
r1.lab(config-if)# ppp chap hostname r1
r1.lab(config-if)# ppp chap password 0 pass

 

R2:
r2.lab#conf t
r2.lab(config)#interface FastEthernet0/0
r2.lab(config-if)# ip address 10.30.0.1 255.255.0.0
r2.lab(config-if)# duplex auto
r2.lab(config-if)# speed auto
r2.lab(config-if)#!
r2.lab(config-if)#interface FastEthernet0/1
r2.lab(config-if)# ip address 10.20.0.2 255.255.0.0
r2.lab(config-if)# duplex auto
r2.lab(config-if)# speed auto
R3:
r3.lab#conf t
r3.lab(config)#interface FastEthernet0/0
r3.lab(config-if)# ip address 10.60.0.1 255.255.0.0
r3.lab(config-if)# duplex auto
r3.lab(config-if)# speed auto
r3.lab(config-if)#!
r3.lab(config-if)#interface FastEthernet0/1
r3.lab(config-if)# ip address 10.50.0.2 255.255.0.0
r3.lab(config-if)# duplex auto
r3.lab(config-if)# speed auto
R4:
r4.lab#conf t
r4.lab(config)#username r1 privilege 0 password 0 pass
r4.lab(config)#interface FastEthernet0/0
r4.lab(config-if)# ip address 10.40.0.1 255.255.0.0
r4.lab(config-if)# duplex auto
r4.lab(config-if)# speed auto
r4.lab(config-if)#!
r4.lab(config-if)#interface FastEthernet0/1
r4.lab(config-if)# ip address 10.50.0.1 255.255.0.0
r4.lab(config-if)# duplex auto
r4.lab(config-if)# speed auto
r4.lab(config-if)#!
r4.lab(config-if)#interface Serial0/1/0
r4.lab(config-if)# ip address 10.70.0.2 255.255.0.0
r4.lab(config-if)# encapsulation ppp
r4.lab(config-if)# clock rate 128000
r4.lab(config-if)# ppp authentication chap

r4.lab(config-if)# ppp chap hostname r4
r4.lab(config-if)# ppp chap password 0 pass
r4.lab(config-if)#clock rate 128000

Configuring RIP v1 on routers:
R1:
r1.lab#conf t
r1.lab(config)#router rip
r1.lab(config-router)#version 1
r1.lab(config-router)#network 10.10.0.0
r1.lab(config-router)#network 10.20.0.0
r1.lab(config-router)#network 10.70.0.0
R2:
r2.lab#conf t
r2.lab(config)#router rip
r2.lab(config-router)#version 1
r2.lab(config-router)#network 10.30.0.0
r2.lab(config-router)#network 10.20.0.0
R3:
r3.lab#conf t
r3.lab(config)#router rip
r3.lab(config-router)#version 1
r3.lab(config-router)#network 10.60.0.0
r3.lab(config-router)#network 10.50.0.0
R4:
r4.lab#conf t
r4.lab(config)#router rip
r4.lab(config-router)#version 1
r4.lab(config-router)#network 10.40.0.0
r4.lab(config-router)#network 10.50.0.0
r4.lab(config-router)#network 10.70.0.0

Thanks in advance!

25 Replies 25

Joseph W. Doherty
Hall of Fame
Hall of Fame

Did you also use PPP encapsulation for your other serial links (that showed differently for networks)?

I have configured the IP addresses and subnet mask on the Fast Ethernet interfaces. On the Serial interfaces I configured PPP encapsulation with CHAP authorization protocol and Pass password according to the topology

This normal 

Any p2p interface will appear as two

"C" which is subnet of interface as you enter under the interface 

"L"  the /32 ip of interface.

The router use longest match so always it use /32 but for IGP it adverise /16 (in your case)

MHM

These last two lines in the routing tables with explicitly specified local network and router port are found in all router routing tables (I'll give them below).
r2.lab#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP

10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
R 0.10.0.0/16 [120/1] via 10.20.0.1, 00:00:13,
FastEthernet0/1
C 10.30.0.0/16 is directly connected, FastEthernet0/0
C 10.20.0.0/16 is directly connected, FastEthernet0/1
R 10.40.0.0/16 [120/2] via 10.20.0.1, 00:00:13,
FastEthernet0/1
R 10.60.0.0/16 [120/3] via 10.20.0.1, 00:00:13,
FastEthernet0/1
R 10.50.0.0/16 [120/2] via 10.20.0.1, 00:00:13,
FastEthernet0/1
R 10.70.0.0/16 [120/1] via 10.20.0.1, 00:00:13,
FastEthernet0/1
R 10.70.0.2/32 [120/1] via 10.20.0.1, 00:00:13,
FastEthernet0/1

R3:

r3.lab#show ip route

Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
R 10.10.0.0/16 [120/2] via 10.50.0.1, 00:00:00,
FastEthernet0/1
R 10.30.0.0/16 [120/3] via 10.50.0.1, 00:00:00,
FastEthernet0/1
R 10.20.0.0/16 [120/2] via 10.50.0.1, 00:00:00,
FastEthernet0/1
R 10.40.0.0/16 [120/1] via 10.50.0.1, 00:00:00,
FastEthernet0/1
C 10.60.0.0/16 is directly connected, FastEthernet0/0
C 10.50.0.0/16 is directly connected, FastEthernet0/1
R 10.70.0.0/16 [120/1] via 10.50.0.1, 00:00:00,
FastEthernet0/1
R 10.70.0.1/32 [120/1] via 10.50.0.1, 00:00:00,
FastEthernet0/1

R4:

r4.lab#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
10.0.0.0/8 is variably subnetted, 8 subnets, 2
masks
R 10.10.0.0/16 [120/1] via 10.70.0.1, 00:00:22, Serial0/1/0
R 10.30.0.0/16 [120/2] via 10.70.0.1, 00:00:22,
Serial0/1/0
R 10.20.0.0/16 [120/1] via 10.70.0.1, 00:00:22,
Serial0/1/0
C 10.40.0.0/16 is directly connected, FastEthernet0/0
R 10.60.0.0/16 [120/1] via 10.50.0.2, 00:00:16,
FastEthernet0/1
C 10.50.0.0/16 is directly connected, FastEthernet0/1
C 10.70.0.0/16 is directly connected, Serial0/1/0
C 10.70.0.1/32 is directly connected, Serial0/1/0

I apologize if I explain something wrong, I study at the university and my supervisor after configuring this network in the classroom on a given topology requires an explanation from the official documentation Cisco, but there I did not find explanations so I turned here

you are correct, 
can you change the ver to 2 and check the route in R2 and R3

This is my new topology 

IMG_5029.jpeg

R1:

r1.lab#conf t

r1.lab(config)#router rip

r1.lab(config-router)#version 2

R2:

r2.lab#conf t

r2.lab(config)#router rip

r2.lab(config-router)#version 2

R3:

r3.lab#conf t

r3.lab(config)#router rip

r3.lab(config-router)#version 2

R4:

r4.lab#conf t

r4.lab(config)#router rip

r4.lab(config-router)#version 2

New show ip route:

R1:

r1.lab#show ip route

Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

C 10.10.0.0/16 is directly connected, FastEthernet0/0

R 10.0.0.0/8 [120/1] via 192.168.100.2, 00:00:11,

Serial0/1/0

R 10.30.0.0/16 [120/1] via 10.20.0.2, 00:00:08,

FastEthernet0/1

C 10.20.0.0/16 is directly connected, FastEthernet0/1

192.168.100.0/24 is variably subnetted, 2 subnets,

2 masks

C 192.168.100.0/30 is directly connected, Serial0/1/0

C 192.168.100.2/32 is directly connected, Serial0/1/0

 

R2:

r2.lab#show ip route

Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

R 10.10.0.0/16 [120/1] via 10.20.0.1, 00:00:20,

FastEthernet0/1

R 10.0.0.0/8 [120/2] via 10.20.0.1, 00:00:20,

FastEthernet0/1

C 10.30.0.0/16 is directly connected, FastEthernet0/0

C 10.20.0.0/16 is directly connected, FastEthernet0/1

R 192.168.100.0/24 [120/1] via 10.20.0.1, 00:00:20,

FastEthernet0/1 

 

R3:

r3.lab#show ip route

Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

R 10.0.0.0/8 [120/2] via 10.50.0.1, 00:00:24,

FastEthernet0/1

R 10.40.0.0/16 [120/1] via 10.50.0.1, 00:00:24,

FastEthernet0/1

C 10.60.0.0/16 is directly connected, FastEthernet0/0

C 10.50.0.0/16 is directly connected, FastEthernet0/1

R 192.168.100.0/24 [120/1] via 10.50.0.1, 00:00:24,

FastEthernet0/1 

 

R4:

r4.lab#show ip route

Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

R 10.0.0.0/8 [120/1] via 192.168.100.1, 00:00:06,

Serial0/1/0

C 10.40.0.0/16 is directly connected, FastEthernet0/0

R 10.60.0.0/16 [120/1] via 10.50.0.2, 00:00:09,

FastEthernet0/1

C 10.50.0.0/16 is directly connected, FastEthernet0/1

192.168.100.0/24 is variably subnetted, 2 subnets,

2 masks

C 192.168.100.0/30 is directly connected, Serial0/1/0

C 192.168.100.1/32 is directly connected, Serial0/1/0

First rip is no more use' but since you study it I will try help you as I can.

Now 

You change serial interface to be 192.x.x.x this without use no-autosummary under rip make another issue called discontiguous issue.

So only add no auto-summary under rip and check.

MHM

Oh my, I suspect bringing up discontinuous Classful subnets is very likely to confuse OP.  Plus, are you suggesting to use a Class C network with a Class A mask?

So, do I now understand all you serial ports were configured the same and they all impacted the route table in a similar manner, correct?

Possibly you're wondering why the serial ports impact the route table differently from the Ethernet ports?  If so, Ethernet ports are considered multi-access while serial ports are considered point-to-point.

Yes, the question is why Serial and Fe ports have different subnet mapping. The Fe port has only the subnet and nexthop explicitly listed, while the Serial port has both the subnet and the port of another router. And I would like to know why, because my job requires it. That is, why when building a routing table for the first router, for example, we see not:
C 10.20.0.0.0/16 is directly connected, FastEthernet0/1
C 10.70.0.0.0/16 is directly connected, Serial0/1/0

And we see:
C 10.20.0.0.0/16 is directly connected, FastEthernet0/1
C 10.70.0.0.0/16 is directly connected, Serial0/1/0
C 10.70.0.0.2/32 is directly connected, Serial0/1/0

Why instead of one line for Fe ports we get two lines for Serial port.

maksunity_0-1703604262679.png

 

That question was answered by myself and @MHM Cisco World, i.e. different kinds of interfaces.

I recall (?) you'll see a /32 and interface network for a loopback interface too.

If you were using OSPF, you would see it also treat, by default, Ethernet interfaces differently from serial interfaces.

Lastly, and BTW, the connected "C" routes are independent of the IGP, whether RIP or another.  However, RIP(v1) is a Classful routing protocol that has its own issues, such as the /32 IPs will not be seen by other RIP routers.

Hi maksunity,

This topology is an example of classless...so, you should use RIP version 2 with no auto-summary command...

Please try...following configuration...( accroding to new topology)

r1.lab#conf t

r1.lab(config)#router rip

r1.lab(config-router)#version 2

r1.lab(config-router)# network 10.20.0.0

r1.lab(config-router)# network 192.168.100.0

r1.lab(config-router)# network 10.10.0.0

r1.lab(config-router)# no auto-summary

r1.lab(config-router)#end

r2.lab#conf t

r2.lab(config)#router rip

r2.lab(config-router)#version 2

r2.lab(config-router)# network 10.20.0.0

r2.lab(config-router)# network 10.30.0.0

r2.lab(config-router)# no auto-summary

r2.lab(config-router)# end

Same way...configure for other routers...

Best regards
******* If This Helps, Please Rate *******

 

 

 

 

 

I've disabled autosummarization for RIPv2:

R1:
r1.lab#conf t
r1.lab(config)#router rip
r1.lab(config-router)# no auto-summary
R2:
r2.lab#conf t
r2.lab(config)#router rip
r2.lab(config-router)# no auto-summary
R3:
r3.lab#conf t
r3.lab(config)#router rip
r3.lab(config-router)# no auto-summary

R4:
r4.lab#conf t
r4.lab(config)#router rip
r4.lab(config-router)# no auto-summary

This is what I got:

r1.lab#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C 10.10.0.0/16 is directly connected, FastEthernet0/0
R 10.0.0.0/8 [120/1] via 192.168.100.2, 00:01:24,
Serial0/1/0
R 10.30.0.0/16 [120/1] via 10.20.0.2, 00:00:28,
FastEthernet0/1
C 10.20.0.0/16 is directly connected, FastEthernet0/1
R 10.40.0.0/16 [120/1] via 192.168.100.2, 00:00:24,
Serial0/1/0
R 10.60.0.0/16 [120/2] via 192.168.100.2, 00:00:24,
Serial0/1/0
R 10.50.0.0/16 [120/1] via 192.168.100.2, 00:00:24,
Serial0/1/0
192.168.100.0/24 is variably subnetted, 2 subnets,
2 masks
C 192.168.100.0/30 is directly connected, Serial0/1/0
C 192.168.100.2/32 is directly connected, Serial0/1/0

R2:
r2.lab#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
10.0.0.0/16 is subnetted, 6 subnets
R 10.10.0.0 [120/1] via 10.20.0.1, 00:00:22,
FastEthernet0/1
C 10.30.0.0 is directly connected, FastEthernet0/0
C 10.20.0.0 is directly connected, FastEthernet0/1
R 10.40.0.0 [120/2] via 10.20.0.1, 00:00:22,
FastEthernet0/1

R 10.60.0.0 [120/3] via 10.20.0.1, 00:00:22,
FastEthernet0/1
R 10.50.0.0 [120/2] via 10.20.0.1, 00:00:22,
FastEthernet0/1
192.168.100.0/24 is variably subnetted, 3 subnets,
3 masks
R 192.168.100.0/30 [120/1] via 10.20.0.1, 00:00:22,
FastEthernet0/1
R 192.168.100.0/24 is possibly down,
routing via 10.20.0.1, FastEthernet0/1
R 192.168.100.2/32 [120/1] via 10.20.0.1, 00:00:22,
FastEthernet0/1

R3:
r3.lab#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
10.0.0.0/16 is subnetted, 6 subnets
R 10.10.0.0 [120/2] via 10.50.0.1, 00:00:22,
FastEthernet0/1
R 10.30.0.0 [120/3] via 10.50.0.1, 00:00:22,
FastEthernet0/1
R 10.20.0.0 [120/2] via 10.50.0.1, 00:00:22,
FastEthernet0/1
R 10.40.0.0 [120/1] via 10.50.0.1, 00:00:22,
FastEthernet0/1
C 10.60.0.0 is directly connected, FastEthernet0/0
C 10.50.0.0 is directly connected, FastEthernet0/1
192.168.100.0/24 is variably subnetted, 3 subnets,
3 masks
R 192.168.100.0/30 [120/1] via 10.50.0.1, 00:00:22,
FastEthernet0/1
R 192.168.100.0/24 is possibly down,
routing via 10.50.0.1, FastEthernet0/1
R 192.168.100.1/32 [120/1] via 10.50.0.1, 00:00:22,
FastEthernet0/1

R4:
r4.lab#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks

R 10.10.0.0/16 [120/1] via 192.168.100.1, 00:00:09,
Serial0/1/0
R 10.0.0.0/8 is possibly down,routing via
192.168.100.1, Serial0/1/0
R 10.30.0.0/16 [120/2] via 192.168.100.1, 00:00:09,
Serial0/1/0
R 10.20.0.0/16 [120/1] via 192.168.100.1, 00:00:09,
Serial0/1/0
C 10.40.0.0/16 is directly connected, FastEthernet0/0
R 10.60.0.0/16 [120/1] via 10.50.0.2, 00:00:07,
FastEthernet0/1
C 10.50.0.0/16 is directly connected, FastEthernet0/1
192.168.100.0/24 is variably subnetted, 2 subnets,
2 masks
C 192.168.100.0/30 is directly connected, Serial0/1/0
C 192.168.100.1/32 is directly connected, Serial0/1/0

Screenshot (614).pngScreenshot (615).pngScreenshot (616).pngScreenshot (617).pngScreenshot (618).png

Review Cisco Networking for a $25 gift card