06-08-2022 12:52 AM - last edited on 06-08-2022 10:33 PM by Translator
Dear friends,
I need to summarize routes from the backbone area to connected areas!
The line in the config of the ABR looks like:
router ospf 2
area 0 range 10.4.0.0 255.255.0.0
area 1 range 10.2.0.0 255.255.0.0
The routing table on a router in area 1 looks like this:
d7-2610xm-TelAnl#sh ip route os
1.0.0.0/24 is subnetted, 1 subnets
O IA 1.0.0.0 [110/11] via 2.0.0.1, 00:18:31, FastEthernet0/0
10.0.0.0/32 is subnetted, 2 subnets
O IA 10.4.1.1 [110/12] via 2.0.0.1, 00:18:31, FastEthernet0/0
No summary 10.4.0.0/16
Is summarization only supported from an area to backbone area?
I found some examples in the net from cisco training sites, which show that summary should als work from backbone area to outside!
regards, Hannes
Solved! Go to Solution.
06-08-2022 08:41 AM
06-08-2022 06:46 AM - last edited on 06-08-2022 10:47 PM by Translator
Hello,
Could you provide the
show run
configurations of all 3 devices?
A couple things to note:
The
NOT-ADVERTISE
keyword will NOT advertise the summary address. If you want it advertised and showing up make sure to take that off
The
area range
command needs to be done in the Area where the routes are originated from, not going to.
Try deleting your
range
commands with the full mask and use / notation if it will let you.
Side note: If there are other connections to these devices where they are getting the same subnet it will use the more specific route. (longest match)
-David
06-08-2022 06:47 AM - last edited on 06-08-2022 11:40 PM by Translator
Hello
@hannes1967 wrote:Is summarization only supported from an area to backbone area?
It supported either way:
from the BB area into a non BB area
from non BB area into BB area
I assume rtr has presence in both areas <ABR>, if so then append a network statment for a network which will be included in the summary and you should be good.
example:
router ospf 2
network 10.4.2.2 0.0.0.0. area 0
network 10.2.2.2 0.0.0.0. area 1
area 0 range 10.4.0.0 255.255.0.0
area 1 range 10.2.0.0 255.255.0.0
06-08-2022 07:21 AM - last edited on 06-08-2022 10:56 PM by Translator
Hi,
summary example:
vIOS3
interface GigabitEthernet0/0
ip address 1.3.1.3 255.255.255.0
ip ospf 1 area 10
!
interface Loopback10
ip address 10.10.10.10 255.255.255.0
ip ospf 1 area 0
!
interface Loopback20
ip address 10.10.20.10 255.255.255.0
ip ospf 1 area 0
!
router ospf 1
area 0 range 10.10.0.0 255.255.0.0
vIOS1
interface GigabitEthernet0/0
ip address 1.3.1.1 255.255.255.0
ip ospf 1 area 10
vIOS1#show ip route
10.0.0.0/16 is subnetted, 1 subnets
O IA 10.10.0.0 [110/2] via 1.3.1.3, 00:12:41, GigabitEthernet0/0
06-08-2022 08:14 AM
Hi!
Looks like a solution!
Thank you very much!
I will check with GNS3 simulator tomorrow morning!
regards, Hannes
06-08-2022 08:26 PM - last edited on 06-08-2022 11:46 PM by Translator
Dear Friends,
now I tested on GNS3 and I have a solution!
Thank you all!
Please see also att image001.png, which is not complete!
My mistakes in due to misunderstanding of OSPF:
I tried to summarize the network 10.4.1.1 which is in area 8!
The summarization I made was in d2 which is an ABR between area 0 and area 1!
If 10.4.1.1 were in area 0, everything would working fine!
So I configured additional networks with loopback interfaces in d4 in area 0!
Then I summarized these networks with range command in d2!
d2#sh run | i ran
area 0 range 11.0.0.0 255.0.0.0
area 0 range 12.0.0.0 255.0.0.0
All configs:
d4
interface Loopback0
ip address 11.4.1.1 255.255.255.255
ip ospf network point-to-point
!
interface Loopback1
ip address 11.5.1.1 255.255.255.255
ip ospf network point-to-point
!
interface Loopback3
ip address 12.6.1.1 255.255.0.0
!
interface Loopback4
ip address 10.4.1.1 255.255.255.0
!
interface Loopback5
ip address 12.7.1.1 255.255.0.0
!
interface FastEthernet0/0
ip address 1.0.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 2
log-adjacency-changes
area 0 range 10.6.0.0 255.255.0.0
network 1.0.0.0 0.0.0.255 area 0
network 10.4.1.0 0.0.0.255 area 8
network 10.5.1.0 0.0.0.255 area 8
network 10.6.0.0 0.0.255.255 area 0
network 11.0.0.0 0.255.255.255 area 0
network 12.0.0.0 0.255.255.255 area 0
d2
interface FastEthernet0/0
ip address 1.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 2.0.0.1 255.255.255.0
duplex auto
speed auto
!
!
router ospf 2
log-adjacency-changes
area 0 range 11.0.0.0 255.0.0.0
area 0 range 12.0.0.0 255.0.0.0
area 1 range 10.2.0.0 255.255.0.0
area 1 range 10.4.0.0 255.255.0.0 not-advertise
network 1.0.0.0 0.0.0.255 area 0
network 2.0.0.0 0.0.0.255 area 1
network 10.20.0.0 0.0.255.255 area 1
d7
interface Loopback0
ip address 10.2.1.1 255.255.255.255
!
interface Loopback1
ip address 10.3.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 2.0.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 2
log-adjacency-changes
network 2.0.0.0 0.0.0.255 area 1
network 10.2.1.0 0.0.0.255 area 1
network 10.3.0.0 0.0.255.255 area 1
Routing table d7:
d7#sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
O IA 1.0.0.0 [110/2] via 2.0.0.1, 02:10:16, FastEthernet0/0
2.0.0.0/24 is subnetted, 1 subnets
C 2.0.0.0 is directly connected, FastEthernet0/0
10.0.0.0/32 is subnetted, 3 subnets
C 10.2.1.1 is directly connected, Loopback0
C 10.3.1.1 is directly connected, Loopback1
O IA 10.4.1.1 [110/3] via 2.0.0.1, 02:10:16, FastEthernet0/0
O IA 11.0.0.0/8 [110/3] via 2.0.0.1, 00:21:14, FastEthernet0/0
O IA 12.0.0.0/8 [110/3] via 2.0.0.1, 01:25:08, FastEthernet0/0
06-09-2022 08:12 AM
Ohh,
I was think that my solution is not right and there is some thing in commend I share,
anyway glad that your issue is solved, so as I mention the issue you config the area range in wrong ABR.
Good Job friend.
06-09-2022 10:51 PM
Thank you very much!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide