cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
876
Views
10
Helpful
3
Replies

Router configuration to connect separate LANs

ramram
Level 1
Level 1

Hi,

I am trying to use a Cisco 1841 router to make a connection between two separate LANs which are directly connected.

 

FastEthernet 0/0 is connected to network 10.80.1.0/24 and the interface received IP 10.80.1.135 IP via DHCP from a router on this network (a TP-Link router at 10.80.1.1)

 

FastEthernet 0/1 is network 192.168.0.0/24 and I want the 1841 router to provide DHCP.

 

What is required to make these two networks able to communicate with each other? 

How can I allow clients on the 192.168.0.0 network to access the internet using my TP-Link router at 10.80.1.1?

 

I am very new to Networking and I am currently studying for CCNA R&S so any advice would be very much appreciated.

 

Router#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.80.1.135     YES DHCP   up                    up
FastEthernet0/1            192.168.0.1     YES manual up                    up
Serial0/0/0                unassigned      YES unset  administratively down down
Router#
Building configuration...

Current configuration : 928 bytes
!
! Last configuration change at 11:34:32 UTC Sat Dec 28 2019
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.50
!
ip dhcp pool Floor1
network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 192.168.0.1
!
!
ip cef
multilink bundle-name authenticated
!
!
license udi pid CISCO1841 sn FCZ151294GL
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
 clock rate 2000000
!
ip forward-protocol nd
!
!
no ip http server
!
!
!
control-plane

!
!
line con 0
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end


Router#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is 10.80.1.1 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 10.80.1.1
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.80.1.0/24 is directly connected, FastEthernet0/0
L        10.80.1.135/32 is directly connected, FastEthernet0/0
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, FastEthernet0/1
L        192.168.0.1/32 is directly connected, FastEthernet0/1

Thanks, 

James

 

 

 

1 Accepted Solution

Accepted Solutions

Hello

It looks like you modem is already performing network translation for the 10.80.1.0/24 subnet

 

So you would need to NAT the 192.168.1.0/x subnet on the router so the users on this ip range would also be able to access the internet, and add a more specific static route than one you would have obtained via the dhcp from you modem,

 

int fa0/0
ip nat outside

int fa0/1
ip nat inside

access-list 10 permit 192.168.1.0 0.0.0.255
ip nat inside source list 10 interface fa0/0
ip route 0.0.0.0 0.0.0.0 fa0/0 dhcp

 

lastly you dhcp pool for the lan users should work as it is but if it doesn't then you have two options to either import the dhcp options from the modem into the dhcp pool or change the dns server to your isp dns or a public dns


ip dhcp pool Floor1
import all
no dns-server 192.168.0.1

or
ip dhcp pool Floor1
dns-server 8.8.8.8 8.8.8.4


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

3 Replies 3

balaji.bandi
Hall of Fame
Hall of Fame

Can we have more information, what is the device connected from Router(interface FastEthernet0/1  )  to end device ? or Switch?

 

If the switch can we have the configuration of that.

 

if point to point link you can route a mutually static route, so each segment can communicate with each other.

 

ip route 0.0.0.0 0.0.0.0 FastEthernet 0/0
ip route 192.168.0.0 255.255.255.0 X/X (where the FAS 0/1 connect neighbour IP)

 

(TP Link also should have static route back to your router)

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hello

It looks like you modem is already performing network translation for the 10.80.1.0/24 subnet

 

So you would need to NAT the 192.168.1.0/x subnet on the router so the users on this ip range would also be able to access the internet, and add a more specific static route than one you would have obtained via the dhcp from you modem,

 

int fa0/0
ip nat outside

int fa0/1
ip nat inside

access-list 10 permit 192.168.1.0 0.0.0.255
ip nat inside source list 10 interface fa0/0
ip route 0.0.0.0 0.0.0.0 fa0/0 dhcp

 

lastly you dhcp pool for the lan users should work as it is but if it doesn't then you have two options to either import the dhcp options from the modem into the dhcp pool or change the dns server to your isp dns or a public dns


ip dhcp pool Floor1
import all
no dns-server 192.168.0.1

or
ip dhcp pool Floor1
dns-server 8.8.8.8 8.8.8.4


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Thanks for both the replies, I have managed to get this working with the below entries:

router(config)#access-list 1 permit 192.168.0.0 0.0.0.255

router(config)#ip nat inside source list 1 interface fastEthernet 0/0 overload
router(config)#
router(config)#int fa 0/1
router(config-if)#ip nat inside

router(config)#int fa 0/0
router(config-if)#ip nat outside
Review Cisco Networking products for a $25 gift card