03-17-2025 06:17 PM
Hi, I came accross this problem that Router 0 (Kodad) and Router 3 (Pargi) has a common vlan (Vlan 1) , where its network address is 158.75.8.192/26. it is a part of the larger corporate network 158.75.0.0/16. I have turned off auto0summarization for RIPv2 in both of them. every device can ping its own router, gateway router (R1) and ISP (R2) . Router 0 can ping other interfaces of Router 3 except for the interface belonging in vlan1 (158.75.8.221) and the switch (158.75.8.220) and vise-versa in case of router3. They both have their default route to the gateway router.
Running config of R0:
Building configuration...
Current configuration : 1126 bytes
!
version 15.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname kodad_R1
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/1.1
encapsulation dot1Q 1 native
ip address 158.75.8.194 255.255.255.192
!
interface GigabitEthernet0/0/1.715
encapsulation dot1Q 715
ip address 158.75.0.1 255.255.248.0
!
interface Serial0/1/0
ip address 158.75.9.33 255.255.255.252
!
interface Serial0/1/1
ip address 158.75.9.37 255.255.255.252
!
interface Serial0/2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/2/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 158.75.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
IP protocol of R0:
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 9 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/1/0 22
GigabitEthernet0/0/1.122
GigabitEthernet0/0/1.71522
Serial0/1/1 22
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
158.75.0.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
158.75.9.38 120 00:00:17
158.75.9.34 120 00:00:09
Distance: (default is 120)
Routing table of R0:
kodad_R1# sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 158.75.9.38 to network 0.0.0.0
158.75.0.0/16 is variably subnetted, 12 subnets, 6 masks
C 158.75.0.0/21 is directly connected, GigabitEthernet0/0/1.715
L 158.75.0.1/32 is directly connected, GigabitEthernet0/0/1.715
R 158.75.8.0/25 [120/1] via 158.75.9.34, 00:00:03, Serial0/1/0
R 158.75.8.128/26 [120/1] via 158.75.9.34, 00:00:03, Serial0/1/0
C 158.75.8.192/26 is directly connected, GigabitEthernet0/0/1.1
L 158.75.8.194/32 is directly connected, GigabitEthernet0/0/1.1
R 158.75.9.0/27 [120/1] via 158.75.9.38, 00:00:06, Serial0/1/1
C 158.75.9.32/30 is directly connected, Serial0/1/0
L 158.75.9.33/32 is directly connected, Serial0/1/0
C 158.75.9.36/30 is directly connected, Serial0/1/1
L 158.75.9.37/32 is directly connected, Serial0/1/1
R 158.75.9.40/30 [120/1] via 158.75.9.34, 00:00:03, Serial0/1/0
[120/1] via 158.75.9.38, 00:00:06, Serial0/1/1
R* 0.0.0.0/0 [120/1] via 158.75.9.38, 00:00:06, Serial0/1/1
running config of R3:
Building configuration...
Current configuration : 1328 bytes
!
version 15.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Pargi_R2
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0/1.1
encapsulation dot1Q 1 native
ip address 158.75.8.221 255.255.255.192
!
interface GigabitEthernet0/0/1.256
description default gateway of vlanZ
encapsulation dot1Q 256
ip address 158.75.8.129 255.255.255.192
!
interface GigabitEthernet0/0/1.313
description default gatway of vlanY
encapsulation dot1Q 313
ip address 158.75.8.1 255.255.255.128
!
interface Serial0/1/0
ip address 158.75.9.34 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
ip address 158.75.9.41 255.255.255.252
clock rate 2000000
!
interface Serial0/2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/2/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 158.75.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
IP Protocol of R3:
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 11 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/1/0 22
GigabitEthernet0/0/1.25622
GigabitEthernet0/0/1.31322
Serial0/1/1 22
GigabitEthernet0/0/1.122
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
158.75.0.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
158.75.9.42 120 00:00:26
158.75.9.33 120 00:00:26
Distance: (default is 120)
Routing table of R3:
Pargi_R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 158.75.9.42 to network 0.0.0.0
158.75.0.0/16 is variably subnetted, 13 subnets, 6 masks
R 158.75.0.0/21 [120/1] via 158.75.9.33, 00:00:20, Serial0/1/0
C 158.75.8.0/25 is directly connected, GigabitEthernet0/0/1.313
L 158.75.8.1/32 is directly connected, GigabitEthernet0/0/1.313
C 158.75.8.128/26 is directly connected, GigabitEthernet0/0/1.256
L 158.75.8.129/32 is directly connected, GigabitEthernet0/0/1.256
C 158.75.8.192/26 is directly connected, GigabitEthernet0/0/1.1
L 158.75.8.221/32 is directly connected, GigabitEthernet0/0/1.1
R 158.75.9.0/27 [120/1] via 158.75.9.42, 00:00:12, Serial0/1/1
C 158.75.9.32/30 is directly connected, Serial0/1/0
L 158.75.9.34/32 is directly connected, Serial0/1/0
R 158.75.9.36/30 [120/1] via 158.75.9.33, 00:00:20, Serial0/1/0
[120/1] via 158.75.9.42, 00:00:12, Serial0/1/1
C 158.75.9.40/30 is directly connected, Serial0/1/1
L 158.75.9.41/32 is directly connected, Serial0/1/1
R* 0.0.0.0/0 [120/1] via 158.75.9.42, 00:00:12, Serial0/1/1topology
Solved! Go to Solution.
03-18-2025 11:49 PM
Router 0 can ping other interfaces of Router 3 except for the interface belonging in vlan1 (158.75.8.221) and the switch (158.75.8.220) and vise-versa in case of router3
Can we have Router1 configuration also, along with showing IP route information? I need to look at what the routing looks like. I see that the default route points to R1, as per the information. Post R3 connected switch config.
On R3 -
are you able to ping R0 interfaces and Switch IP addresses behind R0?
From R0, can you traceroute to R3 and Switch the IP address and post information?
03-18-2025 10:14 AM
Hello @rehnumarahmat ,
given your network topology routers are connected to each other using serial interfaces only so it is not correct to say that they share a VLAN.
Ignore everything related to this subnet because it is not really able to talk with other site. The giga port connects to local switch only.
Apart from this your setup is likely correct.
Hope to help
Giuseppe
03-18-2025 11:49 PM
Router 0 can ping other interfaces of Router 3 except for the interface belonging in vlan1 (158.75.8.221) and the switch (158.75.8.220) and vise-versa in case of router3
Can we have Router1 configuration also, along with showing IP route information? I need to look at what the routing looks like. I see that the default route points to R1, as per the information. Post R3 connected switch config.
On R3 -
are you able to ping R0 interfaces and Switch IP addresses behind R0?
From R0, can you traceroute to R3 and Switch the IP address and post information?
03-19-2025 02:14 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide