I have simple nat config which I need to use:
ip nat pool test 40.0.0.3 40.0.0.3 netmask 255.255.255.0
ip nat inside source list 1 interface GigabitEthernet0/0/1 overload
ip nat inside source list 2 pool test overload
access-list 1 permit 10.0.0.0 0.0.255.255
access-list 2 permit 192.168.1.0 0.0.0.255
interface GigabitEthernet0/0/1
ip address 40.0.0.1 255.255.255.0
ip nat outside
However when I try it on asr 1001 I get that address can't be assigned since pool might be exhausted. I get this as soon as I enter nat config, there is no traffic at all. I can't figure this one out, please help !