cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

326
Views
0
Helpful
2
Replies
Beginner

Source and Destination Static NAT

Hi all,

 

I was hoping to get some help with a static nat configuration I am struggling to set up (beginner here).

Here is the basic networking configuration (I am using a Stratix 5900 router).

 

interface vlan10
ip address 10.0.0.1 255.255.255.0

interface vlan20
ip address 20.0.0.1 255.255.255.0

interface fastethernet0
switchport mode access
switchport access vlan 10

interface fastethernet1
switchport mode access
switchport access vlan 20

 

I would like any traffic on the network destined for A to have the destination translated to B and the source of the traffic translated from C to D as per the table below (basic example). The idea of this configuration is that if I change the IP address of a single device, I can update the NAT configuration and everything will still be able to talk. Both interfaces will be connected to the same physical network. I am aware that I may need secondary IP addresses configured on the VLAN interfaces matching the NAT configuration to get this working.

 

ABCD
10.0.0.420.0.0.410.0.0.120.0.0.1
20.0.0.110.0.0.120.0.0.410.0.0.4

 

I have been reading about NAT configurations and inside/outside local/global and am a little confused. Can anyone point me in the right direction for this configuration?

 

Thanks in advance,

 

Jack

Everyone's tags (3)
2 REPLIES 2
Rising star

Re: Source and Destination Static NAT

first I want to emphasize this is a Cisco forum.

You may get better answers for your specific router on a Rockwell related forum?

 

but having that said, first keep your focus on the router you are configuring here.

in the total path there may occur even more NAT, but that is of no concern when evaluating inside/outside/local/global on the router you are configuring.

 

inside local/global counts for source NAT

inside local is the real source address of the datastream, inside global is the source as the destination receives it.

mind you it is the senders address not the routers sending interface.

similar outside local/global for destination NAT.

outside local is the outside address that the source sends its packets to,

the router NAT's this destination address to the outside global address before is sends the the packets out of its interface to the destination.

 

does this clarify a bit?

 

so your original packet is from C to A

and the received packet is from D to B

C: inside local

D: inside global

A: outside local

B: outside global

VIP Advisor

Re: Source and Destination Static NAT

Hello

what you have stated has confused me greatly !

 

Please Confirm 

Hosts on A to be natted to a host B address

 

Hosts on C to be natted to a host D

 

so

host A will be seen has host B

host C will be seen as host D

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here