09-16-2023 02:48 AM - last edited on 09-19-2023 12:03 PM by Translator
Hello,
I've built very simple topology in GNS with Layer 3 Switches.
Static Routing is configured on
IOU1 and IOU3
IOU1[12.0.0.1]----[12.0.0.2] IOU2 [23.0.0.2]------[23.0.0.3] IOU3
If I configure ports as Layer3 ( no switchport) then I am able to ping from
IOU1 - > IOU3 23.0.0.3
BUT if I configure SVI on all switches , I am able to ping only
23.0.0.2 and not 23.0.0.3
Configuration is very simple - SVI configuration on switches , trunk on ports between switches and static routing on
IOU1 / IOU1
Why I'm not able to
ping 23.0.0.3?
Thanks in advance.
If anyone has different image - could you please try the same lab with the same config and let me know if it works for you?
I use
L2-ADVENTERPRISEK9-M-15.2-IRON-20151103.bin
JUST SMALL UPDATE(I've done the same lab in Packet Tracer and outcome is the same , so is it expected behavior?? if so then why and how to make it work?)
IOU1#show running-config interface vlan 12
interface Vlan12
ip address 12.0.0.1 255.255.255.0
end
IOU1#show running-config interface ethernet 0/0
interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
end
IOU1#show ip route 23.0.0.3
Routing entry for 23.0.0.0/24
Known via "static", distance 1, metric 0
Routing Descriptor Blocks:
* 12.0.0.2
Route metric is 0, traffic share count is 1
IOU3#show ip route 12.0.0.1
Routing entry for 12.0.0.0/24
Known via "static", distance 1, metric 0
Routing Descriptor Blocks:
* 23.0.0.2
Route metric is 0, traffic share count is 1
Solved! Go to Solution.
09-16-2023 03:25 AM - last edited on 09-19-2023 12:14 PM by Translator
Hello,
I am using
vios_l2-ADVENTERPRISEK9-M), Version 15.2(4.0.55)E
it works fine. Make sure all Vlans (12 and 23) exist on all switches (I had to manually create them) and that the route on
IOU1
is pointing to
12.0.0.12
(as in your drawing, unless the drawing is wrong and the
next hop
need to be .2)
09-16-2023 03:13 AM - last edited on 09-19-2023 12:07 PM by Translator
According to
IOU1configuration
IOU1 e0/0is configured as trunk...operates at L2...
If You want to see communication from
IOU1 to IOU3....
All routers
(IOU1, IOU2 and IOU3) E0/0
must be confiured as Routed port (L3)...
Here is the syntax for Routed port configuration:
IOU1(config)# Interface E0/0
IOU1(config-if)# ip address <ip address> <subnet mask>
IOU1(config-if)# no shudown
IOU1(config-if)# exit
I hope the above information is useful..
Thanks
Gopinath
09-16-2023 03:17 AM - last edited on 09-19-2023 12:09 PM by Translator
Thanks for the response.
Yeah
Eth0/0
is configured as trunk but I span this
vlan to IOU2
and I've also configured SVIs so why I should not be able to
ping 23.0.0.3?
I am able to ping Between
1 and 2
2 and 3
I'm also able to ping as mentioned
23.0.0.2
from 1 but not
23.0.0.3
So basically SVIs act as Layer3 , but for some reasons I'm not able to
ping 23.0.0.3 of IOU3
Any other ideas?
09-16-2023 03:25 AM - last edited on 09-19-2023 12:10 PM by Translator
If you add
Ip routing
In
l3sw and svi
not work then
It
gns3
limitations.
09-16-2023 03:32 AM - last edited on 09-19-2023 12:11 PM by Translator
Thanks for the response
ip routing
is configured.
09-16-2023 03:50 AM - last edited on 09-19-2023 12:12 PM by Translator
Which IOS version in GNS does this limitation apply to ? My version works fine with
SVIs and ip routing
enabled.
09-16-2023 03:24 AM
Thanks - I see you've updated your post but as I've mentioned in post if I configure as Routed ports it works fine.
The question is why it does not work when you have SVIs configure?
09-16-2023 03:30 AM
Yes...mentioned...!!
Got it..!!
09-16-2023 03:25 AM - last edited on 09-19-2023 12:14 PM by Translator
Hello,
I am using
vios_l2-ADVENTERPRISEK9-M), Version 15.2(4.0.55)E
it works fine. Make sure all Vlans (12 and 23) exist on all switches (I had to manually create them) and that the route on
IOU1
is pointing to
12.0.0.12
(as in your drawing, unless the drawing is wrong and the
next hop
need to be .2)
09-16-2023 03:35 AM - last edited on 09-19-2023 12:19 PM by Translator
VLAN 12
is configured on
IOU1
only.
VLAN12 and 23
is configured on
IOU2
VLAN 23 on IOU
Please keep in mind that I am able to ping from
IOU2 both next hop IPs ( IOU1 and IOU3 )
I'm also able to ping from
IOU1 23.0.0.2 which is behind IOU2
but for some reasons I'm not able to
ping 23.0.0.3
I'm afraid it could be gns or image limitation.
Would you mind sharing your config and outputs please?
09-16-2023 03:48 AM - last edited on 09-19-2023 12:20 PM by Translator
Hello,
here are my configs. I am using an image where
ip routing
is enabled by default, so it doesn't show up in the running config.
IOU1
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface Vlan12
ip address 12.0.0.1 255.255.255.0
!
ip route 23.0.0.0 255.255.255.0 12.0.0.12
IOU2
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface Vlan12
ip address 12.0.0.12 255.255.255.0
!
interface Vlan23
ip address 23.0.0.2 255.255.255.0
IOU3
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface Vlan23
ip address 23.0.0.3 255.255.255.0
!
ip route 12.0.0.0 255.255.255.0 23.0.0.2
09-16-2023 04:00 AM
I've used another image AND IT WORKS!
Thanks a lot everyone for help.
09-16-2023 03:44 AM
I'm trying new image now......
Will keep you posted.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide