11-15-2017 08:13 AM - edited 03-05-2019 09:29 AM
Hey Guys,
We have a router with three sub-interfaces Gig0/1.111, Gig0/1.222 and Gig 0/1.333.
I would like to set Gig 0/1.111 and 1.222 to use Gig0/2 ISP and Gig0/1.333 to use Gig 0/3 ISP.
My problem is we cant use VRF and static routing due to limitation.
Is there any other way I can achieve it ?
Thanks
11-15-2017 08:17 AM
Hello
Does you rtr support Policy Based Routing ( PBR) ?
res
Paul
11-15-2017 08:23 AM
No its 1800 series old ATT router, its not supported.
11-16-2017 02:49 AM - edited 11-16-2017 02:53 AM
Hi
I agree with Paul, I have some 1800 routers and it works, the config could be:
ip access-list NET1-TO-ISP
deny ip 192.168.111.0 0.0.0.255 10.0.0.0 0.255.255.255
deny ip 192.168.111.0 0.0.0.255 172.16.0.0 0.15.255.255
deny ip 192.168.111.0 0.0.0.255 192.168.0.0 0.0.255.255
permit ip any any
ip access-list NET2-TO-ISP
deny ip 192.168.222.0 0.0.0.255 10.0.0.0 0.255.255.255
deny ip 192.168.222.0 0.0.0.255 172.16.0.0 0.15.255.255
deny ip 192.168.222.0 0.0.0.255 192.168.0.0 0.0.255.255
permit ip any any
ip access-list NET3-TO-ISP
deny ip 192.168.333.0 0.0.0.255 10.0.0.0 0.255.255.255
deny ip 192.168.333.0 0.0.0.255 172.16.0.0 0.15.255.255
deny ip 192.168.333.0 0.0.0.255 192.168.0.0 0.0.255.255
permit ip any any
<next hops: 1.1.1.1 ISP1 and 2.2.2.2 ISP2>
route-map NET1-TO-ISP permit
match ip address NET1-TO-ISP
set ip next-hop 1.1.1.1
route-map NET2-TO-ISP permit
match ip address NET2-TO-ISP
set ip next-hop 1.1.1.1
route-map NET3-TO-ISP permit
match ip address NET3-TO-ISP
set ip next-hop 2.2.2.2
interface fa0/0.111
ip policy route-map NET1-TO-ISP
interface fa0/0.222
ip policy route-map NET2-TO-ISP
interface fa0/0.333
ip policy route-map NET3-TO-ISP
Hope it is useful
:-)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide