11-27-2023 10:44 AM
We're attempting to route T1 traffic into a T1 card in an ISR4451 router, to another ISR4451, and out a T1 card installed there. Currently it's just the two IRS4451 devices directly connected by a Cat6 cale. We've tried following the process of encapsulating the T1 traffic using a serial interface with an IP address but we're definitely missing something. I've included some config exceprts below and if anyone has any thoughts or tips they'd be much appreciated.
ISR4451-1
controller T1 0/1/0
framing esf
clock source line primary
linecode b8zs
cablelength short 110
channel-group 1 timeslots 1-24
!
interface GigabitEthernet0/0/1
ip address 10.131.0.11 255.255.255.0
negotiation auto
!
interface Serial0/1/0:1
ip address 192.168.1.2 255.255.255.0
crc 32
!
ip default-gateway 10.131.0.10
ip route 0.0.0.0 0.0.0.0 10.131.0.10
ISR4451-2
controller T1 0/2/0
framing esf
clock source line secondary
linecode b8zs
cablelength short 110
channel-group 1 timeslots 1-24
!
interface GigabitEthernet0/0/1
ip address 10.131.0.10 255.255.255.0
negotiation auto
!
interface Serial0/2/0:1
ip address 192.168.2.2 255.255.255.0
crc 32
!
ip default-gateway 10.131.0.11
ip route 0.0.0.0 0.0.0.0 10.131.0.11
11-27-2023 11:10 AM
Hello @sblakely
Config seems to be good.
Don't need of ip default-gateway command since ip route command is configured.
Do you have a T1 cable with the good pinout?
See the screenshot attached if needed.
11-27-2023 02:31 PM
M02@rt37 The T1 cable pinout is good. We have a fluke tester going into one of the T1 cards on router 1 and a looped pinout on the T1 card on router 2. I'm partially trying to do a sanity check here on if it's even possible to directly route the signal between interfaces on different routers like that.
11-27-2023 03:32 PM
I've done back-to-back serial T1 between earlier Cisco ISRs (2800 series?).
Recall (?) using a V35 cable.
Have you seen https://www.cisco.com/c/en/us/support/docs/wan/t1-e1-t3-e3/9333-t1-back-to-back.html ?
11-27-2023 10:44 PM - edited 11-27-2023 10:46 PM
OK @sblakely, Thanks.
Miss encapsulation ppp command under serial interfaces.
Please provide us ouputs:
First ISR:
sh int serial0/1/0:1
sh controllers T1
Second ISR:
sh int serial0/2/0:1
sh controllers T1
11-28-2023 06:34 AM
If you are directly connecting the 2 routers, you will need a T1 crossover cable. Also, one side of the link needs to be 'clock source internal' or you will have slips on the link.
11-28-2023 08:07 AM - edited 11-28-2023 08:22 AM
@Elliot Dierksen @Joseph W. Doherty
For further clarification, the two routers are communicating with each other using layer 3 routing over their GigEth 0/0/1 interfaces.
Fluke -> T1 Card -> GigEth0/0/1 -> GigEth0/0/1 -> T1 Card -> Loop
| ISR 2 | ISR 1 |
M02@rt37 Outputs below
ISR 1
show int serial0/1/0:1
Serial0/1/0:1 is down, line protocol is down
Hardware is NIM-4MFT-T1/E1
Internet address is 192.168.1.2/24
MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,
reliability 202/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 32, loopback not set
Keepalive set (10 sec)
Last input 1w0d, output 00:00:08, output hang never
Last clearing of "show interface" counters 1w2d
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
29587 packets input, 2554765 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
3584238056 input errors, 1761820468 CRC, 0 frame, 0 overrun, 0 ignored, 1822417588 abort
90876 packets output, 4286763 bytes, 0 underruns
Output 0 broadcasts (0 IP multicasts)
0 output errors, 0 collisions, 10 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
20 carrier transitions alarm present
Timeslot(s) Used:1-24, subrate: 64Kb/s, transmit delay is 0 flags
sh controllers T1
T1 0/1/0 is up
Applique type is Channelized T1
Cablelength is short 110
No alarms detected.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Clear LOF State:Clear
Framing is ESF, Line Code is B8ZS, Clock Source is Line Primary.
BER thresholds: SF = 10e-3 SD = 10e-6
Data in current interval (829 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Total Data (last 24 hours)
8116 Line Code Violations, 10 Path Code Violations,
6 Slip Secs, 2 Fr Loss Secs, 2 Line Err Secs, 0 Degraded Mins,
5 Errored Secs, 1 Bursty Err Secs, 0 Severely Err Secs, 5 Unavail Secs
ISR 2
show int serial0/2/0:1
Serial0/2/0:1 is up, line protocol is up (looped)
Hardware is NIM-4MFT-T1/E1
Internet address is 192.168.2.2/24
MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 32, loopback not set
Keepalive set (10 sec)
Last input 00:00:01, output 00:00:01, output hang never
Last clearing of "show interface" counters 1w2d
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
951 packets input, 85863 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
3 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored, 2 abort
951 packets output, 85863 bytes, 0 underruns
Output 0 broadcasts (0 IP multicasts)
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
9 carrier transitions no alarm present
Timeslot(s) Used:1-24, subrate: 64Kb/s, transmit delay is 0 flags
sh controllers T1
T1 0/2/0 is up
Applique type is Channelized T1
Cablelength is short 110
No alarms detected.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Clear LOF State:Clear
Framing is ESF, Line Code is B8ZS, Clock Source is Line Secondary.
BER thresholds: SF = 10e-3 SD = 10e-6
Data in current interval (522 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Total Data (last 24 hours)
6 Line Code Violations, 3 Path Code Violations,
1 Slip Secs, 76 Fr Loss Secs, 3 Line Err Secs, 0 Degraded Mins,
3 Errored Secs, 0 Bursty Err Secs, 1 Severely Err Secs, 75 Unavail Secs
11-28-2023 08:20 AM
Thanks @sblakely
Somewhere the link is given hard loop !
11-28-2023 03:40 PM
Oops, I just realized I had the two ISR's backwards. The setup is as follows
Fluke -> T1 Card -> GigEth0/0/1 -> GigEth0/0/1 -> T1 Card -> Loop
| ISR 1 | ISR 2 |
So yes, ISR 2 does have a hard loop on it specifically to loop back the bits sent from the Fluke 635 QuickBERT tester.
11-28-2023 07:39 PM
I am late to the discussion and perhaps there are things in the discussion that I have not appropriately considered. But I focus on this from the OP "Currently it's just the two IRS4451 devices directly connected by a Cat6 cale". In my experience of doing T1 between routers it has required a specific T1 crossover pinout. I don't think Cat6 can do that.
11-28-2023 08:53 AM
@sblakely wrote:
@Elliot Dierksen @Joseph W. Doherty
For further clarification, the two routers are communicating with each other using layer 3 routing over their GigEth 0/0/1 interfaces.
Fluke -> T1 Card -> GigEth0/0/1 -> GigEth0/0/1 -> T1 Card -> Loop
| ISR 2 | ISR 1 |
OK, so what is it you are trying to accomplish with the T1 (circuit emulation, voice, etc)? I have done several kinds of connections for voice faking out the devices in either side into thinking they were directly connected. If it is some kind of voice device with a proprietary common signaling channel protocol then CCS frame forwarding is what you want. I haven't done the circuit emulation stuff, so I can't comment on that.
11-28-2023 10:31 AM
The hope is to connect a T1 line to one of these ISR routers in one location, convert to ethernet and pass through our layer 2/3 ethernet network to another ISR router in a different location, and convert back to T1 for a device on the other end of the line. It's going to be transmitting a combination of voice and other data so I'm guessing the circuit emulation is going to be a good plan.
11-28-2023 11:55 AM
Perhaps I am missing something, but trying to pass circuit emulation over ethernet is 100% not the way I would do that. If you have to do a T1/E1 for voice, do it as a PRI. That will require DSP's (PVDM modules) and the appropriate feature set. Do the data stuff via native routing over ethernet. What are the voice devices you are trying to connect?
11-28-2023 02:52 PM
While I agree it's not the best way, it's unfortunately the situation I've been handed to try and solve. We have Juniper CTP151 devices in other locations doing the same process, but we're trying to find Cisco equipment that can do it as we're a predominantly Cisco infrastructure.
Currently the only device producing data that we're trying to route through this link is a Fluke 635a QuickBERT T1.
11-28-2023 10:57 PM
If you agree it isn't the best way. why not investigate alternatives? Given that, I return to the question of what kind of device is it that you want to connect to the T1 port?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide