cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
875
Views
0
Helpful
5
Replies
Highlighted
Beginner

TFTP Service

All,

  i am trying to find a way to verify that the TFTP service is not running on the router.  i issued the no tftp-server flash: <ios> and it accepted it even though it does not show up in the show running config.   any docs would be helpful.                  

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

If the command isn't in the running config, it's disabled. The tftp server isn't turned on by default. There are version differences that seem to either support the control-plane command and those that don't. I have a 3845 that has it, but I have a 3825 that doesn't. Here's a 3745 that does that would show you the results should you decide to maybe update your router:

R1#sh control-plane host open-ports

Active internet connections (servers and established)

Prot        Local Address      Foreign Address                  Service    State

tcp                 *:23                  *:0                   Telnet   LISTEN

udp                 *:69                  *:0              TFTP-Server   LISTEN

R1#

HTH,

John

HTH, John *** Please rate all useful posts ***

View solution in original post

5 REPLIES 5
Highlighted
Advisor

If you have the command, you can do:

sh control-plane host open-ports

HTH,

John

HTH, John *** Please rate all useful posts ***
Highlighted

no i do not have that command available.  its a 3800 series router.

Highlighted

sh ip socket will show me the ports is listening on but, i was looking for a doc that states that by default the TFTP service is disabled and how to verify that it is not running.

Highlighted

If the command isn't in the running config, it's disabled. The tftp server isn't turned on by default. There are version differences that seem to either support the control-plane command and those that don't. I have a 3845 that has it, but I have a 3825 that doesn't. Here's a 3745 that does that would show you the results should you decide to maybe update your router:

R1#sh control-plane host open-ports

Active internet connections (servers and established)

Prot        Local Address      Foreign Address                  Service    State

tcp                 *:23                  *:0                   Telnet   LISTEN

udp                 *:69                  *:0              TFTP-Server   LISTEN

R1#

HTH,

John

HTH, John *** Please rate all useful posts ***

View solution in original post

Highlighted

thanks