cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2670
Views
20
Helpful
11
Replies

Tunnel gre site-to-site and redistribution of routing OSPF and EIGRP

I would like to configure OSPF and EIGRP redistribution on routers R0 and R1 via tunnel gre, like in the scheme.

I will be greatful for help in configuration.

Below is actual  R0 and R2 configuration 

R0

interface Loopback0
ip address 10.0.0.1 255.255.0.
!

interface Loopback1
ip address 10.10.0.1 255.255.0.0
!
interface Tunnel0
ip address 172.16.0.1 255.255.255.252
mtu 1476
tunnel source Serial0/0/0
tunnel destination 160.0.0.6
!
interface Serial0/0/0
ip address 160.0.0.2 255.255.255.252
!

router eigrp 1
network 10.0.0.0 0.0.255.255
network 10.10.0.0 0.0.255.255
network 172.16.0.0 0.0.0.3
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0


R2

interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
ip address 192.168.10.1 255.255.255.0
!
interface Tunnel0
ip address 172.16.0.2 255.255.255.252
mtu 1476
tunnel source Serial0/0/0
tunnel destination 160.0.0.2
!
interface Serial0/0/0
ip address 160.0.0.6 255.255.255.252
!
router ospf 1
network 192.168.0.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.3 area 0
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0

11 Replies 11

Hi

You could use a dynamic routing protocol between the routers (ospf or eigrp) then redistribute on the other protocol. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

The configuration of the GRE tunnel is pretty straightforward and should work fine. The configuration of the routing protocol is surprising and as shown here would be problematic. Router R0 is running EIGRP over the tunnel. But there is no EIGRP neighbor through the tunnel. So there will be no advertisement of EIGRP routes and no learning of EIGRP routes over the tunnel. Similarly on R2 is running OSPF over the tunnel. But there is no OSPF neighbor on the tunnel so there will be no advertising of OSPF routes and no learning of OSPF routes over the tunnel.

For this to work there has to be a device that is running both protocols and doing redistribution between the protocols.

HTH

Rick

HTH

Rick

Thank you for advice.

So i add on:

  • R0

int loopback2 192.168.20.1/24 and run proces OSPF 1 and doing redistribution on both routing protocols


router ospf 1
network 192.168.10.0 0.0.0.255 area 0
redistribute eigrp 1 subnets

router eigrp 1
redistribute ospf 1 metric 1000 33 255 1 1500

  • R2

int loopback2 10.30.0.1/16 and run proces EIGRP 1 and doing redistribution on both routing protocols

router eigrp 1
redistribute ospf 1 metric 100 50000 255 1 17916
network 10.30.0.0 0.0.255.255

router ospf 1
redistribute eigrp 1 subnets

But this doesn't work, what's wrong?
On the symulation mode it's communicat "The OSPF process for this ID is not running. The device drops the packet." when R2 sends OSPF packet to R0. I don't understand why.

Hello,

here is a working config with mutual redistribution on both routers:

R0

interface Loopback0
ip address 10.0.0.1 255.255.0.
!
interface Loopback1
ip address 10.10.0.1 255.255.0.0
!
interface Tunnel0
ip address 172.16.0.1 255.255.255.252
mtu 1476
tunnel source Serial0/0/0
tunnel destination 160.0.0.6
!
interface Serial0/0/0
ip address 160.0.0.2 255.255.255.252
!
router eigrp 1
network 10.0.0.0 0.0.255.255
network 10.10.0.0 0.0.255.255
network 172.16.0.0 0.0.0.3
redistribute ospf 1 metric 1500 2000 255 1 1500
!
router ospf 1
redistribute eigrp 1 metric 50000 subnets
network 10.0.0.0 0.0.255.255 area 0
network 10.10.0.0 0.0.255.255 area 0
network 172.16.0.0 0.0.0.3 area 0

!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0

R2

interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
ip address 192.168.10.1 255.255.255.0
!
interface Tunnel0
ip address 172.16.0.2 255.255.255.252
mtu 1476
tunnel source Serial0/0/0
tunnel destination 160.0.0.2
!
interface Serial0/0/0
ip address 160.0.0.6 255.255.255.252
!
router ospf 1
redistribute eigrp 1 metric 50000 subnets
network 192.168.0.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.3 area 0
!
router eigrp 1
network 172.16.0.0 0.0.0.3
network 192.168.0.0
network 192.168.10.0
redistribute ospf 1 metric 1500 2000 255 1 1500
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0

The problem with what you have done to run both routing protocols is that you have enabled the routing protocol on interfaces which have no physical connection. So while OSPF is running on R0 there is not any way that it can send OSPF hello messages and become a neighbor with R2. And a similar issue with running EIGRP on R2. The protocol is running on a loopback interface but can not send or receive EIGRP hello messages with R0.

For this to work both routing protocols must be running on interfaces that connect to the neighbor router.

HTH

Rick

HTH

Rick

I'm not sure i understood you.

Will it work when instead of loopback interfaces i use physical interfaces or redistribution is impossible until establish connection between both sites via physical line?

I would like to try to explain this starting with two very fundamental concepts about redistribution and dynamic routing protocols.

1) running a dynamic routing protocol makes sense when the routing protocol will be able to form a neighbor relationship with at least one other router and then be able to advertise some routes to that neighbor or learn some routes from that neighbor. It makes very little sense to run a dynamic routing protocol when it will not form any neighbor relationships and not able to learn or advertise any routes with a neighbor.

2) redistribution of routes between two routing protocols is always possible if a router is running both protocols. But for redistribution to accomplish anything a routing protocol must have learned some routes that it can redistribute to the other protocol.

With those points in mind we can see that running EIGRP or OSPF only on a loopback interface is not effective. It can not form any neighbor relationship and can not learn any routes. So it has no routes to offer for redistribution. And while it might learn routes from the other protocol it has no neighbor to which it can advertise them.

I hope that this helps you to understand better what is required.

HTH

Rick

HTH

Rick

Ok, so let's say that behind R0 are 2 additional routers which work in domain EIGRP  together with R0, and similarly on the second site but with OSPF domain.

On R0  let's configure process OSPF with network 172.16.0.0 (tunnel GRE). So now R0 has configured two dynamic routing protocol. Obviously on R2 network 172.16.0.0 is added to OSPF process.

I think now two conditions are met and it should work. Please verify my way of thinking.

Below is scheme.

I am puzzled at this statement

On R0  let's configure process OSPF with network 172.16.0.0 (tunnel GRE). So now R2 has configured two dynamic routing protocol

I am not clear whether you really meant to say R2 or whether that is just a typo and you meant R0 (which is the one with two dynamic routing protocols). Assuming that it was a typo then you have a correct understanding. You did not mention it but let me point out that you would do redistribution on R0 (EIGRP to OSPF and also OSPF to EIGRP) and no need for redistribution on R2.

HTH

Rick

HTH

Rick

Of course, i mistook. 
I edited the typo.

Rick, thank you for your support!

You are quite welcome. These forums are excellent places to learn about networking. I am glad that this discussion has been beneficial to your understanding.

HTH

Rick

HTH

Rick
Review Cisco Networking for a $25 gift card