01-01-2018 07:25 PM - edited 03-05-2019 09:42 AM
Hi. I'm having difficulty getting Bridge-Domain to work on my ISR4351/K9 Router.
Topology is as follows:
Router Interface g0/0/1 & 2 will go into a Firewall eventually but for testing I have them connected to a unmanaged hub and my pc is connected to this to create a network.
When I only have 1 link up on the Router (either 1 or 2) I PC can ping the Router no problems but when I connect the 2nd cable I start to get a loop... I know this because interface counters on g0/0/1 & 2 start to increment like crazy up to the 400Mb limit of my Router.
Config is as follows:
bridge-domain 1
!
bridge irb
!
interface GigabitEthernet0/0/1
description inside
no ip address
load-interval 30
negotiation auto
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
!
interface GigabitEthernet0/0/2
description inside
no ip address
load-interval 30
negotiation auto
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
!
interface BDI1
ip address 123.123.123.1 255.255.255.0
Must be missing something really simple!
Anybody help will be greatly appreciated.
TIA.
Solved! Go to Solution.
01-03-2018 04:21 PM
01-01-2018 07:37 PM - edited 01-01-2018 07:39 PM
Hi
Try with this configuration:
bridge irb
bridge 1 protocol ieee
bridge 1 route ip
interface g0/0/1
bridge-group 1
interface g0/0/2
bridge-group 1
interface bvi 1
ip address x.x.x.x y.y.y.y
no shutdown.
The following link can be useful, it includes: BVI and BDI (Bridge domain interface):
Hope it is useful
:-)
01-01-2018 07:54 PM
No go :(
I don't have IEEE option type:
Routert(config)#bridge 1 protocol ?
dec DEC protocol
ibm IBM protocol
vlan-bridge vlan-bridge protocol
Router(config)#bridge 1 protocol
And in the Interface I don't have an option to put down 'bridge-group 1'.
My Router is running this IOS: isr4300-universalk9.03.16.06b.S.155-3.S6b-ext.SPA
So it's an IOS-XE...
If I have only 1 leg up PC can ping the Router but when both legs are up ping times out so probably related to a loop happening?
01-02-2018 01:33 AM
Hello,
on a side note, and I don't know if that output is just omitted, make sure you have your service instance configured as well:
bridge-domain 1
!
bridge irb
!
interface GigabitEthernet0/0/1
description inside
no ip address
load-interval 30
negotiation auto
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
!
interface GigabitEthernet0/0/2
description inside
no ip address
load-interval 30
negotiation auto
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
!
service instance 1 ethernet
bridge-domain 1
!
interface BDI1
ip address 123.123.123.1 255.255.255.0
01-02-2018 03:39 PM
01-03-2018 01:10 AM
Hello,
the command is:
Router(config)#service instance
without the dash. What are your options at:
Router(config)#service ?
01-03-2018 01:15 AM
01-03-2018 01:16 AM
01-03-2018 07:25 AM
"service instance" is configured under the interface.
01-03-2018 12:36 PM
01-03-2018 01:38 PM - edited 01-03-2018 01:52 PM
service instance isn't a global config. You also don't need "bridge irb"... that is for bridge-groups and BVI interfaces.
This is the bare minumum you need.
bridge-domain 1
!
interface GigabitEthernet0/0/1
no shut
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
!
interface GigabitEthernet0/0/2
no shut
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
!
interface BDI1
ip address 123.123.123.1 255.255.255.0
no shut
Also if you plug both of them into a hub or dumb switch at the same time you are creating an L2 loop which leads to a broadcast storm and your interfaces will eventually not process any traffic because they are 100 percent full with replicated frames.
01-03-2018 04:21 PM
01-03-2018 04:49 PM
So it was a loop problem...
Now you can add all of your bonus features you want on the router.
01-03-2018 05:04 PM
05-22-2019 08:57 AM
Hi,
I am not getting option of Bridge under GigabitEthernet or Serial Interface. How do I configure Bridge command under any interface.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide