04-17-2024 05:28 AM
Hello, I built using the packet tracer a simple topology of three routers with ospf routing. I created a tunnel between the two routers that are not physically connected to each other, but I can't ping between one end and the other. I managed to ping between two in loopbacks.
hanks for all replies.
Router#show run
Building configuration...
Current configuration : 1084 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX152412Z5-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
ip address 10.10.10.254 255.255.255.0
!
interface Tunnel0
ip address 100.100.100.10 255.255.255.0
mtu 1476
tunnel source Loopback0
tunnel destination 20.20.20.254
!
!
interface GigabitEthernet0/0
ip address 10.0.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.0.5.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 10.0.1.0 0.0.0.255 area 0
network 192.168.1.1 0.0.0.0 area 0
network 100.100.100.0 0.0.0.3 area 0
network 10.0.5.0 0.0.0.255 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
____________________________________________
Router#show run
Building configuration...
Current configuration : 1084 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX152412Z5-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
ip address 10.10.10.254 255.255.255.0
!
interface Tunnel0
ip address 100.100.100.10 255.255.255.0
mtu 1476
tunnel source Loopback0
tunnel destination 20.20.20.254
!
!
interface GigabitEthernet0/0
ip address 10.0.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.0.5.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 10.0.1.0 0.0.0.255 area 0
network 192.168.1.1 0.0.0.0 area 0
network 100.100.100.0 0.0.0.3 area 0
network 10.0.5.0 0.0.0.255 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Solved! Go to Solution.
04-18-2024 06:59 AM
Hi @noforshow92 ,
I am unable to download the file from this link. Can you please zip the file and upload it here.
Regards,
04-18-2024 07:13 AM
04-18-2024 07:29 AM
Hi @noforshow92 ,
I made the modification to use the physical interface instead of the loopback interface as recommended previously and it works for me.
Router2:
interface Tunnel0
ip address 100.100.100.10 255.255.255.0
mtu 1476
tunnel source GigabitEthernet0/0
tunnel destination 10.0.2.1
!
Router1:
interface Tunnel0
ip address 100.100.100.20 255.255.255.0
mtu 1476
tunnel source GigabitEthernet0/1
tunnel destination 10.0.1.1
!
Router#ping 100.100.100.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
Router#ping 100.100.100.20
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
Regards,
04-18-2024 10:27 AM
Thank you very much man!.
It seems like only the port that connected to the third router can function as a source and destination, any other port on routers does not work with gre vpn, including the loopbacks. is that right?
Another thing, why doesn't my CLI recognize the mtu command?
Router(config)#int tunnel 0
Router(config-if)#mtu
Router(config-if)#mtu?
% Unrecognized command
04-18-2024 11:32 AM - edited 04-18-2024 11:34 AM
Hi @noforshow92 ,
> It seems like only the port that connected to the third router can function as a source and destination
I have not done extended testing, but it looks like it is the case.
> Another thing, why doesn't my CLI recognize the mtu command?
This command is auto generated and it appears like you can't change it manually.
Bear in mind that Cisco Packet Trace is a network simulation tool and although it does an excellent job at providing a great learning experience, many restrictions in this tool are not present when you use real devices.
Regards,
Regards,
04-18-2024 03:54 AM
You have to add diagram as well and draw all your ip on interfaces so that we can help you with.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide