cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2608
Views
0
Helpful
17
Replies

Upgrade ROMMON ASR1004-RP2

sebastien3
Participant
Participant

Hello,

 

I get the following messages upgrade rom-monitor filename bootflash:asr1000-rommon.169_5r_SPA.pkg all :

ROMMON upgrade complete.
To make the new ROMMON permanent, you must restart the RP.

Upgrade rom-monitor on Embedded-Service-Processor 0

Target copying rom-monitor image file
rsync: link_stat "rommon/mcp/FP/20G/latest.bin" (in rommon_upgrade_pub) failed: No such file or directory (2)
rsync error: some files could not be transferred (code 23) at /scratch/mcpre/release/BLD-V03_16_10_S_FC3/contrib/rsync/main.c(1392) [receiver=2.6.9]

Upgrade rom-monitor on SPA-Inter-Processor 0

Target copying rom-monitor image file
rsync: link_stat "rommon/mcp/CC/10G/latest.bin" (in rommon_upgrade_pub) failed: No such file or directory (2)
rsync error: some files could not be transferred (code 23) at /scratch/mcpre/release/BLD-V03_16_10_S_FC3/contrib/rsync/main.c(1392) [receiver=2.6.9]
Slot      CPLD Version        Firmware Version
--------- ------------------- ---------------------------------------
0         09111601            15.3(3r)S
R0        10021901            16.9(5r)
F0        08041102            15.5(3r)S1

Is this problematic if the version of a firmware is not the same on an ASR1004-RP2 concerning Slot 0; R0 and F0 ??

 

I have this IOS version : asr1000rp2-adventerprisek9.03.16.10.S.155-3.S10-ext.bin

Thank !

17 Replies 17

Hi @Deepak Kumar,

My IOS XE is 03.16.10.S, on your url I don't show this version...

mgrabovs
Cisco Employee
Cisco Employee

Hello,

 

You can check this page which is the release notes for your running IOS-XE: https://www.cisco.com/c/en/us/td/docs/routers/asr1000/release/notes/asr1k_rn_rel_notes/asr1k_rn_sys_req.html#19706 

 

In there you can check the section ROMmon Release Requirements

This is happening due to the fact that the ROMmon version you're trying to install is not compatible with the running version you have.

 

Thanks

Marin

Hi, 

There is no ROMMON version 16.9(5r) for ESP, SIP and MIP modules.

 

https://community.cisco.com/t5/routing/unable-to-upgrade-asr1000-esp40-to-16-9-5r-rom-monitor/td-p/3863856

 

A Tabela 1 exibe as versões mínimas e recomendadas do ROMMON para cada módulo ASR1000.

https://www.cisco.com/c/en/us/td/docs/routers/asr1000/rommon/asr1000-rommon-upg-guide.html#concept_zdm_2nx_5bb

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers