cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1623
Views
0
Helpful
6
Replies
Ansir Ilyas
Beginner

Voice Port remains "Off-hook” if caller doesn't get response in TCL Script

I have Cisco ISR 4321 router with VIC-4FXO card installed. It’s running CME version 11.5. I’ve configured TCL script for AA (Auto Attendant) which is working fine as it is supposed to be. (CUE is not installed)

 

When someone calls from outside (inbound call on FXO), Voice Port gets “Off-Hook” and TCL script triggers AA which asks the caller to dial some extension, the caller dials the ext and AA forwards the call to that extension and the person on that extension doesn’t answer, the AA plays media file for “Destination is unreachable”, but if the outside caller hangs up (disconnect) the call even then Voice Port remains “Off-Hook” status and this voice port can’t be used for making or receiving any outside call until I do “shutdown” and “no shutdown” manually in the Router.

 

Running Configuration is attached for reference. 

 

 

- Hafiz M Ansir 

6 REPLIES 6
Nipun Singh Raghav
Cisco Employee

How about testing it bypassing tcl and just route the call directly to a phone and see if its the same behaviour ? If it is then we would need to tweak some parameters.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"

when I bypass TCL script then port is released after few rings are not answered... but when it is passed through TCL Script the port is not released until I "shutdown" it and then "no shutdown" 

 

P.S: when I'm bypassing the TCL script, it rings the extension number, but upon every ring voice-port is engaged and after every ring the voice-port is released. (picture is attached) 

 

 

BNIT-JED-ISR(config-voiceport)#do sh voice po su
IN OUT
PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
=============== == ============ ===== ==== ======== ======== ==
0/1/0 -- fxo-ls up dorm idle on-hook y
0/1/1 -- fxo-ls up up ring-det off-hook y
0/1/2 -- fxo-ls up dorm idle on-hook y
0/1/3 -- fxo-ls up dorm idle on-hook y
50/0/48 1 efxs up dorm on-hook idle y
50/0/112 1 efxs up dorm on-hook ringing y
50/0/112 2 efxs up dorm on-hook ringing y

PWR FAILOVER PORT PSTN FAILOVER PORT
================= ==================

BNIT-JED-ISR(config-voiceport)#
BNIT-JED-ISR(config-voiceport)#
BNIT-JED-ISR(config-voiceport)#do sh voice po su
IN OUT
PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
=============== == ============ ===== ==== ======== ======== ==
0/1/0 -- fxo-ls up dorm idle on-hook y
0/1/1 -- fxo-ls up dorm idle on-hook y
0/1/2 -- fxo-ls up dorm idle on-hook y
0/1/3 -- fxo-ls up dorm idle on-hook y
50/0/48 1 efxs up dorm on-hook idle y
50/0/112 1 efxs up dorm on-hook idle y
50/0/112 2 efxs up dorm on-hook idle y

PWR FAILOVER PORT PSTN FAILOVER PORT
================= ==================

BNIT-JED-ISR(config-voiceport)#

Georg Pauwen
VIP Expert

Hello Ansir,

 

apparently this is a common problem. Which country are you in ?

 

Check the thread below, it lists various solutions for voice port configuration...

 

https://supportforums.cisco.com/t5/ip-telephony/fxo-incoming-call-disconnect-problem/td-p/2203774

hi Georg, 

I'm in Riyadh, Saudi Arabia. We are using STC analog lines. I just called in STC help line and the representative told me that these are "Loop Start" lines. 

I've read in the mentioned post that there is a bug in Loop Start in STC analog lines, I'll apply the suggested solution and inform you. 

 

Thank you.

I applied following commands (taken from the mentioned link) in Voice-port but still same situation.. 

https://supportforums.cisco.com/t5/ip-telephony/fxo-incoming-call-disconnect-problem/td-p/2203774

 

 

!
voice-port 0/1/1
supervisory disconnect anytone
no battery-reversal
groundstart auto-tip
input gain 3
echo-cancel coverage 32
cptone SA
timeouts initial 0
timeouts interdigit 5
timeouts call-disconnect 0
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing sup-disconnect 85
connection plar opx immediate 198
description **** STC Line_2 012-xxxx769 ****
bearer-cap Speech
caller-id enable
!

aneesap90
Beginner

Dear ,

 

Did you resolve the issue..I have same issue for FXO. I have router 4321.Issue is fxo is always get offhook even after call end. I checked many custom CP tone configuration and result is same. I work in saudi. Please let me know if you have any suggestion .