01-17-2016 01:25 AM - edited 03-05-2019 03:08 AM
Dear All,
I have problem with VRF Lite and NAT on IOS
I tried two configuration without success
!
! ### Config 1
!
version 15.5
!
interface GigabitEthernet0/0
ip vrf forwarding EXTERNAL
ip address 8.1.61.118 255.255.255.248
ip nat enable
!
interface GigabitEthernet0/1
ip vrf forwarding EXTERNAL
ip address 2.1.155.50 255.255.255.240
ip nat enable
!
ip nat source static 2.1.155.61 8.1.61.116 vrf EXTERNAL
!
! ### Config 2
!
version 15.5
!
interface GigabitEthernet0/0
ip vrf forwarding EXTERNAL
ip address 8.1.61.118 255.255.255.248
ip nat outside
!
interface GigabitEthernet0/1
ip vrf forwarding EXTERNAL
ip address 2.1.155.50 255.255.255.240
ip nat inside
!
ip nat inside source static 2.1.155.61 8.1.61.116 vrf EXTERNAL
!
! when I remove VRFs everything is working fine
Kind regards,
Vice Lacmanovic
01-17-2016 01:47 AM
I also tried
!
ip nat inside source static 2.1.155.61 8.1.61.116 vrf EXTERNAL extendable match-in-vrf
!
Kind regards,
Vice Lacmanovic
01-17-2016 03:33 AM
I think that vrf require the "ip nat enable" commando, not ip nat inside|outside
Bye,
enrico
PS: please rate if useful
01-18-2016 07:30 AM
Hi,
what exactly did not work?
How did you test (trace/capture packets)?
Was routing for the VRF configured correctly?
Regards,
Milan
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide