cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3113
Views
0
Helpful
6
Replies
Highlighted
Beginner

vrrp stuck in Init state

Hi, 

I notice an issue in my new setup with vrrp status. When checked from the router 1 and router 2 perspective where the router 1 which is configured with lower priority takes the Master role while the router 2 which is configured with higher priority takes the Init role without getting into the Master state. Below is the configuration. Please advise for any changes which can set right the vrrp status. 

ACL LAB config

ip access-list extended LAB

10 permit ip any 10.0.0.0 0.255.255.255

20 permit ip any 224.0.0.0 15.255.255.255 

30 deny ip any any

Router 1 interface configuration: 

interface FastEthernet0/0
ip address 20.45.21.150 255.255.255.192
ip access-group LAB in
no ip redirects
no ip unreachables
no ip proxy-arp
ip accounting output-packets
ip flow ingress
ip flow egress
ip pim dr-priority 200
ip pim sparse-mode
load-interval 30
speed 100
full-duplex
vrrp 1 ip 20.45.21.149
vrrp 1 timers learn
vrrp 1 priority 150
vrrp 1 track 1 decrement 20
fair-queue
no cdp enable
no mop enabled
end

Router 1 vrrp status

show vrrp
FastEthernet0/0 - Group 1
State is Master
Virtual IP address is 20.45.21.149
Virtual MAC address is 0000.5e00.0101
Advertisement interval is 1.000 sec
Preemption enabled
Priority is 150
Track object 1 state Up decrement 20
Master Router is 20.45.21.150 (local), priority is 150
Master Advertisement interval is 1.000 sec
Master Down interval is 3.414 sec

track 1 rtr 92 reachability

show track 1
Track 1
Response Time Reporter 92 reachability
Reachability is Up
1 change, last change 03:44:18
Latest operation return code: OK
Latest RTT (millisecs) 4
Tracked by:
VRRP FastEthernet0/0 1

ip sla 92
icmp-echo 25.24.160.101 source-ip 25.24.160.102
timeout 2000
threshold 2000
frequency 10
ip sla schedule 92 life forever start-time now

Router 2 configuration

=================

interface FastEthernet1
ip address 20.45.21.151 255.255.255.192
ip access-group LAB  in
no ip redirects
no ip unreachables
no ip proxy-arp
ip accounting output-packets
ip flow ingress
ip flow egress
ip pim dr-priority 240
ip pim sparse-mode
no ip mroute-cache
duplex auto
speed 100
vrrp 1 ip 20.45.21.149
vrrp 1 priority 160
vrrp 1 track 2 decrement 20
fair-queue
no cdp enable
end

Router 2 vrrp status

show vrrp
FastEthernet1 - Group 1
State is Init
Virtual IP address is 20.45.21.149
Virtual MAC address is 0000.5e00.0101
Advertisement interval is 1.000 sec
Preemption is enabled
min delay is 0.000 sec
Priority is 160
Track object 2 state Up decrement 20
Master Router is 20.45.21.150, priority is 150
Master Advertisement interval is 1.000 sec
Master Down interval is 3.375 sec

track 2 rtr 19 reachability

show track 2
Track 2
Response Time Reporter 19 reachability
Reachability is Up
5 changes, last change 04:12:27
Latest operation return code: OK
Latest RTT (millisecs) 4
Tracked by:
VRRP FastEthernet1 1

rtr 19
type echo protocol ipIcmpEcho 96.52.239.116 source-ipaddr 96.52.239.115
timeout 2000
threshold 2000
frequency 10
rtr schedule 19 life forever start-time now

6 REPLIES 6
Highlighted
VIP Mentor

Hi

If you remove that acl does it work ,just wondering as vrrp is 224.0.0.18

are these routers directly connected between those interfaces or is there a layer 2 switch  , is this virtual or physical kit  

Highlighted

my vrrp backup router also stuck in init state.

 

I have a switch in between the two routers any idea?

Highlighted

Hello,

 

how are the switchports configured ? Also post the (VVRP) configs of both sides...

Highlighted
VIP Advocate

Hi,

I tested the mentioned configuration in my lab and it is working fine without any issue. I hope there is some issue with your switch port configuration. Did you configure any ACL/VACL on the switch?

 

Regards,

Deepak Kumar

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Highlighted
VIP Mentor

Hello

Debug vrrp all



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

I had this problem with the Nexus 9k. In my case a no shutdown on the vrrp was necessary.

 

int vlan 9

vrrp 9

no shut