cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1147
Views
0
Helpful
3
Replies

WAN HSRP status

Bob Greer
Level 4
Level 4

Hi there,

 

Thanks for reading.

I have a pair of high availability HSRP routers for which i've configured in-place replacement routers.  I know that i can work on the router in Standby status without worrying about interrupting traffic but i'd like to manually change status on the Active router to Standby once I've replaced the current Standby.

Attached are the (I think) relevant show outputs.

What are the commands to do this?

Thanks!

Bob

3 Replies 3

Seth Beauchamp
Level 1
Level 1
You will need to use something like "standby 1 priority 250" to increase the priority on the other router. You will also need to configure preempt so that the router will take over after configuring the new priority "standby 1 preempt".

Then just remove the priority command afterwards to flip back over if you want. I would recommend leaving preempt on both sides though, if the primary decrements to a value lower than the secondary, it still wont flip over if preempt is not configured.

Jaderson Pessoa
VIP Alumni
VIP Alumni

@Bob Greer hello,

 

add commands in bold to solve your problem

 

RT01 & RT02

RT01
interface GigabitEthernet0/0
description Internet
ip address aa.107.183.yy 255.255.255.224
ip nat outside
standby 1 ip aa.107.183.xx
standby 1 timers 1 10
standby 1 priority 200
standby 1 preempt
standby 1 name xvpn_ha
standby 1 track 1 decrement 150
crypto map xvpn redundancy xvpn_ha
end
!
interface GigabitEthernet0/1
description LAN
ip address 10.150.249.249 255.255.255.0
ip nat inside
standby 10 ip 10.150.249.250
standby 10 priority 200
standby 10 preempt
standby 10 track 2 decrement 150

|
Interface Grp Pri P State Active Standby Virtual IP
Gi0/0 1 200 P Active local aa.107.183.xx aa.107.183.yy
Gi0/1 10 200 P Active local 10.150.249.248 10.150.249.250

===============================================================

RT02
interface GigabitEthernet0/0
description INTERNET

ip address aa.107.183.xx 255.255.255.224

ip nat ouside
standby 1 ip aa.107.183.xx
standby 1 timers 1 10
standby 1 name xvpn_ha

standby 1 preempt
standby 1 track 1 decrement 150
crypto map xvpn redundancy xvpn_ha
end

interface GigabitEthernet0/1
description LAN
ip address 10.150.249.248 255.255.255.0
ip nat inside
standby 10 ip 10.150.249.250

standby 10 preempt

standby 10 track 2 decrement 150
end

P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Gi0/0 1 100 Standby aa.107.183.yy local aa.107.183.xx
Gi0/1 10 100 Standby 10.150.249.249 local 10.150.249.250

 

if possible, share track 1 and configuration and your default routes;

 

Regards,

Jaderson Pessoa
*** Rate All Helpful Responses ***

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Bob,

you have two different HSRP groups on two different interfaces.

 

In order to make RT02 active for both groups in order to perform a SW update on RT01 you need

 

int gi0/0

standby 1 priority 240

int gi0/1

standby 10 priority 240

 

After RT01 comes back you just need to remove the two commands above from RT02 to go back to previous configuration

the preempt command is necessary without it no HSRP active switchover can occur. And it is needed on both routers both interfaces for their respective HSRP groups 1 and 10.

 

Hope to help

Giuseppe

 

Review Cisco Networking for a $25 gift card