cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
745
Views
0
Helpful
6
Replies

WAN Load Balancing with 2 ISP

senthilmds
Level 1
Level 1

Hi All,

i have two isp connected to my router, i have Multiple Nat pools using route maps.

here is my router config

ip nat inside source route-map Nat interface Dialer1 overload

ip nat inside source route-map Nat1 interface Dialer2 overload

!

route-map Nat permit 10

match interface Dialer1

set interface Loopback5

!

route-map Nat1 permit 10

match interface Dialer2

set interface Loopback5

!

my target requirement is load balancing with the two isp's like how UTM firewall does this functionality or similar.

regards

Senthil Kumar S

6 Replies 6

simonstoll
Level 1
Level 1

Hi

The probleme is that you have to asure that each connection always stays with the same ISP (address), otherwise your connections will get broken. I had to do the same thing but with 6 DLS link whith different adresse ranges to the same ISP. It didn't work fine until I used 6 routers for the DSL lines plus one (two for redundancy) which distributet the load to the six routers. That way we had a very cheap but fast internet connection. I don't understand 100% your config, why do you match in your nat route-map the dialer interfaces and set interface loopback5 as outgoing?

Best regards

Simon

Simon,

i have updated the post with my current running configuration,

the roue-map for dialer-interface is for selecting the appropirate nat pools and xlate the address. the wan links are terminated in a single router. you could also use route maps for multiple nat pools and get sorted out with using multiple routers.

regards

Senthil

kamlesh.sharma
Level 3
Level 3

suppose you have two different network in your LAN network x.x.x.x and y.y.y.y than match one of the network in one route--map and other one in second route -map than on lan side your load balancing will work .

for other help please give us specific information too.

please rate if it helps

HTH kamlesh

i have single lan you could ref the link below

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080093fca.shtml

multiple nat pools to support address translation at the internal segment. nat translations timeout, doesnt work for me. i have two default gateway, i need to load balance each destination address to take a path.

here is my current running configuration

ip subnet-zero

no ip source-route

!

!

no ip domain-lookup

ip domain-name test

!

ip audit notify log

ip audit po max-events 100

ip cef

vpdn enable

!

vpdn-group 1

! Default PPTP VPDN group

accept-dialin

protocol pptp

virtual-template 1

!

vpdn-group 2

!

vpdn-group DDSL

request-dialin

protocol pppoe

!

!

!

!

!

interface Loopback0

ip address 192.168.105.1 255.255.255.255

ip nat inside

!

interface Loopback5

ip address 10.1.1.1 255.255.255.255

ip nat inside

!

!

interface FastEthernet0

ip address 192.168.100.10 255.255.255.0 secondary

ip address 203.187.x.x.255.255.128

ip access-group 100 in

ip access-group 100 out

ip nat outside

speed auto

pppoe enable

pppoe-client dial-pool-number 1

!

interface Serial0

no ip address

shutdown

!

interface Virtual-Template1

ip unnumbered Loopback0

ip nat inside

ip load-sharing per-packet

peer default ip address pool default

ppp authentication pap callin

ppp ipcp dns 202.9.x.x.187.244.13

!

interface Dialer1

bandwidth 64

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp pap sent-username senthilmds@eth.net password 7 xxxxxxxxx

!

router eigrp 53

network 192.168.105.0

network 192.168.106.0 0.0.0.3

no auto-summary

no eigrp log-neighbor-changes

!

ip local pool default 192.168.105.2 192.168.105.254

ip nat pool INET 203.187.x.x.187.245.57 netmask 255.255.255.128

ip nat inside source route-map Nat interface Dialer1 overload

ip nat inside source route-map Nat1 pool INET overload

ip nat inside source static udp 192.168.100.9 69 203.187.245.57 69 extendable

ip classless

ip route 0.0.0.0 0.0.0.0 203.187.245.1 5

ip route 0.0.0.0 0.0.0.0 Dialer1 6

ip route 10.0.0.0 255.0.0.0 Null0

ip route 172.16.0.0 255.240.0.0 Null0

ip route 192.168.0.0 255.255.0.0 Null0

ip route 192.168.100.3 255.255.255.255 192.168.100.9

no ip http server

ip pim bidir-enable

!

!

no logging trap

access-list 10 permit 10.1.1.1

access-list 10 permit 192.168.100.0 0.0.0.255

access-list 10 permit 192.168.102.0 0.0.0.255

access-list 10 permit 192.168.105.0 0.0.0.255

access-list 10 permit 192.168.200.0 0.0.0.255

access-list 21 permit 218.248.16.129

access-list 21 permit 203.187.245.57

access-list 22 permit 202.54.180.65

access-list 23 permit 192.168.105.2

access-list 100 remark Deny Virus

access-list 100 deny tcp any any eq 445

access-list 100 deny tcp any any eq 135

access-list 100 deny udp any any eq 135

access-list 100 deny udp any any range netbios-ns netbios-ss

access-list 100 deny tcp any any range 137 139

access-list 100 deny udp any any eq 1434

access-list 100 deny tcp any any eq 1434

access-list 100 permit ip any any

access-list 103 permit tcp any eq www any

access-list 104 permit tcp any eq ftp any

access-list 104 permit tcp any eq ftp-data any

access-list 155 permit ip 192.168.105.0 0.0.0.255 any

access-list 155 permit ip any host 10.1.1.1

dialer-list 1 protocol ip permit

!

route-map Nat permit 10

match interface Dialer1

set interface Loopback5

!

route-map Nat1 permit 10

match ip address 155

set interface Loopback5

!

!

!

line con 0

line aux 0

line vty 0 4

!

no scheduler allocate

ntp clock-period 17180136

ntp server 192.5.41.209

end

regards

Senthil

Hi Senthil

Your config looks rather complicated :-) I d'ont understand exactly what is the inside of your network and where the two ISP's are connected as the only physical interface you are using is the ETH0 which is "outside", could you please clarify that a bit?

Simon

Simon,

it is not too complicated. it is my home network with two 128kbps internet connected. the problem is one ethernet interface, hence i use pptp tunnen to connect to the router and it becomes as a interface. rest the two wan connections are connected via ethernet and one via pppoe dialer1 interface.

if i have

ip route 0.0.0.0 0.0.0.0 di1 name dial-up

ip route 0.0.0.0 0.0.0.0 203.187.245.1 name ethernet-cable mode.

to nat the exact internal ip i use route-map to match the class.

do suggest me a method to load balance the internet. by acheving either destination based or packet based.

to get full 256k internet access speed.

regards

Senthil Kumar S

Review Cisco Networking for a $25 gift card