cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10387
Views
0
Helpful
3
Replies
Enthusiast

N2K-C2248TP-1GE Fex and autonegotiation

Hello all,

Cisco does it again...

[1] How can i see if a port has autonegotiated to a certain speed and duplex, and not been configured for a fixed speed or duplex ?

I am trying to determine how the server connected to this port is configured (can be 1000 fixed, or auto-neg)

Eth125/1/20   SRV xxxx S connected 1000      full    1000    --        

The port config is:

interface Ethernet125/1/20

  description SRV xxxx S

  switchport access vlan 1000

  spanning-tree guard root

So, I assume this one has autonegotiated ?

Where is the a-full a-1000 in the sh int status then ?

I have to use the command:"sh run int eth125/1/20 all" ?

interface Ethernet125/1/20

  description SRV xxxx S

  lacp port-priority 32768

  lacp rate normal

  lldp transmit

  lldp receive

  no switchport block unicast

  no switchport block multicast

  no hardware multicast hw-hash

  cdp enable

  switchport

  switchport mode access

  no switchport dot1q ethertype

  no switchport priority extend

  switchport access vlan 1000

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  spanning-tree bpduguard enable

  spanning-tree guard root

  no spanning-tree bpdufilter

  speed auto

  duplex auto

  flowcontrol receive off

  flowcontrol send on

  link debounce

  no beacon

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  mdix auto

  no shutdown lan

  load-interval counter 1 30

  load-interval counter 2 300

  no load-interval counter 3

  no shutdown

So, it must have autonegotated, but it is not clear from "sh int status"

sh int eth125/1/20

Ethernet125/1/20 is up

  Hardware: 100/1000 Ethernet, address: 0007.7daf.9f15 (bia 0007.7daf.9f15)

  Description: SRV xxxx S

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  Port mode is access

  full-duplex, 1000 Mb/s -> no indication of auto-neg either

  Beacon is turned off

  Input flow-control is off, output flow-control is on

  Switchport monitor is off

  EtherType is 0x8100

  Last link flapped 2d06h

  Last clearing of "show interface" counters 4d15h

  30 seconds input rate 80 bits/sec, 10 bytes/sec, 0 packets/sec

  30 seconds output rate 1224 bits/sec, 153 bytes/sec, 1 packets/sec

  Load-Interval #2: 5 minute (300 seconds)

    input rate 104 bps, 0 pps; output rate 1.19 Kbps, 1 pps

  RX

    0 unicast packets  66859 multicast packets  0 broadcast packets

    66859 input packets  5616156 bytes

    0 jumbo packets  0 storm suppression packets

    0 giants  0 input error  0 short frame  0 overrun   0 underrun

    0 watchdog  0 if down drop

    0 input with dribble  0 input discard

    0 Rx pause

  TX

    4886 unicast packets  487748 multicast packets  360719 broadcast packets

    853353 output packets  97647243 bytes

    0 jumbo packets

    0 output errors  0 collision  0 deferred  0 late collision

    0 lost carrier  0 no carrier  0 babble

    0 Tx pause

  3 interface resets

[2] Do the N2K ports even support auto duplex and half duplex ??

sh int eth125/1/20 cap

Ethernet125/1/20

  Model:                 N2K-C2248TP-1GE

  Type (Non SFP):        --

  Speed:                 100,1000,auto

  Duplex:                full             -> doh ? no auto ? no half ? only full supported ?

  Trunk encap. type:     802.1Q

  Channel:               yes

  Broadcast suppression: percentage(0-100)

  Flowcontrol:           rx-(off/on),tx-(off/on)

  Rate mode:             none

  QOS scheduling:        rx-(6q1t),tx-(1p6q0t)

  CoS rewrite:           no

  ToS rewrite:           no

  SPAN:                  yes

  UDLD:                  no

  Link Debounce:         yes

  Link Debounce Time:    yes

  MDIX:                  no

  Pvlan Trunk capable:   yes

  TDR capable:           no

  Port mode:             Switched

  FEX Fabric:            no

  POE capable:           no

[3] Once speed is configured, is autonegotiation disabled maybe ?

interface Ethernet125/1/12

  description SRV xxxxx S

  switchport access vlan 1000

  spanning-tree guard root

  speed 100

I am getting a lot of errors on this interface:

sh int count error

--------------------------------------------------------------------------------

Port       Align-Err     FCS-Err    Xmit-Err     Rcv-Err   UnderSize OutDiscards

--------------------------------------------------------------------------------

Eth125/1/12  19101784       30372           0    19132156           0           0

Can only be the case if the other port has been configured 100 full fixed, we would autoneg to 100 half then ? However, how can i see ?

sh run int Eth125/1/12 all

interface Ethernet125/1/12

  description SRV xxxxx S

  lacp port-priority 32768

  lacp rate normal

  lldp transmit

  lldp receive

  no switchport block unicast

  no switchport block multicast

  no hardware multicast hw-hash

  cdp enable

  switchport

  switchport mode access

  no switchport dot1q ethertype

  no switchport priority extend

  switchport access vlan 1000

  spanning-tree port-priority 128

  spanning-tree cost auto

  spanning-tree link-type auto

  spanning-tree port type edge

  spanning-tree bpduguard enable

  spanning-tree guard root

  no spanning-tree bpdufilter

  speed 100

  duplex auto

  flowcontrol receive off

  flowcontrol send on

  link debounce

  no beacon

  snmp trap link-status

  logging event port link-status default

  logging event port trunk-status default

  mdix auto

  no shutdown lan

  load-interval counter 1 30

  load-interval counter 2 300

  no load-interval counter 3

  no shutdown

sh int eth125/1/12

Ethernet125/1/12 is up

  Hardware: 100/1000 Ethernet, address: 0007.7daf.9f0d (bia 0007.7daf.9f0d)

  Description: SRV xxx S

  MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec,

     reliability 230/255, txload 16/255, rxload 1/255

  Encapsulation ARPA

  Port mode is access

  full-duplex, 100 Mb/s

--> mmm , doesn't seem the case, it shows "full" duplex, if it is full duplex auto-neg, then the other side is also in auto-neg, and errors can't be happening. Thanks for the inconsistency....

sh version

Software

  BIOS:      version 1.3.0

  loader:    version N/A

  kickstart: version 5.0(3)N2(1)

  system:    version 5.0(3)N2(1)

BTW: it seems TDR cable diagnostics can only be run on N5K ports, not N2K ports (even if they are "ethernet"..):

test cable-diagnostics tdr interface eth125/1/12

TDR tests can be run only on ethernet ports

regards,

GN

Everyone's tags (3)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Cisco Employee

N2K-C2248TP-1GE Fex and autonegotiation

Hello GN

2248/2224 FEX does auto-negotiate speed to either 100Mbps or 1000Mbps depending on what the far end is advertising. For duplex, the FEX only supports full duplex.

So if you hard code speed to 100 on the FEX and auto-negotiating on the far end, the far end autonegotiating device would do 100/half.

24-10-4948-1#sh run int gigabitEthernet 1/1

Building configuration...

Current configuration : 193 bytes

!

interface GigabitEthernet1/1

description ***used by prkrishn***

no switchport

ip address 1.1.1.100 255.255.255.0

logging event link-status

end

24-10-4948-1#sh int gigabitEthernet 1/1 status

Port      Name               Status       Vlan       Duplex  Speed Type

Gi1/1     ***used by prkrish connected    routed     a-half  a-100 10/100/1000-TX

24-10-4948-1#

GC-TAC-EFT-5596-A(config-if)# sh run int eth109/1/1

!Command: show running-config interface Ethernet109/1/1

!Time: Wed May 23 08:41:15 2012

version 5.2(1)N1(1)

interface Ethernet109/1/1

  spanning-tree bpdufilter enable

  speed 100

GC-TAC-EFT-5596-A(config-if)#

GC-TAC-EFT-5596-A(config-if)# sh int ethernet 109/1/1 counters errors

--------------------------------------------------------------------------------

Port          Align-Err    FCS-Err   Xmit-Err    Rcv-Err  UnderSize OutDiscards

--------------------------------------------------------------------------------

Eth109/1/1         4          1          0          5          0           0

--------------------------------------------------------------------------------

Port         Single-Col  Multi-Col   Late-Col  Exces-Col  Carri-Sen       Runts

--------------------------------------------------------------------------------

Eth109/1/1         0          0          0          0          0           4

--------------------------------------------------------------------------------

Port          Giants SQETest-Err Deferred-Tx IntMacTx-Er IntMacRx-Er Symbol-Err

--------------------------------------------------------------------------------

Eth109/1/1         0          --           0           0           0          0

TDR is not supported on any interface on the Nexus 5000 and the message you see when you try it for FEX interfaces is misleading for sure.

View solution in original post

Highlighted
Beginner

N2K-C2248TP-1GE Fex and autonegotiation

Also according to release notes.

If you configure a Cisco  Nexus 2248TP port to 100 Mbps instead of autonegotiation,  autonegotiation does not occur, which is expected behavior. Both sides  of the link should be configured to both hardwired speed or both  autonegotiate.

no speed—Autonegotiates and advertises all speeds (only full duplex)

speed 1000—Autonegotiates only for a 802.3x pause

speed 100—Does not autonegotiate; pause cannot be  advertised. The peer must be set to not autonegotiate and fix at 100  Mbps (similar to the N2248TP)

For details, see CSCte81998.

View solution in original post

3 REPLIES 3
Highlighted
Cisco Employee

N2K-C2248TP-1GE Fex and autonegotiation

Hello GN

2248/2224 FEX does auto-negotiate speed to either 100Mbps or 1000Mbps depending on what the far end is advertising. For duplex, the FEX only supports full duplex.

So if you hard code speed to 100 on the FEX and auto-negotiating on the far end, the far end autonegotiating device would do 100/half.

24-10-4948-1#sh run int gigabitEthernet 1/1

Building configuration...

Current configuration : 193 bytes

!

interface GigabitEthernet1/1

description ***used by prkrishn***

no switchport

ip address 1.1.1.100 255.255.255.0

logging event link-status

end

24-10-4948-1#sh int gigabitEthernet 1/1 status

Port      Name               Status       Vlan       Duplex  Speed Type

Gi1/1     ***used by prkrish connected    routed     a-half  a-100 10/100/1000-TX

24-10-4948-1#

GC-TAC-EFT-5596-A(config-if)# sh run int eth109/1/1

!Command: show running-config interface Ethernet109/1/1

!Time: Wed May 23 08:41:15 2012

version 5.2(1)N1(1)

interface Ethernet109/1/1

  spanning-tree bpdufilter enable

  speed 100

GC-TAC-EFT-5596-A(config-if)#

GC-TAC-EFT-5596-A(config-if)# sh int ethernet 109/1/1 counters errors

--------------------------------------------------------------------------------

Port          Align-Err    FCS-Err   Xmit-Err    Rcv-Err  UnderSize OutDiscards

--------------------------------------------------------------------------------

Eth109/1/1         4          1          0          5          0           0

--------------------------------------------------------------------------------

Port         Single-Col  Multi-Col   Late-Col  Exces-Col  Carri-Sen       Runts

--------------------------------------------------------------------------------

Eth109/1/1         0          0          0          0          0           4

--------------------------------------------------------------------------------

Port          Giants SQETest-Err Deferred-Tx IntMacTx-Er IntMacRx-Er Symbol-Err

--------------------------------------------------------------------------------

Eth109/1/1         0          --           0           0           0          0

TDR is not supported on any interface on the Nexus 5000 and the message you see when you try it for FEX interfaces is misleading for sure.

View solution in original post

Highlighted
Beginner

N2K-C2248TP-1GE Fex and autonegotiation

Also according to release notes.

If you configure a Cisco  Nexus 2248TP port to 100 Mbps instead of autonegotiation,  autonegotiation does not occur, which is expected behavior. Both sides  of the link should be configured to both hardwired speed or both  autonegotiate.

no speed—Autonegotiates and advertises all speeds (only full duplex)

speed 1000—Autonegotiates only for a 802.3x pause

speed 100—Does not autonegotiate; pause cannot be  advertised. The peer must be set to not autonegotiate and fix at 100  Mbps (similar to the N2248TP)

For details, see CSCte81998.

View solution in original post

Highlighted
Enthusiast

N2K-C2248TP-1GE Fex and autonegotiation

ok, i understand now.

But still i feel the output is not consistent:

If a port is configure like

interface Ethernet125/1/12

  description SRV xxxxx S

  switchport access vlan 1000

  spanning-tree guard root

  speed 100

exit

the command: "sh run int Eth125/1/12 all"

should read:

speed 100

duplex full

(indicating, no auto-neg, only full supported)

and not

speed 100

duplex auto

(-> still suggesting that autonegotiation is used)

btw, an indication of autoneg in the "sh int eth125/1/20" would also be great :-)

sh int eth125/1/20

Ethernet125/1/20 is up

  Hardware: 100/1000 Ethernet, address: 0007.7daf.9f15 (bia 0007.7daf.9f15)

  Description: SRV xxxx S

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  Port mode is access

  a-f-dup, a-1000 Mb/s

(-> indicating autoneg is enabled and it has negotiated to the settings above)

instead of

Capabilities should also show


  Duplex:                full, auto

(instead of just full)

CreatePlease to create content