Showing results for 
Search instead for 
Did you mean: 

SM-SRE-910-K9 and SRE-V

Level 1
Level 1


before I get too epic let me ask, are there still downright SRE specialists around?

Problem: have SM-SRE-910-K9 with SRE-V /ESXi 5.0 on it, can't log in (have not the required root password), have no access to the installation files for a re-install. Any suggestions?

Consoled via Putty into the router, Alt-F1 to escape the DCUI not possible, Putty problem or simply not allowed to leave the DCUI?

Last Question: in status report, under the "resources info" there are no drives listed, albeit they can be seen under "boot diag" with no problems. Any idea why is that?

Any chance to get hold of further/more extensive documentation on the blade?

Thank you



27 Replies 27

Level 1
Level 1
Just to clarify - it is my own SRE in my own 2951 (home :-) ) router, Ebay-purchased...if you can help, you won't help me with illegal activities...

So you are trying to access SRE-V after purchasing on ebay, right? You'd better re-install the software ( ) , which BTW got stucked on 5.x vSphere version and then you can go unsupported but up to vSphere version 6.0 by manually cli vib upgrades.


thanks for caring to answer - yep, that's what I wanted to do. Of course I would like to re-install the SW but simply don't have it. But anyway, problem meanwhile solved, I managed to reset the password and have SRE-V working now. I'd like to do the upgrade, but am somewhat fearful it might get stuck again - never change a running system.

Thank you anyway,



I successfully managed to upgrade my SM 910 running SRE-V 2.0.2 all the way up to ESXi v6.5 Update 2, I tried v6.7 but it killed it so I am now re-installing it from scratch.


But I can confirm that it works perfectly with ESXi v6.5 Update 2, also I installed a pair of cheapo SSDs in it instead of the SATA300 5400RPM HDDs and did a single node vSAN which also works.


I have a pair of SM 910s in a Cisco 2951 in my home lab and the MGF internal connection is 4GBit so I am planning on trying to get a ROBO vSAN set up.

What sequence of commands did you use to update from the 5.1 in the 2.0.2 bundle? I've tried a few of the ESXCLI commands to update, but either get package incompatibility errors, or end up with a busted install if I overwrite the Cisco OEM profile :(


Finally, with reference to the SSD's, did you just replace both drives and reinstall the 2.0.2 bundle?

Thank you!

Got bored waiting...

So I've managed to get the SRE to ESXi 6.5 with a couple of caveats.

The command sequence is approximately this.

This works on the assumption you have:
    2.0.2 package accessible on an FTP server (server IP address of in this instance, running Xlight FTP server)
    downloaded the ESXi 5.5 and 6.5 most recent rollup bundles.

In brief, we're going 5.1 -> 5.5 -> 6.5
While technically you can jump 5.1 straight to 6.5 (installing the 5.5 patch in the middle without rebooting, I found I had issues with the 6.5 issues being able to access the datastores)

On the router console:
**we need this later once the Cisco specific VIBs are removed from VMWare to stop the router restarting the service module
service-module sm1/0 heartbeat-reset disable
**install Cisco Certified VMWare 5.1
service-module sm1/0 install url        
**choose -1 (nonraid) for the raid config or else the upgrade to 5.5 will fail (nb - haven't tried Raid0, but Raid1 definitely fails)
**once install has completed
service-module sm1/0 session
**log in using router credentials
**set root password (default is blank)
**access HTTPS://<ip of your VMware instance - in this case
**download/install VMware vSphere client for 5.1
**run vSphere client. Log in using IP address, root & password set above
**configuration -> storage -> upload ESX Bundle files (ESXi550-201809001 and ESXi650-201811002) to root of datastore1
**configuration -> security profile, properties on services, select SSH -> Options -> Start -> OK
SSH to vmware instance.
**remove problem SATA driver (nb if you have chosen RAID1, it'll fail on reboot as it now sees two disks with identical signatures)
esxcli software vib remove -n scsi-ptiahci
**do not reboot
**remove Cisco reset button tools (starts failing on 6.5 installation)
esxcli software vib remove -n char-reset-button
**do not reboote
**perform upgrade to 5.5
esxcli software vib install -d /vmfs/volumes/datastore1/
(either type reboot in SSH session or right click on IP in vSphere client & select reboot -> yes)
**access HTTPS://<ip of your VMware instance - in this case
**download/install VMware vSphere client for 5.5
**run vSphere client. Log in using IP address, root & password set earlier
**configuration -> storage -> 'Add Storage...' -> 'Disk/LUN' -> Next -> Choose top 'Local ATA Disk' -> Next -> Keep the existing signature -> Finish
**repeat above step for other ATA disks
**configuration -> security profile, properties on services, select SSH -> Options -> Start -> OK
SSH to vmware instance.
**perform upgrade to 6.5
esxcli software vib install -d /vmfs/volumes/datastore1/
(either type reboot in SSH session or right click on IP in vSphere client & select reboot -> yes)
**access HTTPS://<ip of your VMware instance) -> log in as root with password set earlier -> rejoice at ESXi 6.5 goodness

For reference, my SM1/0 is configured:

interface SM1/0
        ip unnumbered GigabitEthernet0/1
        service-module heartbeat-reset disable
        service-module ip address
        service-module ip default-gateway

And the gi0/1 port on the router:

interface GigabitEthernet0/1
        ip address
        duplex auto
        speed auto

The memory onboard appears to be of type 'PC2-5300P DDR2 667MHz ECC 2Rx4 VLP', those are a lot cheaper than the official part# SM-MEM-VLP-4GB
I've had no success swapping the drives for non-'approved' ones - even to the extent of doing a forensic copy onto another drive. evidently the check is implemented in the drive firmware
If anyone has a more recent SRE (en-140 or similar), I'd be most interested if you could export your Cisco VIBs to see if we can get the SRE-910's playing nicely under ESXi 6.5


Sorry for not replying sooner I am in the middle of changing jobs first day tomorrow at a prestigious firm in Canary Wharf London.


i removed both of the hard disks prior to the install and I used diskpart in a windows pc to clean them both for reuse elsewhere.


i Installed 2.0.2 from Cisco and then upgraded to 5.5 and removed the conflicting VIBs. I then upgraded to 6.5 U2 and once this was complete. I powered off and installed some old Samsung 840 SSDs which work perfectly.

Hello olobley,

as the OP I feel obliged to answer in order not to appear unpolite, although your post referenced Simon Sparks post and not mine...

Glad to hear everything worked out fine for you, and that's exactly what I would try myself, but I'm lacking exactly the package you mentioned in the "install url" (the sre-v-k9-r.SPA.smv.2.0.2.pkg), having no Cisco contract I have no way to get hold of that. So, I just dare not change the running old system, being unable to recreate the system should anything go wrong.

Thank you anyway for your informative and extensive presentation.

As you (or fellow posters in Canary Wharf; good luck!) can imagine, I'm, ahum, open for suggestions how to obtain aforementioned pkg...


PM me and I will help you get hold of the package files 

I loved my time in Canary Wharf. I used to work in a place in East Quay off Marsh Wall (I think it's since become a Hilton) before we moved stateside.


I actually didn't try pulling all the partitions off the disk, will do that next to see if it gets me any further. Were you able to get the disks to behave in RAID1, or are they JBOD?


@cisconaut- Given the bulk of the software (vmware 5.1) is effectively free (you only need a vmware account and they'll give you a basic license key), if you were to use a popular search engine, put in my forum ID and the filename (, you might find what you're looking for (don't use the baidu links)

You can download the package file for free from Cisco DevNet no Cisco login required.

Nice, where abouts in the devnet is that?

Hello olobley,

w.r.t. Simon's message: simple. Use the famous search engine with "devnet" and package name (Cisco DevNet, that did it for me, only the link to the package download is not functional, at least not for me.

I'll tried your proposition, found a magnet, but that leading to sites with funny character sets, so-to-say. Since my command of mandarin is quite so excellent, I'm stuck there again. 

I hope for the DevNet solution, if one of you lads has time to verify that the link works, please let me know.

Thank you, have a good time



Thanks, I didn't think to try the actual filename on DevNet.